aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-21 13:38:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-21 13:39:26 +0000
commit3bb6dd60eeac1b7982dfa049aa3696be006ef812 (patch)
treea965a8d78fb6feda1d76c6424bdd484853c52471
parentff08360a99f78745eaa6a05aa052cffe6080252a (diff)
downloadports-3bb6dd60eeac1b7982dfa049aa3696be006ef812.tar.gz
ports-3bb6dd60eeac1b7982dfa049aa3696be006ef812.zip
mail/evolution-ews: fix build
Backport upstream commit 6d8f7d3 which fixes compatibility with newer CMake Approved by: portmgr blanket
-rw-r--r--mail/evolution-ews/files/patch-cmake-modules-PrintableOptions.cmake70
1 files changed, 70 insertions, 0 deletions
diff --git a/mail/evolution-ews/files/patch-cmake-modules-PrintableOptions.cmake b/mail/evolution-ews/files/patch-cmake-modules-PrintableOptions.cmake
new file mode 100644
index 000000000000..f6d5534b7146
--- /dev/null
+++ b/mail/evolution-ews/files/patch-cmake-modules-PrintableOptions.cmake
@@ -0,0 +1,70 @@
+commit 6d8f7d303ec319539add2f0ba5331c2dab9d23c7
+Author: Milan Crha <mcrha@redhat.com>
+Date: Wed Apr 14 16:58:08 2021 +0200
+
+ PrintableOptions.cmake: Correct variable name comparison
+
+ CMake 3.20.1 errors out with:
+
+ CMake Error at cmake/modules/PrintableOptions.cmake:38 (message):
+ variable name cannot be empty
+ Call Stack (most recent call first):
+ CMakeLists.txt:152 (add_printable_variable)
+
+ Change how the parameter value is compared, to fix it.
+
+diff --git cmake/modules/PrintableOptions.cmake cmake/modules/PrintableOptions.cmake
+index ba1c9d0b..339f1da4 100644
+--- cmake/modules/PrintableOptions.cmake
++++ cmake/modules/PrintableOptions.cmake
+@@ -19,40 +19,40 @@
+ # prints all the build options previously added with the above functions
+
+ macro(add_printable_variable_bare _name)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ list(APPEND _printable_options ${_name})
+ endmacro()
+
+ macro(add_printable_option _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "option name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ option(${_name} ${_description} ${_default_value})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE STRING ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable_path _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "path variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE PATH ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable_filepath _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "filepath variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE FILEPATH ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()