aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-01-16 09:23:12 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-01-16 09:23:25 +0000
commit3bbd8494cddb03fe841ad150a4e8da7737e9d36b (patch)
tree411f68692978b62f1da52f3675919128e031bacd
parentb353f5daeeb0aff357b6af460050169838240e6a (diff)
downloadports-3bbd8494cddb03fe841ad150a4e8da7737e9d36b.tar.gz
ports-3bbd8494cddb03fe841ad150a4e8da7737e9d36b.zip
www/libnghttp2: Update to 1.51.0
* Switch to CMake * Modernize Makefile to follow Porters Handbook more closely Poudriere test run by bofh (thanks!) Changelog: https://github.com/nghttp2/nghttp2/releases/tag/v1.51.0 PR: 268536 Approved by: portmgr (maintainer timeout, 2+ weeks)
-rw-r--r--www/libnghttp2/Makefile16
-rw-r--r--www/libnghttp2/distinfo6
-rw-r--r--www/libnghttp2/files/patch-CMakeLists.txt20
-rw-r--r--www/libnghttp2/files/patch-Makefile.in21
-rw-r--r--www/libnghttp2/pkg-plist2
5 files changed, 33 insertions, 32 deletions
diff --git a/www/libnghttp2/Makefile b/www/libnghttp2/Makefile
index 7d1ec104d9f6..2f3c4983e106 100644
--- a/www/libnghttp2/Makefile
+++ b/www/libnghttp2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nghttp2
-PORTVERSION= 1.48.0
+DISTVERSION= 1.51.0
CATEGORIES= www net
-MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -11,12 +11,14 @@ WWW= https://nghttp2.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
+USES= cmake compiler:c++14-lang pathfix pkgconfig tar:xz
-CONFIGURE_ARGS= --enable-lib-only
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_CXXSTD= c++14
USE_LDCONFIG= yes
+CMAKE_OFF= ENABLE_DOC \
+ ENABLE_HTTP3 \
+ ENABLE_PYTHON_BINDINGS
+CMAKE_ON= ENABLE_LIB_ONLY \
+ ENABLE_STATIC_LIB
+
.include <bsd.port.mk>
diff --git a/www/libnghttp2/distinfo b/www/libnghttp2/distinfo
index b1c0da2a4659..5c28ff945e0e 100644
--- a/www/libnghttp2/distinfo
+++ b/www/libnghttp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1656092904
-SHA256 (nghttp2-1.48.0.tar.xz) = 47d8f30ee4f1bc621566d10362ca1b3ac83a335c63da7144947c806772d016e4
-SIZE (nghttp2-1.48.0.tar.xz) = 4112072
+TIMESTAMP = 1671868303
+SHA256 (nghttp2-1.51.0.tar.xz) = 66aa76d97c143f42295405a31413e5e7d157968dad9f957bb4b015b598882e6b
+SIZE (nghttp2-1.51.0.tar.xz) = 4115988
diff --git a/www/libnghttp2/files/patch-CMakeLists.txt b/www/libnghttp2/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9eb3864499c1
--- /dev/null
+++ b/www/libnghttp2/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2022-12-24 08:18:29 UTC
++++ CMakeLists.txt
+@@ -503,7 +503,7 @@ include_directories(
+ set(PKGDATADIR "${CMAKE_INSTALL_FULL_DATADIR}/${CMAKE_PROJECT_NAME}")
+ set(PKGLIBDIR "${CMAKE_INSTALL_FULL_LIBDIR}/${CMAKE_PROJECT_NAME}")
+
+-install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
++#install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
+
+ add_subdirectory(lib)
+ #add_subdirectory(lib/includes)
+@@ -519,7 +519,7 @@ if(ENABLE_DOC)
+ add_subdirectory(doc)
+ endif()
+ add_subdirectory(contrib)
+-add_subdirectory(script)
++#add_subdirectory(script)
+ add_subdirectory(bpf)
+
+
diff --git a/www/libnghttp2/files/patch-Makefile.in b/www/libnghttp2/files/patch-Makefile.in
deleted file mode 100644
index 03e06cc3f46b..000000000000
--- a/www/libnghttp2/files/patch-Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.in.orig 2021-09-21 13:09:49 UTC
-+++ Makefile.in
-@@ -461,8 +461,7 @@ top_srcdir = @top_srcdir@
- # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
- # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
- # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
--SUBDIRS = lib third-party src bpf examples python tests integration-tests \
-- doc contrib script
-+SUBDIRS = lib
-
-
- # Now with python setuptools, make uninstall will leave many files we
-@@ -470,7 +469,7 @@ SUBDIRS = lib third-party src bpf examples python test
- # distcheck rule.
- AM_DISTCHECK_CONFIGURE_FLAGS = --disable-python-bindings
- ACLOCAL_AMFLAGS = -I m4
--dist_doc_DATA = README.rst
-+dist_doc_DATA =
- EXTRA_DIST = nghttpx.conf.sample proxy.pac.sample android-config android-make \
- Dockerfile.android \
- cmakeconfig.h.in \
diff --git a/www/libnghttp2/pkg-plist b/www/libnghttp2/pkg-plist
index 7b377e7e7e4b..fc71897d44a1 100644
--- a/www/libnghttp2/pkg-plist
+++ b/www/libnghttp2/pkg-plist
@@ -3,5 +3,5 @@ include/nghttp2/nghttp2ver.h
lib/libnghttp2.a
lib/libnghttp2.so
lib/libnghttp2.so.14
-lib/libnghttp2.so.14.22.0
+lib/libnghttp2.so.14.24.1
libdata/pkgconfig/libnghttp2.pc