aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-09-22 02:54:35 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-09-22 02:54:54 +0000
commit3bd0bafed5ada28f970251fb42972f546b6e0b08 (patch)
tree5846bd7855ea8a938cb425fe6e374981d3fa819d
parentd951065cea0bd70b902bc25524f1ebcb4efd68ba (diff)
downloadports-3bd0bafed5ada28f970251fb42972f546b6e0b08.tar.gz
ports-3bd0bafed5ada28f970251fb42972f546b6e0b08.zip
x11/elementary-terminal: New port: Terminal emulator designed for elementary OS
-rw-r--r--x11/Makefile1
-rw-r--r--x11/elementary-terminal/Makefile26
-rw-r--r--x11/elementary-terminal/distinfo3
-rw-r--r--x11/elementary-terminal/pkg-descr5
-rw-r--r--x11/elementary-terminal/pkg-plist204
5 files changed, 239 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 72e0d3e5965c..60c7112f14af 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -58,6 +58,7 @@
SUBDIR += dzen2
SUBDIR += eaglemode
SUBDIR += editres
+ SUBDIR += elementary-terminal
SUBDIR += emprint
SUBDIR += erun
SUBDIR += eterm
diff --git a/x11/elementary-terminal/Makefile b/x11/elementary-terminal/Makefile
new file mode 100644
index 000000000000..fa8a0017f8e6
--- /dev/null
+++ b/x11/elementary-terminal/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= terminal
+DISTVERSION= 6.0.0
+CATEGORIES= x11
+PKGNAMEPREFIX= elementary-
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= Terminal emulator designed for elementary OS
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= valac:lang/vala
+LIB_DEPENDS= libgee-0.8.so:devel/libgee \
+ libgranite.so:x11-toolkits/granite \
+ libhandy-1.so:x11-toolkits/libhandy \
+ libpcre2-posix.so:devel/pcre2 \
+ libvte-2.91.so:x11-toolkits/vte3
+
+USES= desktop-file-utils gettext gnome meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= elementary
+USE_GNOME= glib20 gtk30
+GLIB_SCHEMAS= io.elementary.terminal.gschema.xml
+INSTALLS_ICONS= yes
+
+.include <bsd.port.mk>
diff --git a/x11/elementary-terminal/distinfo b/x11/elementary-terminal/distinfo
new file mode 100644
index 000000000000..60da6fd3baf9
--- /dev/null
+++ b/x11/elementary-terminal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632278975
+SHA256 (elementary-terminal-6.0.0_GH0.tar.gz) = 394b17a7705a735d6a4876984a0cbf93f05c8e0b4d772d2ab366573d33777810
+SIZE (elementary-terminal-6.0.0_GH0.tar.gz) = 846484
diff --git a/x11/elementary-terminal/pkg-descr b/x11/elementary-terminal/pkg-descr
new file mode 100644
index 000000000000..a9f30ee43811
--- /dev/null
+++ b/x11/elementary-terminal/pkg-descr
@@ -0,0 +1,5 @@
+A super lightweight, beautiful, and simple terminal. Comes with sane defaults,
+browser-class tabs, sudo paste protection, smart copy/paste, and little to no
+configuration.
+
+WWW: https://github.com/elementary/terminal
diff --git a/x11/elementary-terminal/pkg-plist b/x11/elementary-terminal/pkg-plist
new file mode 100644
index 000000000000..a2c608ff73b9
--- /dev/null
+++ b/x11/elementary-terminal/pkg-plist
@@ -0,0 +1,204 @@
+bin/io.elementary.terminal
+share/applications/io.elementary.terminal.desktop
+share/applications/open-pantheon-terminal-here.desktop
+share/fish/vendor_conf.d/pantheon_terminal_process_completion_notifications.fish
+share/io.elementary.terminal/enable-zsh-completion-notifications
+share/locale/aa/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ab/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ae/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/af/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ak/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/am/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/an/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ar/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/as/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ast/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/av/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ay/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/az/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ba/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/be/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/bg/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/bh/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/bi/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/bm/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/bn/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/bo/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/br/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/bs/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ca/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ce/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ch/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ckb/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/co/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/cr/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/cs/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/cu/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/cv/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/cy/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/da/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/de/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/dv/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/dz/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ee/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/el/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/en_AU/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/en_CA/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/en_GB/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/eo/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/es/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/et/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/eu/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/fa/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ff/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/fi/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/fj/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/fo/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/fr/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/fr_CA/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/fy/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ga/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/gd/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/gl/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/gn/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/gu/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/gv/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ha/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/he/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/hi/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ho/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/hr/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ht/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/hu/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/hy/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/hz/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ia/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/id/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ie/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ig/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ii/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ik/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/io/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/is/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/it/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/iu/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ja/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/jv/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ka/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/kg/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ki/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/kj/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/kk/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/kl/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/km/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/kn/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ko/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/kr/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ks/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ku/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/kv/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/kw/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ky/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/la/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/lb/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/lg/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/li/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ln/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/lo/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/lt/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/lu/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/lv/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/mg/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/mh/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/mi/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/mk/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ml/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/mn/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/mr/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ms/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/mt/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/my/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/na/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/nb/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/nd/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ne/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ng/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/nl/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/nn/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/no/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/nr/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/nv/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ny/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/oc/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/oj/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/om/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/or/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/os/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/pa/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/pi/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/pl/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ps/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/pt/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/pt_BR/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/qu/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/rm/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/rn/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ro/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ro_MD/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ru/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/rue/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/rw/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sa/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sc/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sd/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/se/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sg/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/si/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sk/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sl/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sm/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sma/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sn/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/so/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sq/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sr/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ss/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/st/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/su/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sv/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/sw/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/szl/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ta/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/te/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/tg/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/th/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ti/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/tk/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/tl/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/tlh/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/tn/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/to/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/tr/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ts/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/tt/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/tw/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ty/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ug/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/uk/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ur/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/uz/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/ve/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/vi/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/vo/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/wa/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/wo/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/xh/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/yi/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/yo/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/za/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/zh/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/zh_CN/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/zh_HK/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/zh_TW/LC_MESSAGES/io.elementary.terminal.mo
+share/locale/zu/LC_MESSAGES/io.elementary.terminal.mo
+share/metainfo/io.elementary.terminal.appdata.xml