aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:21:08 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:58:48 +0000
commit3de77140327dc3ab3801f30ca226a4e295a9d7fe (patch)
tree2062aec53d6a0b6ee99738be23dd067a7936d760
parentdb1c3e41b3c8a385b20e47875739c679a56846fe (diff)
downloadports-3de77140327dc3ab3801f30ca226a4e295a9d7fe.tar.gz
ports-3de77140327dc3ab3801f30ca226a4e295a9d7fe.zip
science/py-asdf-unit-schemas: Add py-asdf-unit-schemas 0.1.0
asdf-unit-schemas provides ASDF schemas for validating unit tags. Users should not need to install this directly; instead, install an implementation package such as asdf-astropy, which includes asdf-unit-schemas as a dependency.
-rw-r--r--science/Makefile1
-rw-r--r--science/py-asdf-unit-schemas/Makefile31
-rw-r--r--science/py-asdf-unit-schemas/distinfo3
-rw-r--r--science/py-asdf-unit-schemas/files/setup.py48
-rw-r--r--science/py-asdf-unit-schemas/pkg-descr3
5 files changed, 86 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index d9f958844f24..fd813b9d88e6 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -298,6 +298,7 @@
SUBDIR += py-asdf
SUBDIR += py-asdf-standard
SUBDIR += py-asdf-transform-schemas
+ SUBDIR += py-asdf-unit-schemas
SUBDIR += py-ase
SUBDIR += py-atomium
SUBDIR += py-avogadrolibs
diff --git a/science/py-asdf-unit-schemas/Makefile b/science/py-asdf-unit-schemas/Makefile
new file mode 100644
index 000000000000..c1d3b141bb6b
--- /dev/null
+++ b/science/py-asdf-unit-schemas/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= asdf-unit-schemas
+PORTVERSION= 0.1.0
+CATEGORIES= science python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= asdf_unit_schemas-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= ASDF schemas for units
+WWW= https://github.com/asdf-format/asdf-unit-schemas
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asdf-standard>=1.0.1:science/py-asdf-standard@${PY_FLAVOR}
+
+USES= python:3.8+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30900
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=3:devel/py-importlib-resources@${PY_FLAVOR}
+.endif
+
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
+.include <bsd.port.post.mk>
diff --git a/science/py-asdf-unit-schemas/distinfo b/science/py-asdf-unit-schemas/distinfo
new file mode 100644
index 000000000000..a6791fc132bf
--- /dev/null
+++ b/science/py-asdf-unit-schemas/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674588062
+SHA256 (asdf_unit_schemas-0.1.0.tar.gz) = 42b78d67213efe4ffd4529fb0e58d9c7a0dab5cbf8839b230f1bc0a446bff999
+SIZE (asdf_unit_schemas-0.1.0.tar.gz) = 50607
diff --git a/science/py-asdf-unit-schemas/files/setup.py b/science/py-asdf-unit-schemas/files/setup.py
new file mode 100644
index 000000000000..6a6a4fa69815
--- /dev/null
+++ b/science/py-asdf-unit-schemas/files/setup.py
@@ -0,0 +1,48 @@
+#!/usr/bin/env python
+# setup.py generated by flit for tools that don't yet use PEP 517
+
+from distutils.core import setup
+
+packages = \
+['asdf_unit_schemas']
+
+package_data = \
+{'': ['*']}
+
+package_dir = \
+{'': 'src'}
+
+install_requires = \
+['asdf-standard >= 1.0.1']
+
+extras_require = \
+{':python_version<"3.9"': ['importlib_resources >= 3'],
+ 'docs': ['tomli',
+ 'sphinx',
+ 'sphinx-asdf >= 0.1.3',
+ 'sphinx-astropy',
+ 'astropy >= 5.0.4',
+ 'graphviz',
+ 'matplotlib',
+ 'docutils',
+ 'sphinx-rtd-theme'],
+ 'test': ['asdf >= 2.8.0', 'asdf-astropy', 'scipy', 'pytest']}
+
+entry_points = \
+{'asdf.resource_mappings': ['asdf_unit_schemas = '
+ 'asdf_unit_schemas.integration:get_resource_mappings']}
+
+setup(name='asdf_unit_schemas',
+ version='%%PORTVERSION%%',
+ description='ASDF schemas for units',
+ author=None,
+ author_email='The ASDF Developers <help@stsci.edu>',
+ url=None,
+ packages=packages,
+ package_data=package_data,
+ package_dir=package_dir,
+ install_requires=install_requires,
+ extras_require=extras_require,
+ entry_points=entry_points,
+ python_requires='>=3.8',
+ )
diff --git a/science/py-asdf-unit-schemas/pkg-descr b/science/py-asdf-unit-schemas/pkg-descr
new file mode 100644
index 000000000000..ea73cd3a77df
--- /dev/null
+++ b/science/py-asdf-unit-schemas/pkg-descr
@@ -0,0 +1,3 @@
+asdf-unit-schemas provides ASDF schemas for validating unit tags. Users should
+not need to install this directly; instead, install an implementation package
+such as asdf-astropy, which includes asdf-unit-schemas as a dependency.