aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2019-02-12 11:19:54 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2019-02-12 11:19:54 +0000
commit3e035751fad0d3fae9a0db0252539a4fc7e8379b (patch)
tree5f0d7988b5d40494c141aba2a902a067d5dcc500
parent6e2226668651a3313ef5560bd641be82b8f98b8b (diff)
downloadports-3e035751fad0d3fae9a0db0252539a4fc7e8379b.tar.gz
ports-3e035751fad0d3fae9a0db0252539a4fc7e8379b.zip
Update devel/{ice37|php-ice37|py-ice37} to v3.7.2
Notes
Notes: svn path=/head/; revision=492774
-rw-r--r--devel/ice37/Makefile3
-rw-r--r--devel/ice37/distinfo6
-rw-r--r--devel/ice37/files/patch-cpp-test-Glacier2-ssl-Server.cpp2
-rw-r--r--devel/ice37/files/patch-cpp-test-include-TestHelper.h (renamed from devel/ice37/files/patch-cpp-test-include-TestCommon.h)14
-rw-r--r--devel/ice37/files/patch-python-test-Ice-info-AllTests.py6
-rw-r--r--devel/ice37/files/patch-scripts-Util.py71
-rw-r--r--devel/ice37/pkg-plist42
7 files changed, 64 insertions, 80 deletions
diff --git a/devel/ice37/Makefile b/devel/ice37/Makefile
index 77088ac6d845..89f71e403abb 100644
--- a/devel/ice37/Makefile
+++ b/devel/ice37/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= Ice
-PORTVERSION= 3.7.1
-PORTREVISION= 1
+PORTVERSION= 3.7.2
DISTVERSIONPREFIX= v
CATEGORIES= devel
PKGNAMESUFFIX?= 37
diff --git a/devel/ice37/distinfo b/devel/ice37/distinfo
index 0ccdf42b7f30..a64a426f837d 100644
--- a/devel/ice37/distinfo
+++ b/devel/ice37/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534213743
-SHA256 (zeroc-ice-ice-v3.7.1_GH0.tar.gz) = b1526ab9ba80a3d5f314dacf22674dff005efb9866774903d0efca5a0fab326d
-SIZE (zeroc-ice-ice-v3.7.1_GH0.tar.gz) = 8765196
+TIMESTAMP = 1549889745
+SHA256 (zeroc-ice-ice-v3.7.2_GH0.tar.gz) = e329a24abf94a4772a58a0fe61af4e707743a272c854552eef3d7833099f40f9
+SIZE (zeroc-ice-ice-v3.7.2_GH0.tar.gz) = 9427121
diff --git a/devel/ice37/files/patch-cpp-test-Glacier2-ssl-Server.cpp b/devel/ice37/files/patch-cpp-test-Glacier2-ssl-Server.cpp
index 67db9e7dab60..0c3fc64ae6b6 100644
--- a/devel/ice37/files/patch-cpp-test-Glacier2-ssl-Server.cpp
+++ b/devel/ice37/files/patch-cpp-test-Glacier2-ssl-Server.cpp
@@ -20,6 +20,6 @@
- test(info.localHost == "127.0.0.1");
+ test(info.remoteHost == "127.0.0.1" || inFreeBSDJail());
+ test(info.localHost == "127.0.0.1" || inFreeBSDJail());
- test(info.localPort == getTestPort(current.adapter->getCommunicator()->getProperties(), 1));
+ test(info.localPort == TestHelper::getTestPort(current.adapter->getCommunicator()->getProperties(), 1));
try
diff --git a/devel/ice37/files/patch-cpp-test-include-TestCommon.h b/devel/ice37/files/patch-cpp-test-include-TestHelper.h
index 8dd83ddc21d5..3ccbef2f6a7a 100644
--- a/devel/ice37/files/patch-cpp-test-include-TestCommon.h
+++ b/devel/ice37/files/patch-cpp-test-include-TestHelper.h
@@ -1,8 +1,8 @@
---- cpp/test/include/TestCommon.h.orig 2018-04-20 15:02:08 UTC
-+++ cpp/test/include/TestCommon.h
-@@ -38,6 +38,22 @@
- # endif
- #endif
+--- cpp/test/include/TestHelper.h.orig 2019-02-11 14:02:41.681160000 +0100
++++ cpp/test/include/TestHelper.h 2019-02-11 16:04:38.557681000 +0100
+@@ -199,4 +199,20 @@
+
+ #define test(ex) ((ex) ? ((void)0) : ::Test::testFailed(#ex, __FILE__, __LINE__))
+#if defined(__FreeBSD__)
+extern "C" { int sysctlbyname(const char *name, void *oldp, size_t *oldlenp,
@@ -20,6 +20,4 @@
+}
+#endif
+
- void
- inline print(const std::string& msg)
- {
+ #endif
diff --git a/devel/ice37/files/patch-python-test-Ice-info-AllTests.py b/devel/ice37/files/patch-python-test-Ice-info-AllTests.py
index 6da02f410e6a..bb36c22792b6 100644
--- a/devel/ice37/files/patch-python-test-Ice-info-AllTests.py
+++ b/devel/ice37/files/patch-python-test-Ice-info-AllTests.py
@@ -34,12 +34,12 @@
while(info):
if isinstance(info, Ice.TCPEndpointInfo):
@@ -119,7 +138,7 @@ def allTests(communicator):
- test(tcpEndpoint.port == 12020)
+ test(tcpEndpoint.port == 15000)
tcpEndpoint = getTCPEndpointInfo(publishedEndpoints[0].getInfo())
- test(tcpEndpoint.host == "127.0.0.1")
+ test(tcpEndpoint.host == "127.0.0.1" or isFreeBSDJail())
- test(tcpEndpoint.port == 12020)
+ test(tcpEndpoint.port == 15000)
adapter.destroy()
@@ -137,7 +156,7 @@ def allTests(communicator):
@@ -54,7 +54,7 @@
@@ -147,7 +166,7 @@ def allTests(communicator):
udp = base.ice_datagram().ice_getConnection().getEndpoint().getInfo()
- test(udp.port == 12010)
+ test(udp.port == port)
- test(udp.host == defaultHost)
+ test(udp.host == defaultHost or isFreeBSDJail())
diff --git a/devel/ice37/files/patch-scripts-Util.py b/devel/ice37/files/patch-scripts-Util.py
index f149c7f00d9a..c0a047a7fde9 100644
--- a/devel/ice37/files/patch-scripts-Util.py
+++ b/devel/ice37/files/patch-scripts-Util.py
@@ -1,48 +1,29 @@
---- scripts/Util.py.orig 2018-08-27 01:10:47 UTC
-+++ scripts/Util.py
-@@ -82,7 +82,7 @@ class Platform:
+--- scripts/Util.py.orig 2019-02-11 16:48:19.076747000 +0100
++++ scripts/Util.py 2019-02-11 19:16:32.768690000 +0100
+@@ -232,7 +232,7 @@
+ elif Mapping.getByName("cpp"):
+ cwd = Mapping.getByName("cpp").getPath()
- def parseBuildVariables(self, variables):
- # Run make to get the values of the given variables
-- output = run('make print V="{0}"'.format(" ".join(variables.keys())), cwd = toplevel)
-+ output = run('gmake print V="{0}"'.format(" ".join(variables.keys())), cwd = toplevel)
+- output = run('make print V="{0}"'.format(" ".join(variables.keys())), cwd=cwd)
++ output = run('gmake print V="{0}"'.format(" ".join(variables.keys())), cwd=cwd)
for l in output.split("\n"):
match = re.match(r'^.*:.*: (.*) = (.*)', l)
if match and match.group(1):
-@@ -199,6 +199,46 @@ class AIX(Platform):
+@@ -304,6 +304,27 @@
def hasOpenSSL(self):
return True
+class FreeBSD(Platform):
+
+ def __init__(self):
-+ Platform.__init__(self)
-+
-+ def getFilters(self, config):
-+ filters = Platform.getFilters(self, config)
-+ #filters = (filters[0], filters[1] + ["Slice/*"])
-+ return filters
++ self.nugetPackageCache = None
+
+ def hasOpenSSL(self):
+ return True
+
-+ def getBinSubDir(self, mapping, process, current):
-+ buildPlatform = current.driver.configs[mapping].buildPlatform
-+ return "bin"
-+
-+ def getLibSubDir(self, mapping, process, current):
-+ buildPlatform = current.driver.configs[mapping].buildPlatform
-+
-+ # PHP module is always installed in the lib directory for the default build platform
-+ if isinstance(mapping, PhpMapping) and buildPlatform == self.getDefaultBuildPlatform():
-+ return "lib"
-+ return "lib"
-+
-+ def getBuildSubDir(self, name, current):
-+ return os.path.join("build", current.config.buildPlatform, current.config.buildConfig)
-+
+ def getSliceDir(self, iceDir):
-+ return os.path.join(iceDir, "slice")
++ installDir = self.getInstallDir(mapping, current)
++ return os.path.join(installDir, "slice")
+
+ def getDefaultExe(self, name, config):
+ if name == "icebox":
@@ -56,7 +37,24 @@
class Linux(Platform):
def __init__(self):
-@@ -434,6 +474,8 @@ if sys.platform == "darwin":
+@@ -1374,13 +1402,13 @@
+ if os.path.exists(translator):
+ return translator + " " + args if args else translator
+ elif isinstance(platform, Windows):
+- return os.path.join(os.path.dirname(sys.executable), "Scripts", "slice2py.exe")
++ return os.path.join(os.path.dirname(sys.executable), "Scripts", "slice2py.exe") + " " + args if args else translator
+ elif os.path.exists("/usr/local/bin/slice2py"):
+- return "/usr/local/bin/slice2py"
++ return "/usr/local/bin/slice2py" + " " + args if args else translator
+ else:
+ import slice2py
+ return sys.executable + " " + os.path.normpath(
+- os.path.join(slice2py.__file__, "..", "..", "..", "..", "bin", "slice2py"))
++ os.path.join(slice2py.__file__, "..", "..", "..", "..", "bin", "slice2py")) + " " + args if args else translator
+ else:
+ return Process.getCommandLine(self, current, args)
+
+@@ -3786,6 +3807,8 @@
platform = Darwin()
elif sys.platform.startswith("aix"):
platform = AIX()
@@ -65,14 +63,3 @@
elif sys.platform.startswith("linux") or sys.platform.startswith("gnukfreebsd"):
platform = Linux()
elif sys.platform == "win32" or sys.platform[:6] == "cygwin":
-@@ -1333,8 +1375,8 @@ class SliceTranslator(ProcessFromBinDir,
- return translator + " " + args if args else translator
- elif isinstance(platform, Windows):
- return os.path.join(os.path.dirname(sys.executable), "Scripts", "slice2py.exe")
-- elif os.path.exists("/usr/local/bin/slice2py"):
-- return "/usr/local/bin/slice2py"
-+ elif os.path.exists("%%LOCALBASE%%/bin/slice2py"):
-+ return "%%LOCALBASE%%/bin/slice2py " + args if args else "%%LOCALBASE%%/bin/slice2py "
- else:
- import slice2py
- return sys.executable + " " + os.path.normpath(
diff --git a/devel/ice37/pkg-plist b/devel/ice37/pkg-plist
index a14680e2e800..7d2cbf0cc540 100644
--- a/devel/ice37/pkg-plist
+++ b/devel/ice37/pkg-plist
@@ -219,79 +219,79 @@ include/IceUtil/UUID.h
include/IceUtil/UndefSysMacros.h
%%STATIC%%lib/libGlacier2++11.a
lib/libGlacier2++11.so
-lib/libGlacier2++11.so.3.7.1
+lib/libGlacier2++11.so.3.7.2
lib/libGlacier2++11.so.37
%%STATIC%%lib/libGlacier2.a
lib/libGlacier2.so
-lib/libGlacier2.so.3.7.1
+lib/libGlacier2.so.3.7.2
lib/libGlacier2.so.37
-lib/libGlacier2CryptPermissionsVerifier.so.3.7.1
+lib/libGlacier2CryptPermissionsVerifier.so.3.7.2
lib/libGlacier2CryptPermissionsVerifier.so.37
%%STATIC%%lib/libIce++11.a
lib/libIce++11.so
-lib/libIce++11.so.3.7.1
+lib/libIce++11.so.3.7.2
lib/libIce++11.so.37
%%STATIC%%lib/libIce.a
lib/libIce.so
-lib/libIce.so.3.7.1
+lib/libIce.so.3.7.2
lib/libIce.so.37
%%STATIC%%lib/libIceBox++11.a
lib/libIceBox++11.so
-lib/libIceBox++11.so.3.7.1
+lib/libIceBox++11.so.3.7.2
lib/libIceBox++11.so.37
%%STATIC%%lib/libIceBox.a
lib/libIceBox.so
-lib/libIceBox.so.3.7.1
+lib/libIceBox.so.3.7.2
lib/libIceBox.so.37
-lib/libIceDB.so.3.7.1
+lib/libIceDB.so.3.7.2
lib/libIceDB.so.37
%%STATIC%%lib/libIceDiscovery++11.a
lib/libIceDiscovery++11.so
-lib/libIceDiscovery++11.so.3.7.1
+lib/libIceDiscovery++11.so.3.7.2
lib/libIceDiscovery++11.so.37
%%STATIC%%lib/libIceDiscovery.a
lib/libIceDiscovery.so
-lib/libIceDiscovery.so.3.7.1
+lib/libIceDiscovery.so.3.7.2
lib/libIceDiscovery.so.37
%%STATIC%%lib/libIceGrid++11.a
lib/libIceGrid++11.so
-lib/libIceGrid++11.so.3.7.1
+lib/libIceGrid++11.so.3.7.2
lib/libIceGrid++11.so.37
%%STATIC%%lib/libIceGrid.a
lib/libIceGrid.so
-lib/libIceGrid.so.3.7.1
+lib/libIceGrid.so.3.7.2
lib/libIceGrid.so.37
%%STATIC%%lib/libIceLocatorDiscovery++11.a
lib/libIceLocatorDiscovery++11.so
-lib/libIceLocatorDiscovery++11.so.3.7.1
+lib/libIceLocatorDiscovery++11.so.3.7.2
lib/libIceLocatorDiscovery++11.so.37
%%STATIC%%lib/libIceLocatorDiscovery.a
lib/libIceLocatorDiscovery.so
-lib/libIceLocatorDiscovery.so.3.7.1
+lib/libIceLocatorDiscovery.so.3.7.2
lib/libIceLocatorDiscovery.so.37
%%STATIC%%lib/libIcePatch2.a
lib/libIcePatch2.so
-lib/libIcePatch2.so.3.7.1
+lib/libIcePatch2.so.3.7.2
lib/libIcePatch2.so.37
%%STATIC%%lib/libIceSSL++11.a
lib/libIceSSL++11.so
-lib/libIceSSL++11.so.3.7.1
+lib/libIceSSL++11.so.3.7.2
lib/libIceSSL++11.so.37
%%STATIC%%lib/libIceSSL.a
lib/libIceSSL.so
-lib/libIceSSL.so.3.7.1
+lib/libIceSSL.so.3.7.2
lib/libIceSSL.so.37
%%STATIC%%lib/libIceStorm++11.a
lib/libIceStorm++11.so
-lib/libIceStorm++11.so.3.7.1
+lib/libIceStorm++11.so.3.7.2
lib/libIceStorm++11.so.37
%%STATIC%%lib/libIceStorm.a
lib/libIceStorm.so
-lib/libIceStorm.so.3.7.1
+lib/libIceStorm.so.3.7.2
lib/libIceStorm.so.37
-lib/libIceStormService.so.3.7.1
+lib/libIceStormService.so.3.7.2
lib/libIceStormService.so.37
-lib/libIceXML.so.3.7.1
+lib/libIceXML.so.3.7.2
lib/libIceXML.so.37
man/man1/glacier2router.1.gz
man/man1/icebox.1.gz