aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Hutchinson <portmaster@bsdforge.com>2022-05-19 15:41:47 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2022-05-19 15:55:04 +0000
commit3e3839f529db8ad92e799e5225b0de3b291740ff (patch)
treee27556576d7150225cf284a3a1e72ed381257d1b
parent2782e67ab128b28ad76603d9bfda1436989a7f1d (diff)
downloadports-3e3839f529db8ad92e799e5225b0de3b291740ff.tar.gz
ports-3e3839f529db8ad92e799e5225b0de3b291740ff.zip
shells/rc: switch to GitHub
Minor modifications to submitter's patch: - Bump PORTREVISION since new tarball differs from the old one despite both indicate the same version 1.7.4. PR: 263631 Approved by: maintainer timeout
-rw-r--r--shells/rc/Makefile8
-rw-r--r--shells/rc/distinfo7
-rw-r--r--shells/rc/files/patch-Makefile.am15
-rw-r--r--shells/rc/files/patch-Makefile.in17
-rw-r--r--shells/rc/pkg-descr2
5 files changed, 25 insertions, 24 deletions
diff --git a/shells/rc/Makefile b/shells/rc/Makefile
index 2757f1d20170..ffec66d98e2b 100644
--- a/shells/rc/Makefile
+++ b/shells/rc/Makefile
@@ -2,9 +2,9 @@
PORTNAME= rc
PORTVERSION= 1.7.4
-PORTREVISION= 2
+PORTREVISION= 3
+DISTVERSIONPREFIX=v
CATEGORIES= shells plan9
-MASTER_SITES= http://static.tobold.org/rc/
MAINTAINER= quanstro@quanstro.net
COMMENT= Unix incarnation of the plan9 shell
@@ -12,7 +12,9 @@ COMMENT= Unix incarnation of the plan9 shell
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cpe
+USES= autoreconf cpe
+USE_GITHUB= yes
+GH_ACCOUNT= rakitzis
CPE_VENDOR= ${PORTNAME}_project
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-history
diff --git a/shells/rc/distinfo b/shells/rc/distinfo
index 997830479f60..9bec171b17e0 100644
--- a/shells/rc/distinfo
+++ b/shells/rc/distinfo
@@ -1,3 +1,4 @@
-TIMESTAMP = 1495848718
-SHA256 (rc-1.7.4.tar.gz) = 5ed26334dd0c1a616248b15ad7c90ca678ae3066fa02c5ddd0e6936f9af9bfd8
-SIZE (rc-1.7.4.tar.gz) = 215206
+TIMESTAMP = 1651156140
+SHA256 (rakitzis-rc-v1.7.4_GH0.tar.gz) = 0b83f8698dd8ef44ca97b25c4748c087133f53c7fff39b6b70dab65931def8b0
+SHA512 (rakitzis-rc-v1.7.4_GH0.tar.gz) = d5290faf24511f5e687534cb59d6d6c0522c3d95921b04227b9a0814bdfa8b979c1197d020842060cc655859e4f584c6608d0547b499e9dcb8cb12d262644f0a
+SIZE (rakitzis-rc-v1.7.4_GH0.tar.gz) = 134186
diff --git a/shells/rc/files/patch-Makefile.am b/shells/rc/files/patch-Makefile.am
new file mode 100644
index 000000000000..29c867c3a301
--- /dev/null
+++ b/shells/rc/files/patch-Makefile.am
@@ -0,0 +1,15 @@
+--- Makefile.am.orig 2022-04-28 07:43:21.167704000 -0700
++++ Makefile.am 2022-04-28 07:47:55.514536000 -0700
+@@ -64,8 +64,8 @@
+
+ install-exec-hook:
+ if AMC_HISTORY
+- $(INSTALL_PROGRAM) history $(bindir)/- ;\
+- rm -f $(bindir)/--; $(LN) $(bindir)/- $(bindir)/-- ;\
+- rm -f $(bindir)/-p; $(LN) $(bindir)/- $(bindir)/-p ;\
+- rm -f $(bindir)/--p; $(LN) $(bindir)/- $(bindir)/--p
++ $(INSTALL_PROGRAM) history $(DESTDIR)$(bindir)/- ;\
++ rm -f $(bindir)/--; $(LN) $(DESTDIR)$(bindir)/- $(DESTDIR)$(bindir)/-- ;\
++ rm -f $(bindir)/-p; $(LN) $(DESTDIR)$(bindir)/- $(DESTDIR)$(bindir)/-p ;\
++ rm -f $(bindir)/--p; $(LN) $(DESTDIR)$(bindir)/- $(DESTDIR)$(bindir)/--p
+ endif
diff --git a/shells/rc/files/patch-Makefile.in b/shells/rc/files/patch-Makefile.in
deleted file mode 100644
index f9ebb236f4ac..000000000000
--- a/shells/rc/files/patch-Makefile.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile.in.orig 2017-05-27 01:41:41 UTC
-+++ Makefile.in
-@@ -945,10 +945,10 @@ trip: rc tripping
- ./rc -p < $(srcdir)/trip.rc
-
- install-exec-hook:
--@AMC_HISTORY_TRUE@ $(INSTALL_PROGRAM) history $(bindir)/- ;\
--@AMC_HISTORY_TRUE@ rm -f $(bindir)/--; $(LN) $(bindir)/- $(bindir)/-- ;\
--@AMC_HISTORY_TRUE@ rm -f $(bindir)/-p; $(LN) $(bindir)/- $(bindir)/-p ;\
--@AMC_HISTORY_TRUE@ rm -f $(bindir)/--p; $(LN) $(bindir)/- $(bindir)/--p
-+@AMC_HISTORY_TRUE@ $(INSTALL_PROGRAM) history $(DESTDIR)$(bindir)/- ;\
-+@AMC_HISTORY_TRUE@ rm -f $(DESTDIR)$(bindir)/--; $(LN) $(DESTDIR)$(bindir)/- $(DESTDIR)$(bindir)/-- ;\
-+@AMC_HISTORY_TRUE@ rm -f $(DESTDIR)$(bindir)/-p; $(LN) $(DESTDIR)$(bindir)/- $(DESTDIR)$(bindir)/-p ;\
-+@AMC_HISTORY_TRUE@ rm -f $(DESTDIR)$(bindir)/--p; $(LN) $(DESTDIR)$(bindir)/- $(DESTDIR)$(bindir)/--p
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/shells/rc/pkg-descr b/shells/rc/pkg-descr
index bf8b865c0a7f..d3f496a9175a 100644
--- a/shells/rc/pkg-descr
+++ b/shells/rc/pkg-descr
@@ -5,4 +5,4 @@ cleaner and simpler syntax. Among other things, this makes rc much better than
Bourne-compatible shells at handling filenames which contain spaces. Thus,
writing rc scripts is less error-prone than writing sh scripts.
-WWW: http://tobold.org/article/rc
+WWW: https://github.com/rakitzis/rc