aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2023-03-23 21:34:55 +0000
committerCraig Leres <leres@FreeBSD.org>2023-03-23 21:34:55 +0000
commit3ef98eb228bbf3b4003df96fbe287a634afeb3b6 (patch)
treed68596e4a63af375ef467852b7e7a1231946cd9f
parent1eceef346fc9ca82892ff08d5c77c8ef6f6dc297 (diff)
downloadports-3ef98eb228bbf3b4003df96fbe287a634afeb3b6.tar.gz
ports-3ef98eb228bbf3b4003df96fbe287a634afeb3b6.zip
devel/p4: Update to r22.2.2407422
Remove BROKEN lines (this version is 7 years newer). Documentation is only in html form online now. PR: 270420 Approved by: antonfb@hesiod.org (maintainer)
-rw-r--r--devel/p4api/Makefile36
-rw-r--r--devel/p4api/distinfo8
-rw-r--r--devel/p4api/pkg-descr2
-rw-r--r--devel/p4api/pkg-plist25
4 files changed, 41 insertions, 30 deletions
diff --git a/devel/p4api/Makefile b/devel/p4api/Makefile
index 74f930313769..3cb2963f3d19 100644
--- a/devel/p4api/Makefile
+++ b/devel/p4api/Makefile
@@ -2,47 +2,41 @@ PORTNAME= p4api
PORTVERSION= ${YEAR}.${MAJOR}.${MINOR}
PORTREVISION= 1
CATEGORIES= devel
-# Perforce changes their distfiles when they patch, which changes the
-# zip file's checksum. This does not play well with FreeBSD's conventions.
-# Also, this port is for 2016.1 which no longer is available from Perforce's
-# sites. The new maintainer will backup host until the new 2022.2 port is ready.
-MASTER_SITES= LOCAL/asomers/perforce/p4:zip \
- https://hesiod.org/distfiles/
-DIST_SUBDIR= perforce/p4
-DISTNAME= ${YEAR}-${MAJOR}
-DISTFILES= ${ZIP_FILES}:zip p4api.pdf:pdf
-EXTRACT_ONLY= ${ZIP_FILES}
+# Perforce does not version their distfiles when they patch.
+# This does not play well with FreeBSD's conventions.
+MASTER_SITES= https://ftp.perforce.com/perforce/${P4VERSION}/bin.tools/p4source${EXTRACT_SUFX}?dummy=/ \
+ https://hesiod.org/distfiles/perforce-${MINOR}/p4source${EXTRACT_SUFX}?dummy=/
+DISTNAME= p4source-${MINOR}
MAINTAINER= antonfb@hesiod.org
COMMENT= Perforce API (static libraries and header files)
-WWW= http://www.perforce.com/perforce/loadsupp.html
+WWW= https://www.perforce.com/products/helix-core
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_12_powerpc64= fails to build: /bin/sh: clang++: not found
-
BUILD_DEPENDS= ${JAM}:devel/jam
-OPTIONS_DEFINE= DOCS EXAMPLES
+USES= tar:tgz
-USES= zip
+OPTIONS_DEFINE= EXAMPLES
-WRKSRC= ${WRKDIR}/${DISTNAME}
+WRKSRC= ${WRKDIR}/p4source-${PORTVERSION}
.include <bsd.port.pre.mk>
.include "../p4/Makefile.inc"
-# Sadly, Jam always returns 1 even on success. Ignore its return value and
-# detect build errors during the install phase.
do-build:
cd ${WRKSRC} && ${SETENV} C++="${CXX}" C++FLAGS="${CXXFLAGS}" \
CCFLAGS="${CFLAGS}" \
LINKFLAGS="${LDFLAGS}" \
OSVER=${OSVER} \
API=1 \
+ SSL="yes" \
+ SSLLIB=-lssl \
+ CRYPTOLIB=-lcrypto \
TYPE=pic \
- ${JAM} -dx -j${MAKE_JOBS_NUMBER} || true
+ ${JAM} -dx -sUSE_EXTENSIONS=0 -j${MAKE_JOBS_NUMBER} p4api p4api.tar
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/perforce
@@ -50,10 +44,6 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/perforce
cd ${WRKSRC}/p4-bin/bin.pic/p4api-*/lib && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/perforce
-do-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/p4api.pdf ${STAGEDIR}${DOCSDIR}
-
do-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/p4-bin/bin.pic/p4api-*/sample && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
diff --git a/devel/p4api/distinfo b/devel/p4api/distinfo
index fe1e178cf1aa..895f00dbc4d1 100644
--- a/devel/p4api/distinfo
+++ b/devel/p4api/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1517863861
-SHA256 (perforce/p4/2016-1.zip) = af465c970b5892674089a917ffa3d38f9b878e1ceb32eb73c2e05bd462d5ba63
-SIZE (perforce/p4/2016-1.zip) = 2249015
-SHA256 (perforce/p4/p4api.pdf) = df5e388c2753925d8411d98a14d7b634ef2543d4a0a04a340513e89d887ab57b
-SIZE (perforce/p4/p4api.pdf) = 1908708
+TIMESTAMP = 1679584778
+SHA256 (p4source-2407422.tgz) = 4355375def3f3d2256d4a92ac1b9960173e7aa97404346c0c74caf23a0905e1b
+SIZE (p4source-2407422.tgz) = 6325949
diff --git a/devel/p4api/pkg-descr b/devel/p4api/pkg-descr
index d99330ba9011..260a310cce92 100644
--- a/devel/p4api/pkg-descr
+++ b/devel/p4api/pkg-descr
@@ -1,3 +1,5 @@
The Perforce Client API is a simple beast which packages up the
command invocation, sends it to the server, and then acts on
instructions from the server to carry out the actual command.
+
+For documentation: https://www.perforce.com/manuals/p4api/Content/P4API/Home-p4api.html
diff --git a/devel/p4api/pkg-plist b/devel/p4api/pkg-plist
index 04e0d26a6777..fc849b828c2e 100644
--- a/devel/p4api/pkg-plist
+++ b/devel/p4api/pkg-plist
@@ -1,3 +1,4 @@
+include/perforce/base64.h
include/perforce/charcvt.h
include/perforce/charman.h
include/perforce/charset.h
@@ -5,11 +6,16 @@ include/perforce/clientapi.h
include/perforce/clientmerge.h
include/perforce/clientprog.h
include/perforce/clientresolvea.h
+include/perforce/clientscript.h
include/perforce/clientuser.h
include/perforce/datetime.h
include/perforce/debug.h
include/perforce/diff.h
include/perforce/diffmerge.h
+include/perforce/dmextension.h
+include/perforce/dmextension_c.h
+include/perforce/dmextensiondata.h
+include/perforce/dmextensiondata_c.h
include/perforce/echoctl.h
include/perforce/enviro.h
include/perforce/error.h
@@ -24,15 +30,23 @@ include/perforce/ignore.h
include/perforce/keepalive.h
include/perforce/macfile.h
include/perforce/macutil.h
+include/perforce/malloc_override.h
include/perforce/mangle.h
include/perforce/mapapi.h
include/perforce/md5.h
include/perforce/msgclient.h
include/perforce/msgdb.h
include/perforce/msgdm.h
+include/perforce/msgdm2.h
+include/perforce/msggraph.h
+include/perforce/msghelp.h
+include/perforce/msglbr.h
include/perforce/msgos.h
include/perforce/msgrpc.h
+include/perforce/msgscript.h
include/perforce/msgserver.h
+include/perforce/msgserver2.h
+include/perforce/msgspec.h
include/perforce/msgsupp.h
include/perforce/netbuffer.h
include/perforce/netconnect.h
@@ -40,10 +54,14 @@ include/perforce/netportparser.h
include/perforce/ntmangle.h
include/perforce/ntservice.h
include/perforce/options.h
+include/perforce/p4libs.h
include/perforce/p4tags.h
include/perforce/pathsys.h
include/perforce/runcmd.h
+include/perforce/sanitizers.h
include/perforce/serverhelperapi.h
+include/perforce/sha1.h
+include/perforce/sha256.h
include/perforce/signaler.h
include/perforce/spec.h
include/perforce/stdhdrs.h
@@ -59,10 +77,13 @@ include/perforce/validate.h
include/perforce/vararray.h
include/perforce/web822.h
lib/perforce/libclient.a
-lib/perforce/libp4sslstub.a
+lib/perforce/libp4api.a
+lib/perforce/libp4script.a
+lib/perforce/libp4script_c.a
+lib/perforce/libp4script_curl.a
+lib/perforce/libp4script_sqlite.a
lib/perforce/librpc.a
lib/perforce/libsupp.a
-%%PORTDOCS%%%%DOCSDIR%%/p4api.pdf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Jamfile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Jamrules
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Version