aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2022-08-26 19:01:03 +0000
committerGleb Popov <arrowd@FreeBSD.org>2022-08-26 19:01:55 +0000
commit3ef9df6fa282cf733d3b67b327af644cd02ba3ff (patch)
tree3c3bbef43395d36ea3b9abf6fb394859b0fce383
parent0a2156ecebc082c4019d5b3a8b1d8b5c85b52d61 (diff)
downloadports-3ef9df6fa282cf733d3b67b327af644cd02ba3ff.tar.gz
ports-3ef9df6fa282cf733d3b67b327af644cd02ba3ff.zip
lang/ghc: Use correct LLVM toolchain for the bootstrap compiler.
PR: 264192 Reported by: Mark Millard <marklmi26-fbsd@yahoo.com>
-rw-r--r--lang/ghc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 5939c5a318d7..a0ae512351da 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -40,7 +40,7 @@ GMP_DESC= Use GNU Multi-precision Library from Ports
PROFILE_DESC= Add support for performance profiling
BOOT_CONFIGURE_ENV= GHC=${LOCALBASE}/bin/ghc
-BOOT_CONFIGURE_ENV_OFF= GHC=${BOOT_GHC}
+BOOT_CONFIGURE_ENV_OFF= GHC=${BOOT_GHC} LLC=llc${BOOT_LLVM_VERSION} OPT=opt${BOOT_LLVM_VERSION}
DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
DOCS_VARS= enable_docs=YES