aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-22 06:00:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-22 06:01:48 +0000
commit3f3f7a26800cf77f964ba9e96f9800dc050305aa (patch)
tree42026aa35d39ead16d6a84bd546f4e66386b6dd3
parent61a31f3d501075c151a053445e6e1e9bbe08eba8 (diff)
devel/py-pytest-mpl: New port: Pytest plugin to facilitate image comparison for Matplotlib figures
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-mpl/Makefile26
-rw-r--r--devel/py-pytest-mpl/distinfo3
-rw-r--r--devel/py-pytest-mpl/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e7049c5222d2..ffda1059c384 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5106,6 +5106,7 @@
SUBDIR += py-pytest-markdown
SUBDIR += py-pytest-metadata
SUBDIR += py-pytest-mock
+ SUBDIR += py-pytest-mpl
SUBDIR += py-pytest-mutagen
SUBDIR += py-pytest-mypy
SUBDIR += py-pytest-nunit
diff --git a/devel/py-pytest-mpl/Makefile b/devel/py-pytest-mpl/Makefile
new file mode 100644
index 000000000000..35caf8d80241
--- /dev/null
+++ b/devel/py-pytest-mpl/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= pytest-mpl
+DISTVERSION= 0.16.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pytest plugin to facilitate image comparison for Matplotlib figures
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=20.0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.8+
+USE_PYTHON= distutils autoplist pytest # 4 tests fail, see https://github.com/matplotlib/pytest-mpl/issues/179
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-mpl/distinfo b/devel/py-pytest-mpl/distinfo
new file mode 100644
index 000000000000..4e5aecb57d59
--- /dev/null
+++ b/devel/py-pytest-mpl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1661129725
+SHA256 (pytest-mpl-0.16.1.tar.gz) = 2d571681124e8ff5f4e2b9c0d047d37d0499d6b6d8f2f49a1b50cdd993104469
+SIZE (pytest-mpl-0.16.1.tar.gz) = 663585
diff --git a/devel/py-pytest-mpl/pkg-descr b/devel/py-pytest-mpl/pkg-descr
new file mode 100644
index 000000000000..62d429274e51
--- /dev/null
+++ b/devel/py-pytest-mpl/pkg-descr
@@ -0,0 +1,4 @@
+pytest-mpl is a plugin to facilitate image comparison for Matplotlib figures
+in pytest.
+
+WWW: https://github.com/matplotlib/pytest-mpl