aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-08-12 10:24:36 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-08-12 10:36:06 +0000
commit4011448dbe075aa3203779483070ee59004f8aff (patch)
treee3e6edef88317c027cfd948867bd1920ebd70c20
parentb7134dd28579a66f3027a613e21fa8614b4b7c7e (diff)
downloadports-4011448dbe075aa3203779483070ee59004f8aff.tar.gz
ports-4011448dbe075aa3203779483070ee59004f8aff.zip
finance/kmymoney: allow building with clang on powerpc
-rw-r--r--finance/kmymoney/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/finance/kmymoney/Makefile b/finance/kmymoney/Makefile
index 2e53f975f57d..04ee43c676d0 100644
--- a/finance/kmymoney/Makefile
+++ b/finance/kmymoney/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kmymoney
PORTVERSION= 5.1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
@@ -14,8 +14,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSES/GPL-2.0-or-later.txt
LIB_DEPENDS= libalkimia5.so:finance/alkimia \
libKChart.so:graphics/kdiagram
-USES= cmake desktop-file-utils gettext kde:5 pkgconfig qt:5 \
- shared-mime-info shebangfix tar:xz
+USES= cmake compiler:c++14-lang desktop-file-utils gettext kde:5 \
+ pkgconfig qt:5 shared-mime-info shebangfix tar:xz
USE_QT= buildtools:build core dbus gui network printsupport qmake:build \
sql testlib:build xml webkit widgets
USE_KDE= activities archive auth bookmarks codecs completion config \
@@ -95,14 +95,6 @@ WOOB_USES= python
WOOB_USE= qt=concurrent
WOOB_CMAKE_BOOL= ENABLE_WOOB
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == powerpc
-USES+= compiler:gcc-c++11-lib
-.else
-USES+= compiler:c++14-lang
-.endif
-
.if defined(MAINTAINER_MODE)
# Apply additional substitutions to pkg-plist generated by the 'makeplist' target
create-plist: stage