aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-01 08:35:00 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-01 08:35:34 +0000
commit40ac0b44cb370df13a81a39dae5fa8fdf957ee59 (patch)
tree130cb4f941b67a6a56387214d48a69ab0de8cae5
parentb7d6ba39cee70db8a8cafc5471a10bd343780fca (diff)
downloadports-40ac0b44cb370df13a81a39dae5fa8fdf957ee59.tar.gz
ports-40ac0b44cb370df13a81a39dae5fa8fdf957ee59.zip
x11-toolkits/pythonqt: New port: Dynamic Python binding for Qt Applications
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/pythonqt/Makefile32
-rw-r--r--x11-toolkits/pythonqt/distinfo5
-rw-r--r--x11-toolkits/pythonqt/files/patch-PythonQt.pro10
-rw-r--r--x11-toolkits/pythonqt/pkg-descr2
-rw-r--r--x11-toolkits/pythonqt/pkg-plist40
6 files changed, 90 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 9202b756fcf3..bec7ef8c041c 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -164,6 +164,7 @@
SUBDIR += py-tkinter
SUBDIR += py-tktreectrl
SUBDIR += py-wxPython4
+ SUBDIR += pythonqt
SUBDIR += qml-box2d
SUBDIR += qt5-charts
SUBDIR += qt5-datavis3d
diff --git a/x11-toolkits/pythonqt/Makefile b/x11-toolkits/pythonqt/Makefile
new file mode 100644
index 000000000000..a9b620c2a4db
--- /dev/null
+++ b/x11-toolkits/pythonqt/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= pythonqt
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.3.0-27
+DISTVERSIONSUFFIX= -gf52ff96
+CATEGORIES= x11-toolkits devel python
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
+PATCHFILES= f9149ea9fefdcd0e9ece092ad44fb4bd0c1b4da9.patch:-p1 # fix install paths by adding INSTALL_PREFIX, https://github.com/MeVisLab/pythonqt/pull/92
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Dynamic Python binding for Qt Applications
+WWW= https://mevislab.github.io/pythonqt/
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gettext-runtime gl python:3.6+ qmake qt:5
+USE_QT= core declarative gui multimedia network opengl printsupport sql svg webkit widgets xml xmlpatterns \
+ buildtools:build
+USE_GL= gl
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= MeVisLab
+
+QMAKE_ARGS= PYTHON_VERSION=${PYTHON_VER} \
+ PYTHON_DIR=${LOCALBASE} \
+ QMAKE_CFLAGS="${CFLAGS}" \
+ QMAKE_CXXFLAGS="${CXXFLAGS}" \
+ INSTALL_PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/pythonqt/distinfo b/x11-toolkits/pythonqt/distinfo
new file mode 100644
index 000000000000..33ef710e0e73
--- /dev/null
+++ b/x11-toolkits/pythonqt/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1675238707
+SHA256 (MeVisLab-pythonqt-v3.3.0-27-gf52ff96_GH0.tar.gz) = 1536819a45f8f696d3a3d376c14abb6e43f1495a1cc252b533ce6c783f32ffe7
+SIZE (MeVisLab-pythonqt-v3.3.0-27-gf52ff96_GH0.tar.gz) = 5314463
+SHA256 (f9149ea9fefdcd0e9ece092ad44fb4bd0c1b4da9.patch) = 00503762eeecd5fac7186af5f4323578bdf00b9c79b52c174c77b184b9ce48dd
+SIZE (f9149ea9fefdcd0e9ece092ad44fb4bd0c1b4da9.patch) = 1403
diff --git a/x11-toolkits/pythonqt/files/patch-PythonQt.pro b/x11-toolkits/pythonqt/files/patch-PythonQt.pro
new file mode 100644
index 000000000000..56b0f88eaec6
--- /dev/null
+++ b/x11-toolkits/pythonqt/files/patch-PythonQt.pro
@@ -0,0 +1,10 @@
+--- PythonQt.pro.orig 2023-02-01 08:09:21 UTC
++++ PythonQt.pro
+@@ -1,6 +1,6 @@
+ TEMPLATE = subdirs
+
+-SUBDIRS = generator src extensions tests examples
++SUBDIRS = generator src extensions #tests examples
+ tests.depends += src extensions
+ extensions.depends += src
+ examples.depends += src extensions
diff --git a/x11-toolkits/pythonqt/pkg-descr b/x11-toolkits/pythonqt/pkg-descr
new file mode 100644
index 000000000000..5a2aa7692f53
--- /dev/null
+++ b/x11-toolkits/pythonqt/pkg-descr
@@ -0,0 +1,2 @@
+PythonQt is a dynamic Python binding for Qt. It offers an easy way to embed the
+Python scripting language into your Qt applications.
diff --git a/x11-toolkits/pythonqt/pkg-plist b/x11-toolkits/pythonqt/pkg-plist
new file mode 100644
index 000000000000..d310fe11611c
--- /dev/null
+++ b/x11-toolkits/pythonqt/pkg-plist
@@ -0,0 +1,40 @@
+include/PythonQt.h
+include/PythonQtBoolResult.h
+include/PythonQtClassInfo.h
+include/PythonQtClassWrapper.h
+include/PythonQtConversion.h
+include/PythonQtCppWrapperFactory.h
+include/PythonQtImportFileInterface.h
+include/PythonQtImporter.h
+include/PythonQtInstanceWrapper.h
+include/PythonQtMethodInfo.h
+include/PythonQtMisc.h
+include/PythonQtObjectPtr.h
+include/PythonQtProperty.h
+include/PythonQtPythonInclude.h
+include/PythonQtQFileImporter.h
+include/PythonQtScriptingConsole.h
+include/PythonQtSignal.h
+include/PythonQtSignalReceiver.h
+include/PythonQtSlot.h
+include/PythonQtSlotDecorator.h
+include/PythonQtStdDecorators.h
+include/PythonQtStdIn.h
+include/PythonQtStdOut.h
+include/PythonQtSystem.h
+include/PythonQtThreadSupport.h
+include/PythonQtUtils.h
+include/PythonQtVariants.h
+include/PythonQt_QtAll.h
+include/com_trolltech_qt_core_builtin0.h
+include/com_trolltech_qt_gui_builtin0.h
+lib/PythonQt-Qt5-Python3.pc
+lib/PythonQt_QtAll-Qt5-Python3.pc
+lib/libPythonQt-Qt5-Python%%PYTHON_VER%%.so
+lib/libPythonQt-Qt5-Python%%PYTHON_VER%%.so.3
+lib/libPythonQt-Qt5-Python%%PYTHON_VER%%.so.3.2
+lib/libPythonQt-Qt5-Python%%PYTHON_VER%%.so.3.2.0
+lib/libPythonQt_QtAll-Qt5-Python%%PYTHON_VER%%.so
+lib/libPythonQt_QtAll-Qt5-Python%%PYTHON_VER%%.so.3
+lib/libPythonQt_QtAll-Qt5-Python%%PYTHON_VER%%.so.3.2
+lib/libPythonQt_QtAll-Qt5-Python%%PYTHON_VER%%.so.3.2.0