aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2024-02-13 22:05:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-02-13 22:05:09 +0000
commit40efec60a98d3360c1b6045adce159e3c53ebcca (patch)
tree77737ce1a97e70c0dd543a5df991ebe6aae54399
parentecd2b41fcfe7bd723414e1da61ad71240f16a2c1 (diff)
downloadports-40efec60a98d3360c1b6045adce159e3c53ebcca.tar.gz
ports-40efec60a98d3360c1b6045adce159e3c53ebcca.zip
print/py-reportlab: Update version 3.6.13=>4.1.0
-rw-r--r--print/py-reportlab/Makefile12
-rw-r--r--print/py-reportlab/distinfo6
-rw-r--r--print/py-reportlab/files/patch-setup.py6
3 files changed, 10 insertions, 14 deletions
diff --git a/print/py-reportlab/Makefile b/print/py-reportlab/Makefile
index 29d37a176839..cf792a265933 100644
--- a/print/py-reportlab/Makefile
+++ b/print/py-reportlab/Makefile
@@ -1,5 +1,5 @@
PORTNAME= reportlab
-PORTVERSION= 3.6.13
+PORTVERSION= 4.1.0
CATEGORIES= print python
MASTER_SITES= PYPI \
https://www.reportlab.com/ftp/
@@ -14,13 +14,12 @@ WWW= https://www.reportlab.com/
LICENSE= BSD3CLAUSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PY_PILLOW}
USES= cpe python
-USE_PYTHON= autoplist distutils
-
-CONFLICTS= py*-reportlab[^3]-[^3].* \
- py*-reportlab-[^3].*
+USE_PYTHON= autoplist pep517
PFBFER_VERSION= 20180109
PFBFER= pfbfer-${PFBFER_VERSION}.zip
@@ -49,9 +48,6 @@ post-patch-DOCS-on:
${WRKSRC}/docs/${f}
.endfor
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/reportlab/*/*.so
-
post-install-DOCS-on:
@cd ${WRKSRC}/docs && ${PYTHON_CMD} genAll.py
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/print/py-reportlab/distinfo b/print/py-reportlab/distinfo
index 282959240d7a..eaf61f72ed4c 100644
--- a/print/py-reportlab/distinfo
+++ b/print/py-reportlab/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1682615680
-SHA256 (reportlab-3.6.13.tar.gz) = 6f75d33f7a3720cf47371ab63ced0f0ebd1aeb6db19386ae92f8977a09be9611
-SIZE (reportlab-3.6.13.tar.gz) = 4035524
+TIMESTAMP = 1707810500
+SHA256 (reportlab-4.1.0.tar.gz) = 3a99faf412691159c068b3ff01c15307ce2fd2cf6b860199434874e002040a84
+SIZE (reportlab-4.1.0.tar.gz) = 3146958
SHA256 (pfbfer-20180109.zip) = 851b431550e866b217317d09dd33b5535ae081200975ad4dd25e80be2af10fec
SIZE (pfbfer-20180109.zip) = 737561
diff --git a/print/py-reportlab/files/patch-setup.py b/print/py-reportlab/files/patch-setup.py
index f24e88059088..0c9ae68a1d1e 100644
--- a/print/py-reportlab/files/patch-setup.py
+++ b/print/py-reportlab/files/patch-setup.py
@@ -1,11 +1,11 @@
---- setup.py.orig 2022-06-08 08:27:36 UTC
+--- setup.py.orig 2024-02-13 07:54:28 UTC
+++ setup.py
-@@ -443,9 +443,7 @@ def get_fonts(PACKAGE_DIR, reportlab_files):
+@@ -202,9 +202,7 @@ def get_fonts(PACKAGE_DIR, reportlab_files):
xitmsg = "not downloading T1 font curve files"
else:
try:
- infoline("Downloading standard T1 font curves")
-- zipdata = url2data("http://www.reportlab.com/ftp/pfbfer-20180109.zip")
+- zipdata = url2data("https://www.reportlab.com/ftp/pfbfer-20180109.zip")
- archive = zipfile.ZipFile(zipdata)
+ archive = zipfile.ZipFile("%%DISTDIR%%/%%PFBFER%%")
dst = pjoin(rl_dir, 'fonts')