aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-27 23:07:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-27 23:07:49 +0000
commit4111a7af8836b9b0da73627e9f06d5dd4c8aee91 (patch)
tree30af8d0eb56d6807b87d646bcd056faa8dd34b97
parent3adc4101b944fc111632e68dd15999e046c6f92e (diff)
downloadports-4111a7af8836b9b0da73627e9f06d5dd4c8aee91.tar.gz
ports-4111a7af8836b9b0da73627e9f06d5dd4c8aee91.zip
finance/py-fredapi: New port: Python API for Federal Reserve Economic Data (FRED) from St. Louis Fed
-rw-r--r--finance/Makefile1
-rw-r--r--finance/py-fredapi/Makefile27
-rw-r--r--finance/py-fredapi/distinfo3
-rw-r--r--finance/py-fredapi/pkg-descr4
4 files changed, 35 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 8b9719e15234..e595bd63179c 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -110,6 +110,7 @@
SUBDIR += py-finnhub-python
SUBDIR += py-finviz
SUBDIR += py-finvizfinance
+ SUBDIR += py-fredapi
SUBDIR += py-fundamentalanalysis
SUBDIR += py-investiny
SUBDIR += py-investpy
diff --git a/finance/py-fredapi/Makefile b/finance/py-fredapi/Makefile
new file mode 100644
index 000000000000..63d6259f22cc
--- /dev/null
+++ b/finance/py-fredapi/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= fredapi
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.5.0
+CATEGORIES= finance python
+#MASTER_SITES= CHEESESHOP # no tests
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python API for Federal Reserve Economic Data (FRED) from St. Louis Fed
+WWW= https://github.com/mortada/fredapi
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pandas>=0.15:math/py-pandas@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python
+USE_PYTHON= distutils autoplist pytest # 1 test fails, see https://github.com/mortada/fredapi/issues/60
+
+USE_GITHUB= yes
+GH_ACCOUNT= mortada
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/finance/py-fredapi/distinfo b/finance/py-fredapi/distinfo
new file mode 100644
index 000000000000..eb98eff42b37
--- /dev/null
+++ b/finance/py-fredapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1672179382
+SHA256 (mortada-fredapi-v0.5.0_GH0.tar.gz) = 8a81e2e427e3da463bde5df479985bffe686872ea7435ac2194c46dff7be49a4
+SIZE (mortada-fredapi-v0.5.0_GH0.tar.gz) = 15167
diff --git a/finance/py-fredapi/pkg-descr b/finance/py-fredapi/pkg-descr
new file mode 100644
index 000000000000..e0baa69dab54
--- /dev/null
+++ b/finance/py-fredapi/pkg-descr
@@ -0,0 +1,4 @@
+fredapi is a Python API for the FRED data provided by the Federal Reserve Bank
+of St. Louis. fredapi provides a wrapper in python to the FRED web service,
+and also provides several convenient methods for parsing and analyzing
+point-in-time data (i.e. historic data revisions) from ALFRED.