aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 05:41:31 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 05:49:04 +0000
commit419a1eb49424c25ff3e081206ed345a36ebc4d9f (patch)
treee999fa8267cd64b53c06a192a7536df1af714da1
parent49e08e9226ccb05ea2fe5ca106d2d6aa2ab36c52 (diff)
games/rlvm: Fix build with utf8cpp 4.0.3+
- Update version requirement of BUILD_DEPENDS to avoid using utf8cpp 4.0.2 utf8cpp 3.* installs to ${PREFIX}/include/utf8cpp/. utf8cpp 4.0.{0,1,2} changes to ${PREFIX}/include/. utf8cpp 4.0.3 changes back to ${PREFIX}/include/utf8cpp/.
-rw-r--r--games/rlvm/Makefile2
-rw-r--r--games/rlvm/files/patch-utf8cpp99
2 files changed, 1 insertions, 100 deletions
diff --git a/games/rlvm/Makefile b/games/rlvm/Makefile
index da5f9fe51577..f6c4ec555214 100644
--- a/games/rlvm/Makefile
+++ b/games/rlvm/Makefile
@@ -15,7 +15,7 @@ LICENSE_COMB= multi
BROKEN_FreeBSD_12_powerpc64= fails to link on powerpc64 elfv1: gcn_platform.cc: undefined reference to gcn::Exception::Exception
BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
- utf8cpp>=4.0.0:devel/utf8cpp
+ utf8cpp>=4.0.3:devel/utf8cpp
LIB_DEPENDS= libsndfile.so:audio/libsndfile \
libvorbisfile.so:audio/libvorbis \
libguichan.so:devel/guichan
diff --git a/games/rlvm/files/patch-utf8cpp b/games/rlvm/files/patch-utf8cpp
deleted file mode 100644
index 0d12cd2e93d1..000000000000
--- a/games/rlvm/files/patch-utf8cpp
+++ /dev/null
@@ -1,99 +0,0 @@
---- src/long_operations/textout_long_operation.cc.orig 2021-05-27 12:59:29 UTC
-+++ src/long_operations/textout_long_operation.cc
-@@ -39,7 +39,7 @@
- #include "systems/base/text_page.h"
- #include "systems/base/text_system.h"
- #include "utilities/exception.h"
--#include "utf8cpp/utf8.h"
-+#include "utf8.h"
-
- // Timing information must stay the same between individual
- // TextoutLongOperations. rlBabel compiled games will always display one
---- src/machine/rlvm_instance.cc.orig 2021-05-27 12:59:29 UTC
-+++ src/machine/rlvm_instance.cc
-@@ -43,7 +43,7 @@
- #include "systems/base/graphics_system.h"
- #include "systems/base/system_error.h"
- #include "systems/sdl/sdl_system.h"
--#include "utf8cpp/utf8.h"
-+#include "utf8.h"
- #include "utilities/exception.h"
- #include "utilities/file.h"
- #include "utilities/find_font_file.h"
---- src/modules/module_sys_save.cc.orig 2021-05-27 12:59:29 UTC
-+++ src/modules/module_sys_save.cc
-@@ -54,7 +54,7 @@
- #include "systems/base/surface.h"
- #include "systems/base/system.h"
- #include "libreallive/intmemref.h"
--#include "utf8cpp/utf8.h"
-+#include "utf8.h"
-
- using boost::starts_with;
- using boost::ends_with;
---- src/systems/base/text_page.cc.orig 2021-05-27 12:59:29 UTC
-+++ src/systems/base/text_page.cc
-@@ -35,7 +35,7 @@
- #include "systems/base/system.h"
- #include "systems/base/text_system.h"
- #include "systems/base/text_window.h"
--#include "utf8cpp/utf8.h"
-+#include "utf8.h"
- #include "utilities/exception.h"
- #include "utilities/string_utilities.h"
-
---- src/systems/base/text_system.cc.orig 2021-05-27 12:59:29 UTC
-+++ src/systems/base/text_system.cc
-@@ -49,7 +49,7 @@
- #include "systems/base/text_key_cursor.h"
- #include "systems/base/text_page.h"
- #include "systems/base/text_window.h"
--#include "utf8cpp/utf8.h"
-+#include "utf8.h"
- #include "utilities/exception.h"
- #include "utilities/string_utilities.h"
-
---- src/systems/base/text_window.cc.orig 2021-05-27 12:59:29 UTC
-+++ src/systems/base/text_window.cc
-@@ -45,7 +45,7 @@
- #include "systems/base/system_error.h"
- #include "systems/base/text_system.h"
- #include "systems/base/text_waku.h"
--#include "utf8cpp/utf8.h"
-+#include "utf8.h"
- #include "utilities/exception.h"
- #include "utilities/graphics.h"
- #include "utilities/string_utilities.h"
---- src/systems/sdl/sdl_text_window.cc.orig 2021-05-27 12:59:29 UTC
-+++ src/systems/sdl/sdl_text_window.cc
-@@ -43,7 +43,7 @@
- #include "systems/sdl/sdl_system.h"
- #include "systems/sdl/sdl_text_system.h"
- #include "systems/sdl/sdl_utils.h"
--#include "utf8cpp/utf8.h"
-+#include "utf8.h"
- #include "utilities/exception.h"
- #include "utilities/string_utilities.h"
-
---- src/utilities/string_utilities.cc.orig 2021-05-27 12:59:29 UTC
-+++ src/utilities/string_utilities.cc
-@@ -31,7 +31,7 @@
-
- #include "encodings/codepage.h"
- #include "utilities/exception.h"
--#include "utf8cpp/utf8.h"
-+#include "utf8.h"
-
- using std::string;
- using std::wstring;
---- test/test_system/test_text_system.cc.orig 2021-05-27 12:59:29 UTC
-+++ test/test_system/test_text_system.cc
-@@ -33,7 +33,7 @@
- #include "test_system/mock_surface.h"
- #include "test_system/mock_text_window.h"
- #include "test_system/test_text_window.h"
--#include "utf8cpp/utf8.h"
-+#include "utf8.h"
-
- TestTextSystem::TestTextSystem(System& system, Gameexe& gexe)
- : TextSystem(system, gexe) {}