aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2022-03-01 21:17:37 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2022-03-01 21:17:37 +0000
commit41b6a246b07508bcca8b204cfc4fd960423540fb (patch)
treeb8f9da458f3bff64a92ea29f1df4eeb4fb9c504d
parentda12f86912bf61d903544c27f3dd6ab530c49420 (diff)
downloadports-41b6a246b07508bcca8b204cfc4fd960423540fb.tar.gz
ports-41b6a246b07508bcca8b204cfc4fd960423540fb.zip
security/globalprotect-openconnect: OpenConnect GUI for GlobalProtect
A GlobalProtect VPN client (GUI) for *nix based on Openconnect and built with Qt5, supports SAML auth mode, inspired by gp-saml-gui.
-rw-r--r--security/Makefile1
-rw-r--r--security/globalprotect-openconnect/Makefile23
-rw-r--r--security/globalprotect-openconnect/distinfo7
-rw-r--r--security/globalprotect-openconnect/files/patch-GPClient_CMakeLists.txt11
-rw-r--r--security/globalprotect-openconnect/files/patch-GPService_CMakeLists.txt11
-rw-r--r--security/globalprotect-openconnect/pkg-descr4
-rw-r--r--security/globalprotect-openconnect/pkg-plist8
7 files changed, 65 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 708977847b44..3d77703aba8c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -183,6 +183,7 @@
SUBDIR += git-remote-gcrypt
SUBDIR += git-secret
SUBDIR += gitjacker
+ SUBDIR += globalprotect-openconnect
SUBDIR += gnome-keyring
SUBDIR += gnome-keyring-sharp
SUBDIR += gnome-ssh-askpass
diff --git a/security/globalprotect-openconnect/Makefile b/security/globalprotect-openconnect/Makefile
new file mode 100644
index 000000000000..b19bf4fbf096
--- /dev/null
+++ b/security/globalprotect-openconnect/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= globalprotect-openconnect
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.3.4
+CATEGORIES= security
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= OpenConnect GUI for GlobalProtect protocol
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libopenconnect.so:security/openconnect
+
+USES= cmake:noninja qt:5
+USE_GITHUB= yes
+USE_QT= buildtools core dbus declarative gui location network printsupport qmake_build webchannel webengine websockets widgets
+
+GH_ACCOUNT= yuezk
+GH_PROJECT= GlobalProtect-openconnect
+GH_TUPLE+= itay-grudev:SingleApplication:v3.3.0:sa/3rdparty/SingleApplication
+GH_TUPLE+= SergiusTheBest:plog:1.1.5:plog/3rdparty/plog
+
+.include <bsd.port.mk>
diff --git a/security/globalprotect-openconnect/distinfo b/security/globalprotect-openconnect/distinfo
new file mode 100644
index 000000000000..c6670ced4940
--- /dev/null
+++ b/security/globalprotect-openconnect/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1646167885
+SHA256 (yuezk-GlobalProtect-openconnect-v1.3.4_GH0.tar.gz) = 2c98132352e8fb6f582093ccf33131d471d09f6fa1af950444d4adbfae703521
+SIZE (yuezk-GlobalProtect-openconnect-v1.3.4_GH0.tar.gz) = 115036
+SHA256 (itay-grudev-SingleApplication-v3.3.0_GH0.tar.gz) = b5a789e7e4fda5239b09249a74a91c9ffea8581dcb59bc693e3db8af96d6f1bf
+SIZE (itay-grudev-SingleApplication-v3.3.0_GH0.tar.gz) = 21148
+SHA256 (SergiusTheBest-plog-1.1.5_GH0.tar.gz) = 6c80b4701183d2415bec927e1f5ca9b1761b3b5c65d3e09fb29c743e016d5609
+SIZE (SergiusTheBest-plog-1.1.5_GH0.tar.gz) = 40453
diff --git a/security/globalprotect-openconnect/files/patch-GPClient_CMakeLists.txt b/security/globalprotect-openconnect/files/patch-GPClient_CMakeLists.txt
new file mode 100644
index 000000000000..84289a0fef93
--- /dev/null
+++ b/security/globalprotect-openconnect/files/patch-GPClient_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- GPClient/CMakeLists.txt.orig 2022-03-01 20:51:43 UTC
++++ GPClient/CMakeLists.txt
+@@ -51,7 +51,7 @@ add_3rdparty(
+
+ add_3rdparty(
+ plog
+- GIT_REPOSITORY https://github.com/SergiusTheBest/plog.git
++ #GIT_REPOSITORY https://github.com/SergiusTheBest/plog.git
+ GIT_TAG 1.1.5
+ CMAKE_ARGS
+ -DPLOG_BUILD_SAMPLES=OFF
diff --git a/security/globalprotect-openconnect/files/patch-GPService_CMakeLists.txt b/security/globalprotect-openconnect/files/patch-GPService_CMakeLists.txt
new file mode 100644
index 000000000000..c5fdccdc47a9
--- /dev/null
+++ b/security/globalprotect-openconnect/files/patch-GPService_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- GPService/CMakeLists.txt.orig 2022-03-01 20:54:13 UTC
++++ GPService/CMakeLists.txt
+@@ -29,7 +29,7 @@ add_executable(gpservice
+
+ add_3rdparty(
+ SingleApplication
+- GIT_REPOSITORY https://github.com/itay-grudev/SingleApplication.git
++ #GIT_REPOSITORY https://github.com/itay-grudev/SingleApplication.git
+ GIT_TAG v3.3.0
+ CMAKE_ARGS
+ -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE}
diff --git a/security/globalprotect-openconnect/pkg-descr b/security/globalprotect-openconnect/pkg-descr
new file mode 100644
index 000000000000..16882585f05c
--- /dev/null
+++ b/security/globalprotect-openconnect/pkg-descr
@@ -0,0 +1,4 @@
+A GlobalProtect VPN client (GUI) for *nix based on Openconnect and
+built with Qt5, supports SAML auth mode, inspired by gp-saml-gui.
+
+WWW: https://github.com/yuezk/GlobalProtect-openconnect
diff --git a/security/globalprotect-openconnect/pkg-plist b/security/globalprotect-openconnect/pkg-plist
new file mode 100644
index 000000000000..dc1631ec6ae9
--- /dev/null
+++ b/security/globalprotect-openconnect/pkg-plist
@@ -0,0 +1,8 @@
+bin/gpclient
+bin/gpservice
+lib/systemd/system/gpservice.service
+share/applications/com.yuezk.qt.gpclient.desktop
+share/dbus-1/system-services/com.yuezk.qt.GPService.service
+share/dbus-1/system.d/com.yuezk.qt.GPService.conf
+share/icons/hicolor/scalable/apps/com.yuezk.qt.gpclient.svg
+share/metainfo/com.yuezk.qt.gpclient.metainfo.xml