aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-04 21:18:11 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-04 21:30:01 +0000
commit41c8aa935cda66c8ab735628f12eeda7802e8471 (patch)
treea3f838d59679c9604cc5c5c332096defbe5db143
parentbc9917dc5111e22a27b87de2d49b4b1094633ceb (diff)
downloadports-41c8aa935cda66c8ab735628f12eeda7802e8471.tar.gz
ports-41c8aa935cda66c8ab735628f12eeda7802e8471.zip
devel/py-anyio3: Add py-anyio3 3.7.1 (copied from py-anyio)
- Add PORTSCOUT
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-anyio3/Makefile39
-rw-r--r--devel/py-anyio3/distinfo3
-rw-r--r--devel/py-anyio3/files/patch-pyproject.toml10
-rw-r--r--devel/py-anyio3/pkg-descr17
5 files changed, 70 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 30ce5446528d..7982f6b2fed3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4228,6 +4228,7 @@
SUBDIR += py-antlr4-python3-runtime
SUBDIR += py-anyconfig
SUBDIR += py-anyio
+ SUBDIR += py-anyio3
SUBDIR += py-anyjson
SUBDIR += py-anytree
SUBDIR += py-apache_conf_parser
diff --git a/devel/py-anyio3/Makefile b/devel/py-anyio3/Makefile
new file mode 100644
index 000000000000..2e08970bb08b
--- /dev/null
+++ b/devel/py-anyio3/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= anyio
+PORTVERSION= 3.7.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 3
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= High level compatibility layer for multiple asynchronous event loop implementations
+WWW= https://github.com/agronholm/anyio
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=6.4:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}idna>=2.8:dns/py-idna@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sniffio>=1.1:devel/py-sniffio@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^3\.
+
+OPTIONS_DEFINE= TRIO
+TRIO_DESC= Use trio as backend
+
+TRIO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}trio>=0.22:net/py-trio@${PY_FLAVOR}
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 31100
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}exceptiongroup>=0:devel/py-exceptiongroup@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-anyio3/distinfo b/devel/py-anyio3/distinfo
new file mode 100644
index 000000000000..afecd69a34c0
--- /dev/null
+++ b/devel/py-anyio3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688902087
+SHA256 (anyio-3.7.1.tar.gz) = 44a3c9aba0f5defa43261a8b3efb97891f2bd7d804e0e1f56419befa1adfc780
+SIZE (anyio-3.7.1.tar.gz) = 142927
diff --git a/devel/py-anyio3/files/patch-pyproject.toml b/devel/py-anyio3/files/patch-pyproject.toml
new file mode 100644
index 000000000000..e9bf63a21bb4
--- /dev/null
+++ b/devel/py-anyio3/files/patch-pyproject.toml
@@ -0,0 +1,10 @@
+--- pyproject.toml.orig 2023-05-27 11:12:17 UTC
++++ pyproject.toml
+@@ -1,6 +1,6 @@
+ [build-system]
+ requires = [
+- "setuptools >= 64",
++ "setuptools >= 61",
+ "setuptools_scm >= 6.4"
+ ]
+ build-backend = "setuptools.build_meta"
diff --git a/devel/py-anyio3/pkg-descr b/devel/py-anyio3/pkg-descr
new file mode 100644
index 000000000000..f891ed0294c3
--- /dev/null
+++ b/devel/py-anyio3/pkg-descr
@@ -0,0 +1,17 @@
+AnyIO is a asynchronous compatibility API that allows applications and libraries
+written against it to run unmodified on asyncio, curio and trio.
+
+It bridges the following functionality:
+- Task groups
+- Cancellation
+- Threads
+- Signal handling
+- Asynchronous file I/O
+- Subprocesses
+- Inter-task synchronization and communication (locks, conditions, events,
+ semaphores, object streams)
+- High level networking (TCP, UDP and UNIX sockets)
+
+You can even use it together with native libraries from your selected backend in
+applications. Doing this in libraries is not advisable however since it limits
+the usefulness of your library.