aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2024-02-20 11:27:47 +0000
committerWen Heping <wen@FreeBSD.org>2024-02-20 11:29:14 +0000
commit427cb03fab5df35a86bdacf4bb8438b9ab4ed346 (patch)
tree6f8fe3868d43cd11d3b08a8103473a7635aa1e28
parent53ae79bb9a020d2948d59de9601c346498d58b84 (diff)
databases/mongodb60: Fix build with python-3.11
PR: 275494 Approved by: portmgr(blanket, fix build)
-rw-r--r--databases/mongodb60/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/databases/mongodb60/Makefile b/databases/mongodb60/Makefile
index 53f4194e2ac0..69720bb329f5 100644
--- a/databases/mongodb60/Makefile
+++ b/databases/mongodb60/Makefile
@@ -117,6 +117,12 @@ post-patch:
${RM} -rf ${WRKSRC}/src/third_party/zlib-*
${RM} -rf ${WRKSRC}/src/third_party/zstandard
+# fix build with python-3.11
+ ${REINPLACE_CMD} -e 's#rU#r#g' ${WRKDIR}/spidermonkey-${MOZJS_TAG}/python/mozbuild/mozbuild/util.py
+ ${REINPLACE_CMD} -e 's#rU#r#g' ${WRKDIR}/spidermonkey-${MOZJS_TAG}/python/mozbuild/mozbuild/preprocessor.py
+ ${REINPLACE_CMD} -e 's#rU#r#g' ${WRKDIR}/spidermonkey-${MOZJS_TAG}/python/mozbuild/mozbuild/backend/base.py
+ ${REINPLACE_CMD} -e 's#rU#r#g' ${WRKDIR}/spidermonkey-${MOZJS_TAG}/python/mozbuild/mozbuild/action/process_define_files.py
+
do-configure:
# Replacement of ${WRKSRC}/src/third_party/mozjs/get-sources.sh
${LN} -sF ${WRKDIR}/spidermonkey-${MOZJS_TAG} ${WRKSRC}/src/third_party/mozjs/mozilla-release