aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-25 19:24:07 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-28 12:31:10 +0000
commit429facb51b6f90477d81e2c9b118a765eafb96a7 (patch)
treed06365a5bc4e221eb80d74d3d0b0871341306266
parentf08db191ff75ca34e8295bb60899b6cfbbbedeb2 (diff)
textproc/py-sphinx: switch to pytest4
- Switch to pytest4 to avoid test failures after updating pytest to 7.x PR: 256624
-rw-r--r--textproc/py-sphinx/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/textproc/py-sphinx/Makefile b/textproc/py-sphinx/Makefile
index d238d37d5943..69e437d5e1f9 100644
--- a/textproc/py-sphinx/Makefile
+++ b/textproc/py-sphinx/Makefile
@@ -35,8 +35,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinxcontrib-applehelp>=0:textproc/py-sphin
${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest4-cov>=0:devel/py-pytest4-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest4>=0:devel/py-pytest4@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}html5lib>=0:www/py-html5lib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}typed-ast>=0:devel/py-typed-ast@${PY_FLAVOR} \
cython-${PYTHON_VER}:lang/cython@${PY_FLAVOR}