aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 20:43:46 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 20:43:46 +0000
commit42c316c631664380e0a7e20ceeda99eec2c0aa8a (patch)
tree1541da4aa23b60dfe36f3328f1aa98610353fda9
parentca87f9b768790555d6949b412affefba141e7aff (diff)
downloadports-42c316c631664380e0a7e20ceeda99eec2c0aa8a.tar.gz
ports-42c316c631664380e0a7e20ceeda99eec2c0aa8a.zip
net/py-pyroute2.ipset: Add py-pyroute2.ipset 0.6.4
PyRoute2 is a pure Python netlink library. This module provides IPSet and WiSet classes. WWW: https://github.com/svinota/pyroute2/tree/master/pyroute2.ipset
-rw-r--r--net/Makefile1
-rw-r--r--net/py-pyroute2.ipset/Makefile24
-rw-r--r--net/py-pyroute2.ipset/distinfo3
-rw-r--r--net/py-pyroute2.ipset/pkg-descr5
4 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8d7cef62056f..28b4785357be 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1075,6 +1075,7 @@
SUBDIR += py-pyroute2
SUBDIR += py-pyroute2.core
SUBDIR += py-pyroute2.ethtool
+ SUBDIR += py-pyroute2.ipset
SUBDIR += py-pysendfile
SUBDIR += py-pyshark
SUBDIR += py-pysmb
diff --git a/net/py-pyroute2.ipset/Makefile b/net/py-pyroute2.ipset/Makefile
new file mode 100644
index 000000000000..b4e11f5293d6
--- /dev/null
+++ b/net/py-pyroute2.ipset/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pyroute2.ipset
+PORTVERSION= 0.6.4
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python Netlink library: ipset
+
+LICENSE= APACHE20 GPLv2+
+LICENSE_COMB= dual
+LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.Apache.v2
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/LICENSE.GPL.v2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyroute2.core>=0:net/py-pyroute2.core@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-pyroute2.ipset/distinfo b/net/py-pyroute2.ipset/distinfo
new file mode 100644
index 000000000000..11e300664980
--- /dev/null
+++ b/net/py-pyroute2.ipset/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1624189681
+SHA256 (pyroute2.ipset-0.6.4.tar.gz) = 57a694198bf83c68711e812380dbaaa116dde9fb6a8ab3bfa1f3434040024f2f
+SIZE (pyroute2.ipset-0.6.4.tar.gz) = 31194
diff --git a/net/py-pyroute2.ipset/pkg-descr b/net/py-pyroute2.ipset/pkg-descr
new file mode 100644
index 000000000000..913950c30cbb
--- /dev/null
+++ b/net/py-pyroute2.ipset/pkg-descr
@@ -0,0 +1,5 @@
+PyRoute2 is a pure Python netlink library.
+
+This module provides IPSet and WiSet classes.
+
+WWW: https://github.com/svinota/pyroute2/tree/master/pyroute2.ipset