aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg A. Mamontov <oleg@mamontov.net>2023-08-30 21:01:36 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-10 16:13:02 +0000
commit42c6d0e54ad9bd941e0b805cab7f70af83139806 (patch)
tree3fed9e8bbc796fb5ef4d119182877879cac883f8
parentac2a5278212d9967773e769174f42ea430c435a0 (diff)
downloadports-42c6d0e54ad9bd941e0b805cab7f70af83139806.tar.gz
ports-42c6d0e54ad9bd941e0b805cab7f70af83139806.zip
www/angie-module-upload: Angie upload dynamic module
Module parses request body storing all files being uploaded to a directory. The files are then being stripped from body and altered request is then passed to a location specified by upload_pass directive, thus allowing arbitrary handling of uploaded files. PR: 273462
-rw-r--r--www/Makefile1
-rw-r--r--www/angie-module-upload/Makefile24
-rw-r--r--www/angie-module-upload/files/pkg-message.in15
-rw-r--r--www/angie-module-upload/pkg-descr4
-rw-r--r--www/angie-module-upload/pkg-plist3
5 files changed, 47 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2b2c1f87d6a0..5033ea3047ad 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -47,6 +47,7 @@
SUBDIR += angie-module-rtmp
SUBDIR += angie-module-set-misc
SUBDIR += angie-module-subs
+ SUBDIR += angie-module-upload
SUBDIR += angie-module-xslt
SUBDIR += anyremote2html
SUBDIR += apache-mode.el
diff --git a/www/angie-module-upload/Makefile b/www/angie-module-upload/Makefile
new file mode 100644
index 000000000000..11edfbe73956
--- /dev/null
+++ b/www/angie-module-upload/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= angie-module-upload
+GH_TUPLE= fdintino:nginx-upload-module:2.3.0:module
+
+COMMENT= Angie upload dynamic module
+
+LICENSE_FILE= ${WRKSRC_module}/LICENCE
+
+MASTERDIR= ${.CURDIR}/../../www/angie
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_LIB} ${WRKSRC}/objs/ngx_http_upload_module.so \
+ ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_MAN} ${WRKSRC_module}/README.md ${STAGEDIR}${DOCSDIR}
+
+do-install-DEBUG-on:
+ ${INSTALL} ${COPY} -m ${_SHAREMODE} \
+ ${WRKSRC_DEBUG}/objs/ngx_http_upload_module.so \
+ ${STAGEDIR}${MODDIR}/ngx_http_upload_module-debug.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/angie-module-upload/files/pkg-message.in b/www/angie-module-upload/files/pkg-message.in
new file mode 100644
index 000000000000..486a315b8560
--- /dev/null
+++ b/www/angie-module-upload/files/pkg-message.in
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+
+The upload dynamic module for Angie has been installed.
+To enable this module, add the following to %%PREFIX%%/etc/angie/angie.conf
+and reload angie:
+
+ load_module modules/ngx_http_upload_module.so;
+
+Please refer to the module documentation for further details:
+https://github.com/fdintino/nginx-upload-module
+EOM
+}
+]
diff --git a/www/angie-module-upload/pkg-descr b/www/angie-module-upload/pkg-descr
new file mode 100644
index 000000000000..ef7d0ad9aa39
--- /dev/null
+++ b/www/angie-module-upload/pkg-descr
@@ -0,0 +1,4 @@
+Module parses request body storing all files being uploaded to a directory.
+The files are then being stripped from body and altered request is then passed
+to a location specified by upload_pass directive, thus allowing arbitrary
+handling of uploaded files.
diff --git a/www/angie-module-upload/pkg-plist b/www/angie-module-upload/pkg-plist
new file mode 100644
index 000000000000..4f17dc857aa3
--- /dev/null
+++ b/www/angie-module-upload/pkg-plist
@@ -0,0 +1,3 @@
+%%DOCSDIR%%/README.md
+%%MODDIR%%/ngx_http_upload_module.so
+%%DEBUG%%%%MODDIR%%/ngx_http_upload_module-debug.so