aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:45:28 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:02 +0000
commit42fd710bc61c7718e2de2ce59a4f25c0f2723671 (patch)
tree032f054952f4f93d57a8d9adb25c43c0aa986eb0
parent452fd7d306acee4f1224cddb2822838d3271962e (diff)
downloadports-42fd710bc61c7718e2de2ce59a4f25c0f2723671.tar.gz
ports-42fd710bc61c7718e2de2ce59a4f25c0f2723671.zip
devel/py-rstr: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-rstr/Makefile9
-rw-r--r--devel/py-rstr/files/setup.py3
2 files changed, 5 insertions, 7 deletions
diff --git a/devel/py-rstr/Makefile b/devel/py-rstr/Makefile
index e4c220221c32..79ea8be40071 100644
--- a/devel/py-rstr/Makefile
+++ b/devel/py-rstr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= rstr
PORTVERSION= 3.2.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +12,12 @@ WWW= https://github.com/leapfrogonline/rstr
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=42:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.mk>
diff --git a/devel/py-rstr/files/setup.py b/devel/py-rstr/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/devel/py-rstr/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()