aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 11:48:17 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 17:42:32 +0000
commit432d465db104638da8c59175c72949cfcd145b23 (patch)
tree43a000bd1473e0094879179eb3f935e4b03b3589
parent40154a4aa70b0ba230acf68513d4904ef51df7cd (diff)
databases/postgresql-idn New port
At a fundamental level, this extension grants access to a number of functions provided by the libidn and libidn2 libraries. Not all of the functions provided by these libraries are exposed. Whenever possible, the code will transform the encoding of the data in the database to UTF-8 before further processing. WWW: https://github.com/dyninc/postgresql-idn Sponsored by: Bounce Commerce
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql-idn/Makefile41
-rw-r--r--databases/postgresql-idn/distinfo3
-rw-r--r--databases/postgresql-idn/pkg-descr6
4 files changed, 51 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 1e3bd886e531..b3cf3b7b7c56 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -652,6 +652,7 @@
SUBDIR += postgis32
SUBDIR += postgis33
SUBDIR += postgresql-cstore_fdw
+ SUBDIR += postgresql-idn
SUBDIR += postgresql-jdbc
SUBDIR += postgresql-libpgeasy
SUBDIR += postgresql-libpqxx
diff --git a/databases/postgresql-idn/Makefile b/databases/postgresql-idn/Makefile
new file mode 100644
index 000000000000..0bee9a4b11cb
--- /dev/null
+++ b/databases/postgresql-idn/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= idn
+PORTVERSION= 0.2
+CATEGORIES= databases
+PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= PostgreSQL extension for libidn2
+WWW= https://github.com/dyninc/postgresql-idn
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+LIB_DEPENDS= libidn.so:dns/libidn \
+ libidn2.so:dns/libidn2
+
+USES= gmake pgsql
+WANT_PGSQL= server
+USE_GITHUB= yes
+GH_ACCOUNT= dyninc
+GH_PROJECT= postgresql-idn
+GH_TAGNAME= d4ffaec
+
+BUILD_WRKSRC= ${WRKSRC}/sources
+
+PLIST_FILES= \
+ lib/postgresql/idn.so \
+ share/postgresql/extension/idn.control \
+ share/postgresql/extension/idn--0.2.sql
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CreateTemplateTupleDesc(3, false)|CreateTemplateTupleDesc(3)|g' \
+ ${BUILD_WRKSRC}/idn.c
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/postgresql
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/postgresql/extension
+ ${INSTALL_LIB} ${BUILD_WRKSRC}/idn.so ${STAGEDIR}${PREFIX}/lib/postgresql/idn.so
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/idn--0.2.sql ${STAGEDIR}${PREFIX}/share/postgresql/extension
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/idn.control ${STAGEDIR}${PREFIX}/share/postgresql/extension
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-idn/distinfo b/databases/postgresql-idn/distinfo
new file mode 100644
index 000000000000..3a8be0534f32
--- /dev/null
+++ b/databases/postgresql-idn/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1689853106
+SHA256 (dyninc-postgresql-idn-0.2-d4ffaec_GH0.tar.gz) = 77648e741c96ae186dcd4ce835cada228877864e390e1854c5099277337a0b06
+SIZE (dyninc-postgresql-idn-0.2-d4ffaec_GH0.tar.gz) = 14784
diff --git a/databases/postgresql-idn/pkg-descr b/databases/postgresql-idn/pkg-descr
new file mode 100644
index 000000000000..a3aca8a8234f
--- /dev/null
+++ b/databases/postgresql-idn/pkg-descr
@@ -0,0 +1,6 @@
+At a fundamental level, this extension grants access to a number of
+functions provided by the libidn and libidn2 libraries. Not all of the
+functions provided by these libraries are exposed.
+
+Whenever possible, the code will transform the encoding of the data in
+the database to UTF-8 before further processing.