aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2018-10-17 22:35:36 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2018-10-17 22:35:36 +0000
commit4330d76dbb006233f3aaaedcfcdfcc80f81838d9 (patch)
treecd883ee92075bcad2f4d697fd5ad0473d30b234d
parentf55915fb4b39fa9283d900df375cecd498610b86 (diff)
downloadports-4330d76dbb006233f3aaaedcfcdfcc80f81838d9.tar.gz
ports-4330d76dbb006233f3aaaedcfcdfcc80f81838d9.zip
Introduce python Google Cloud Vision API to
the ports tree. This API can be used to access various Google tools for manipulating images. Sponsored by: Panzura
Notes
Notes: svn path=/head/; revision=482306
-rw-r--r--www/Makefile1
-rw-r--r--www/py-google-cloud-vision/Makefile22
-rw-r--r--www/py-google-cloud-vision/distinfo3
-rw-r--r--www/py-google-cloud-vision/pkg-descr14
4 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a298ed0fa6f5..3ddb6defdf78 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1690,6 +1690,7 @@
SUBDIR += py-google-cloud-core
SUBDIR += py-google-cloud-storage
SUBDIR += py-google-cloud-translate
+ SUBDIR += py-google-cloud-vision
SUBDIR += py-google-resumable-media
SUBDIR += py-graphite-api
SUBDIR += py-graphite-web
diff --git a/www/py-google-cloud-vision/Makefile b/www/py-google-cloud-vision/Makefile
new file mode 100644
index 000000000000..0db84a859780
--- /dev/null
+++ b/www/py-google-cloud-vision/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= google-cloud-vision
+PORTVERSION= 0.34.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jpaetzel@FreeBSD.org
+COMMENT= Python Client for Google Cloud Vision
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-api-core>=0.1.1:www/py-google-api-core@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-google-cloud-vision/distinfo b/www/py-google-cloud-vision/distinfo
new file mode 100644
index 000000000000..0d152f80f501
--- /dev/null
+++ b/www/py-google-cloud-vision/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539810189
+SHA256 (google-cloud-vision-0.34.0.tar.gz) = 50392b2c68e40dbf725c531ba4d325bd910da6441a472ed0a3fadfd0ab8548f7
+SIZE (google-cloud-vision-0.34.0.tar.gz) = 1790457
diff --git a/www/py-google-cloud-vision/pkg-descr b/www/py-google-cloud-vision/pkg-descr
new file mode 100644
index 000000000000..5be9e8e9b518
--- /dev/null
+++ b/www/py-google-cloud-vision/pkg-descr
@@ -0,0 +1,14 @@
+Google Cloud Vision API enables developers to understand
+the content of an image by encapsulating powerful
+machine learning models in an easy to use REST API. It
+quickly classifies images into thousands of categories
+(e.g., sailboat, lion, Eiffel Tower), detects individual
+objects and faces within images, and finds and reads
+printed words contained within images. You can build
+metadata on your image catalog, moderate offensive
+content, or enable new marketing scenarios through image
+sentiment analysis. Analyze images uploaded in the
+request or integrate with your image storage on Google
+Cloud Storage.
+
+WWW: https://pypi.org/project/google-cloud-vision/