aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-08-11 14:23:21 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-11-06 17:49:23 +0000
commit43a873b0bccbeadef7f745f01ac7add5d365b59d (patch)
treed49bca10b56e8f4cc9de1cb5ab75abdaf7217080
parente9c3b81d5c93c5790f87151d8267dd572852c385 (diff)
downloadports-43a873b0bccbeadef7f745f01ac7add5d365b59d.tar.gz
ports-43a873b0bccbeadef7f745f01ac7add5d365b59d.zip
x11/i3lock-color: drop setuid bit via unix-selfauth-helper
pam_helper was supposed to avoid setuid bit but wasn't actually hooked. PR: 273074 Approved by: maintainer timeout (3 months)
-rw-r--r--x11/i3lock-color/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11/i3lock-color/Makefile b/x11/i3lock-color/Makefile
index f732ca37f0ec..348ee7cfaec6 100644
--- a/x11/i3lock-color/Makefile
+++ b/x11/i3lock-color/Makefile
@@ -1,6 +1,6 @@
PORTNAME= i3lock-color
DISTVERSION= 2.13.c.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MAINTAINER= fjachuf@gmail.com
@@ -9,7 +9,6 @@ WWW= https://github.com/Raymo111/i3lock-color
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ${LOCALBASE}/bin/pam_helper:security/pam_helper
LIB_DEPENDS= libev.so:devel/libev \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
@@ -19,6 +18,7 @@ LIB_DEPENDS= libev.so:devel/libev \
libxcb-xrm.so:x11/xcb-util-xrm \
libxkbcommon.so:x11/libxkbcommon \
libxkbfile.so:x11/libxkbfile
+RUN_DEPENDS= unix-selfauth-helper>0:security/unix-selfauth-helper
USES= autoreconf gmake gnome iconv jpeg localbase pkgconfig tar:bzip2 xorg
USE_CSTD= c99
@@ -38,7 +38,8 @@ LDFLAGS+= ${ICONV_LIB}
CONFLICTS_INSTALL= i3lock
-PLIST_FILES= "@(,,4755) bin/i3lock" \
+PLIST_FILES= bin/i3lock \
+ etc/pam.d/i3lock \
man/man1/i3lock.1.gz
OPTIONS_DEFINE= DOCS
@@ -49,6 +50,8 @@ DOCS_PLIST_FILES= ${DOC_FILES:S|^|${DOCSDIR_REL}/|}
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/i3lock
@${RM} ${STAGEDIR}${PREFIX}/etc/pam.d/i3lock
+ @${LN} -s ${LOCALBASE}/etc/pam.d/unix-selfauth \
+ ${STAGEDIR}${PREFIX}/etc/pam.d/i3lock
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}