aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimeon Simeonov <sgs@pichove.org>2021-12-01 09:02:37 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-12-01 09:02:37 +0000
commit44058fa9c71b7d9243a208d2d3ec8b8073686d57 (patch)
treea4ca13b1d18f70de398d8e0b2fd9ed693f1b3137
parenta944e7f1c90f6c61b0dd837637b646b1ff27fb13 (diff)
downloadports-44058fa9c71b7d9243a208d2d3ec8b8073686d57.tar.gz
ports-44058fa9c71b7d9243a208d2d3ec8b8073686d57.zip
irc/py-limnoria: Mark as not compatible with Python 3.10+
Since Python 3.10 the method "collections.MutableMapping" has been renamed to "collections.abc.MutableMapping" which leads to run time errors: [..] class CacheDict(collections.MutableMapping): AttributeError: module 'collections' has no attribute 'MutableMapping' [..] PR: 259979 Reviewed by: koobs (maintainer) Approved by: portmgr (blanket) MFH: 2021Q4
-rw-r--r--irc/py-limnoria/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/irc/py-limnoria/Makefile b/irc/py-limnoria/Makefile
index 74d89409dbed..7537894836cb 100644
--- a/irc/py-limnoria/Makefile
+++ b/irc/py-limnoria/Makefile
@@ -17,7 +17,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser@${PY_F
${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR}
-USES= cpe python:3.6+
+USES= cpe python:3.6-3.9
CPE_VENDOR= ${PORTNAME}_project
USE_GITHUB= yes
USE_PYTHON= autoplist concurrent distutils