aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-10-20 02:47:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-10-20 02:47:19 +0000
commit441a956e5fab5e8c7194b97a1d62d679f16f10e4 (patch)
treee048192e01016a85506cdba16fe2532efa34cc4c
parente90b0843c30c6c589fc330bdf9694cd61d1ac748 (diff)
downloadports-441a956e5fab5e8c7194b97a1d62d679f16f10e4.tar.gz
ports-441a956e5fab5e8c7194b97a1d62d679f16f10e4.zip
lang/libhx: the port had been updated (+)
- Update libHX to version 4.2 - Sadly, the author no longer hosts the project on SourceForge but on his own site instead, this affects MASTER_SITES and WWW line in the port description - Disable getsockopt(SO_BINDTODEVICE) call for now as FreeBSD does not implement this socket option (patches welcome) - While here, assume maintainership of the port
-rw-r--r--lang/libhx/Makefile7
-rw-r--r--lang/libhx/distinfo6
-rw-r--r--lang/libhx/files/patch-src_socket.c18
-rw-r--r--lang/libhx/pkg-descr2
-rw-r--r--lang/libhx/pkg-plist6
5 files changed, 29 insertions, 10 deletions
diff --git a/lang/libhx/Makefile b/lang/libhx/Makefile
index 5808e8060cdd..ecf8256ff922 100644
--- a/lang/libhx/Makefile
+++ b/lang/libhx/Makefile
@@ -1,17 +1,16 @@
# Created by: Sylvio Cesar <sylvio@FreeBSD.org>
PORTNAME= libHX
-PORTVERSION= 3.25
+PORTVERSION= 4.2
CATEGORIES= lang
-MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME}
+MASTER_SITES= https://inai.de/files/libhx/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= C/C++ library with common data structures and functions
LICENSE= LGPL21+
USES= cpe libtool localbase tar:xz
-
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
diff --git a/lang/libhx/distinfo b/lang/libhx/distinfo
index 9d28411aa741..64991e7c360d 100644
--- a/lang/libhx/distinfo
+++ b/lang/libhx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1589449721
-SHA256 (libHX-3.25.tar.xz) = 72ddc565dc9a5bab55438cb782ea01cec07cb6069f5e6930030b2be44cb05b89
-SIZE (libHX-3.25.tar.xz) = 890576
+TIMESTAMP = 1634477831
+SHA256 (libHX-4.2.tar.xz) = 5216b765f73c36ff91e999fd5eabc1dbc13801d140b8238fc80ba9c263d723e6
+SIZE (libHX-4.2.tar.xz) = 365120
diff --git a/lang/libhx/files/patch-src_socket.c b/lang/libhx/files/patch-src_socket.c
new file mode 100644
index 000000000000..4f185a52b567
--- /dev/null
+++ b/lang/libhx/files/patch-src_socket.c
@@ -0,0 +1,18 @@
+--- src/socket.c.orig 2021-10-17 13:36:53 UTC
++++ src/socket.c
+@@ -54,6 +54,7 @@ static int try_sk_from_env(int fd, const struct addrin
+ return -1;
+ if (intf == nullptr)
+ return fd;
++#ifdef SO_BINDTODEVICE
+ char ifname[32];
+ optlen = sizeof(ifname);
+ ret = getsockopt(fd, SOL_SOCKET, SO_BINDTODEVICE, ifname, &optlen);
+@@ -65,6 +66,7 @@ static int try_sk_from_env(int fd, const struct addrin
+ ifname[sizeof(ifname)-1] = '\0';
+ if (strcmp(intf, ifname) != 0)
+ return -1;
++#endif
+ return fd;
+ }
+
diff --git a/lang/libhx/pkg-descr b/lang/libhx/pkg-descr
index f32f04231bfa..774552121f50 100644
--- a/lang/libhx/pkg-descr
+++ b/lang/libhx/pkg-descr
@@ -11,4 +11,4 @@ secondarily, the amount of code) a developer has to spend for otherwise
implementing such. Subsequently, proficient coders can use this to
code as fast as for a scripting language.
-WWW: http://libhx.sourceforge.net/
+WWW: https://inai.de/projects/libhx/
diff --git a/lang/libhx/pkg-plist b/lang/libhx/pkg-plist
index e6ca23333235..10c14d62cd23 100644
--- a/lang/libhx/pkg-plist
+++ b/lang/libhx/pkg-plist
@@ -3,6 +3,7 @@ include/libHX/ctype_helper.h
include/libHX/defs.h
include/libHX/deque.h
include/libHX/init.h
+include/libHX/intdiff.hpp
include/libHX/io.h
include/libHX/libxml_helper.h
include/libHX/list.h
@@ -10,10 +11,11 @@ include/libHX/map.h
include/libHX/misc.h
include/libHX/option.h
include/libHX/proc.h
+include/libHX/socket.h
include/libHX/string.h
include/libHX/wx_helper.hpp
-lib/libHX_rtcheck.so
lib/libHX.so
lib/libHX.so.32
-lib/libHX.so.32.0.0
+lib/libHX.so.32.2.0
+lib/libHX_rtcheck.so
libdata/pkgconfig/libHX.pc