aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-04-12 00:16:40 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-04-12 00:22:01 +0000
commit44e66f4a5cc92f354ead52a5a80ff2b5cf88b937 (patch)
treeed7d45ad976ef575eff1b6b8ad91f58677dddc84
parent93dd70f7599ca0ff79d4050379f99445815afea0 (diff)
downloadports-44e66f4a5cc92f354ead52a5a80ff2b5cf88b937.tar.gz
ports-44e66f4a5cc92f354ead52a5a80ff2b5cf88b937.zip
x11-toolkits/gtk4-layer-shell: add new port
A library for using the Layer Shell Wayland protocol with GTK4. With this library you can build desktop shell components such as panels, notifications and wallpapers. You can use it to anchor your windows to a corner or edge of the output, or stretch them across the entire output. This Library is compatible with C, C++ and any language that supports GObject introspection files (Python, Vala, etc). https://github.com/wmww/gtk4-layer-shell
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/gtk4-layer-shell/Makefile37
-rw-r--r--x11-toolkits/gtk4-layer-shell/distinfo3
-rw-r--r--x11-toolkits/gtk4-layer-shell/pkg-descr6
-rw-r--r--x11-toolkits/gtk4-layer-shell/pkg-plist24
5 files changed, 71 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 2f5a7bdf373a..96d10e6f4eb4 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -31,6 +31,7 @@
SUBDIR += gtk-sharp30
SUBDIR += gtk20
SUBDIR += gtk30
+ SUBDIR += gtk4-layer-shell
SUBDIR += gtk40
SUBDIR += gtkd
SUBDIR += gtkdatabox
diff --git a/x11-toolkits/gtk4-layer-shell/Makefile b/x11-toolkits/gtk4-layer-shell/Makefile
new file mode 100644
index 000000000000..e1763c28c98f
--- /dev/null
+++ b/x11-toolkits/gtk4-layer-shell/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= gtk4-layer-shell
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0
+CATEGORIES= x11-toolkits
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= GTK4 library for the Wayland layer-shell protocol
+WWW= https://github.com/wmww/gtk-layer-shell
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>=1.16:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+TEST_DEPENDS= evdev-proto>0:devel/evdev-proto
+
+USES= compiler:c11 gnome meson pkgconfig vala:build
+USE_GNOME= gtk40 introspection:build
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+GH_ACCOUNT= wmww
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+DOCS_BUILD_DEPENDS= gtk-doc>0:textproc/gtk-doc
+DOCS_MESON_TRUE= docs
+
+EXAMPLES_MESON_TRUE= examples
+
+pre-test:
+ @if [ ! -e ${WRKDIR}/.meson_build_tests ]; then \
+ ${RM} ${CONFIGURE_COOKIE} ${BUILD_COOKIE}; \
+ ${MAKE} -C${.CURDIR} build MESON_ARGS="${MESON_ARGS} --reconfigure -Dtests=true"; \
+ ${TOUCH} ${WRKDIR}/.meson_build_tests; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk4-layer-shell/distinfo b/x11-toolkits/gtk4-layer-shell/distinfo
new file mode 100644
index 000000000000..e926c3e26f68
--- /dev/null
+++ b/x11-toolkits/gtk4-layer-shell/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1666530455
+SHA256 (wmww-gtk4-layer-shell-v1.0.0_GH0.tar.gz) = 89d25ca0a7c2db7795c6bfb46e7d504ee71f005b3ea8580c8e9e35b57027be92
+SIZE (wmww-gtk4-layer-shell-v1.0.0_GH0.tar.gz) = 61143
diff --git a/x11-toolkits/gtk4-layer-shell/pkg-descr b/x11-toolkits/gtk4-layer-shell/pkg-descr
new file mode 100644
index 000000000000..cbca3b44798a
--- /dev/null
+++ b/x11-toolkits/gtk4-layer-shell/pkg-descr
@@ -0,0 +1,6 @@
+A library for using the Layer Shell Wayland protocol with GTK4. With
+this library you can build desktop shell components such as panels,
+notifications and wallpapers. You can use it to anchor your windows to
+a corner or edge of the output, or stretch them across the entire
+output. This Library is compatible with C, C++ and any language that
+supports GObject introspection files (Python, Vala, etc).
diff --git a/x11-toolkits/gtk4-layer-shell/pkg-plist b/x11-toolkits/gtk4-layer-shell/pkg-plist
new file mode 100644
index 000000000000..f6c2af90a821
--- /dev/null
+++ b/x11-toolkits/gtk4-layer-shell/pkg-plist
@@ -0,0 +1,24 @@
+%%PORTEXAMPLES%%bin/gtk4-layer-demo
+include/gtk4-layer-shell/gtk4-layer-shell.h
+lib/girepository-1.0/Gtk4LayerShell-1.0.typelib
+lib/libgtk4-layer-shell.so
+lib/libgtk4-layer-shell.so.0
+lib/libgtk4-layer-shell.so.1.0.0
+libdata/pkgconfig/gtk4-layer-shell-0.pc
+share/gir-1.0/Gtk4LayerShell-1.0.gir
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/api-index-full.html
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/deprecated-api-index.html
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/gtk-layer-shell-GTK4-Layer-Shell.html
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/gtk-layer-shell.devhelp2
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/gtk4-layer-shell.html
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/home.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/index.html
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/left-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/left.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/right-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/right.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/style.css
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/up-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/gtk-layer-shell/up.png
+share/vala/vapi/gtk4-layer-shell-0.deps
+share/vala/vapi/gtk4-layer-shell-0.vapi