aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Bibaut <yom@iaelu.net>2022-07-08 06:38:53 +0000
committerMikael Urankar <mikael@FreeBSD.org>2022-07-08 14:25:43 +0000
commit4588423cca935e99b093ce56e24bb629c439d706 (patch)
treeb1045d8d02178dd8bf0db37e0611ecef90d4883b
parentc56da4a4b0a36b1d6b03f0d3806e663a685fea70 (diff)
downloadports-4588423cca935e99b093ce56e24bb629c439d706.tar.gz
ports-4588423cca935e99b093ce56e24bb629c439d706.zip
www/deno: Fix parseFileInfo
Add freebsd to the list so that parseFileInfo returns correct information. PR: 265080
-rw-r--r--www/deno/Makefile2
-rw-r--r--www/deno/files/patch-runtime_js_30__fs.js11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/deno/Makefile b/www/deno/Makefile
index b8310386db94..6a93836b5a13 100644
--- a/www/deno/Makefile
+++ b/www/deno/Makefile
@@ -1,7 +1,7 @@
PORTNAME= deno
DISTVERSIONPREFIX= v
DISTVERSION= 1.23.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= mikael@FreeBSD.org
diff --git a/www/deno/files/patch-runtime_js_30__fs.js b/www/deno/files/patch-runtime_js_30__fs.js
new file mode 100644
index 000000000000..3f6d98dbbeb3
--- /dev/null
+++ b/www/deno/files/patch-runtime_js_30__fs.js
@@ -0,0 +1,11 @@
+--- runtime/js/30_fs.js.orig 2022-07-08 08:14:40.658820000 +0200
++++ runtime/js/30_fs.js 2022-07-08 08:15:13.943527000 +0200
+@@ -178,7 +178,7 @@
+ }
+
+ function parseFileInfo(response) {
+- const unix = build.os === "darwin" || build.os === "linux";
++ const unix = build.os === "darwin" || build.os === "freebsd" || build.os === "linux";
+ return {
+ isFile: response.isFile,
+ isDirectory: response.isDirectory,