aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-16 16:09:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-16 16:24:48 +0000
commit45b8d900432ead25934b4e6c4e44310b9ab00ca7 (patch)
tree85c784526c9843fa3b1f0dd8b6eed86e4c4b974e
parentd6119b94a3dad8233f2da6dee1c957d205ad69ee (diff)
downloadports-45b8d900432ead25934b4e6c4e44310b9ab00ca7.tar.gz
ports-45b8d900432ead25934b4e6c4e44310b9ab00ca7.zip
audio/faust-lv2: Broken on riscv64
Reported by: fallout
-rw-r--r--audio/faust-lv2/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/audio/faust-lv2/Makefile b/audio/faust-lv2/Makefile
index 9a9c06a53721..21940234c3b9 100644
--- a/audio/faust-lv2/Makefile
+++ b/audio/faust-lv2/Makefile
@@ -15,6 +15,7 @@ BROKEN_aarch64= fails to link: can't create dynamic relocation R_AARCH64_ADR_PR
.if ${/usr/bin/ld:L:tA} == /usr/bin/ld.lld
BROKEN_i386= ld: error: can't create dynamic relocation R_386_32 against symbol: vtable for LV2UI in readonly segment
.endif
+BROKEN_riscv64= can't create dynamic relocation R_RISCV_LO12_I against symbol: vtable for LV2UI in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
BUILD_DEPENDS= lv2>0:audio/lv2 \
faust>0:audio/faust \
@@ -32,7 +33,7 @@ CFLAGS_armv7= -fPIC
CFLAGS_powerpc= -fPIC
CFLAGS_powerpc64= -fPIC
CFLAGS_powerpc64le= -fPIC
-LDFLAGS+= -fPIC # recommended by 13i386 failure messages, it was only failing
+LDFLAGS+= -fPIC # recommended by 13i386 failure messages, it was only failing
OPTIONS_DEFINE_amd64= SIMD
OPTIONS_DEFINE_i386= SIMD