aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-07-01 21:11:38 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-07-01 21:36:26 +0000
commit45dc4cd01181ed22fbb209d371e676f7f4777920 (patch)
treed1c7c9f18a4730eadf5a372492618b67d321a191
parentb8b4094a465f9fcc646b4d1f01871f8f220cfc92 (diff)
downloadports-45dc4cd01181ed22fbb209d371e676f7f4777920.tar.gz
ports-45dc4cd01181ed22fbb209d371e676f7f4777920.zip
x11/waybar: add @nopulse flavor (aka waybar-nopulse)
pulseaudio is a heavy dependency but waybar also supports sndio e.g., $ pkg install sway waybar mpv firefox $ pkg install waybar-nopulse $ pkg autoremove Checking integrity... done (0 conflicting) Deinstallation has been requested for the following 11 packages: Installed packages to be REMOVED: consolekit2: 1.2.4_3 fftw3: 3.3.10_2 fftw3-float: 3.3.10_2 flac: 1.3.4 libltdl: 2.4.7 libsndfile: 1.0.31_1 libsoxr: 0.1.3_3 orc: 0.4.31 pulseaudio: 14.2_4 speexdsp: 1.2.1 webrtc-audio-processing0: 0.3.1_2 Number of packages to be removed: 11 The operation will free 25 MiB. PR: 264678
-rw-r--r--x11/waybar/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/x11/waybar/Makefile b/x11/waybar/Makefile
index c6d45caadbad..904e4afa542f 100644
--- a/x11/waybar/Makefile
+++ b/x11/waybar/Makefile
@@ -20,6 +20,11 @@ LIB_DEPENDS= libdate-tz.so:devel/date \
libxkbregistry.so:x11/libxkbcommon
TEST_DEPENDS= catch>0:devel/catch
+FLAVORS= default nopulse
+default_CONFLICTS_INSTALL= ${PORTNAME}-nopulse
+nopulse_CONFLICTS_INSTALL= ${PORTNAME}
+nopulse_PKGNAMESUFFIX= -nopulse
+
USES= compiler:c++17-lang gnome meson pkgconfig
USE_GITHUB= yes
USE_GNOME= gtkmm30
@@ -37,6 +42,9 @@ SUB_FILES+= date.pc
OPTIONS_DEFINE= DBUS EVDEV GLS ICONSFONT MANPAGES MPD PULSEAUDIO SNDIO UDEV UPOWER
OPTIONS_DEFAULT=DBUS EVDEV GLS ICONSFONT MANPAGES MPD PULSEAUDIO SNDIO UDEV UPOWER
+.if ${FLAVOR:U} == nopulse
+OPTIONS_EXCLUDE=PULSEAUDIO
+.endif
DBUS_LIB_DEPENDS= libdbusmenu-gtk3.so:devel/libdbusmenu
DBUS_MESON_ENABLED= dbusmenu-gtk