aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2022-01-08 20:42:49 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2022-02-05 01:17:21 +0000
commit461373bf1f104917f16cf783dd7d80d2951a993e (patch)
treea6b29d90412b35571c5413d88c511018e11cb989
parent85f832623ad8269c0e53f79093eee19267aaa3e6 (diff)
downloadports-461373bf1f104917f16cf783dd7d80d2951a993e.tar.gz
ports-461373bf1f104917f16cf783dd7d80d2951a993e.zip
*/*: Cleanup after the removal of lang/python36
* Remove codes that aren't necessary after the removal of lang/python36 * Mark ports that aren't necessary with Python 3.7 or later as DEPRECATED and set EXPIRATION_DATE. PR: 261046 Approved by: lwhsu (python)
-rw-r--r--databases/py-databases/Makefile8
-rw-r--r--devel/py-aiortc/Makefile8
-rw-r--r--devel/py-dataclasses/Makefile3
-rw-r--r--net/irrd/Makefile8
-rw-r--r--net/py-netaddr/Makefile8
-rw-r--r--net/py-wsproto/Makefile8
-rw-r--r--sysutils/py-python-crontab/Makefile9
-rw-r--r--textproc/py-fingerprints/Makefile9
-rw-r--r--textproc/py-normality/Makefile9
-rw-r--r--www/py-aiohttp/Makefile8
-rw-r--r--www/py-dj32-django-treebeard/Makefile9
-rw-r--r--www/py-django-markdownx/Makefile11
-rw-r--r--www/py-django-treebeard/Makefile9
-rw-r--r--www/qutebrowser/Makefile4
14 files changed, 15 insertions, 96 deletions
diff --git a/databases/py-databases/Makefile b/databases/py-databases/Makefile
index cd784f6c4efe..d7528bc572b2 100644
--- a/databases/py-databases/Makefile
+++ b/databases/py-databases/Makefile
@@ -41,10 +41,4 @@ SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiosqlite>0:databases/py-aiosqlite@${
# do-test:
# cd ${WRKSRC} && ${SETENV} ${TEST_ENV} TEST_DATABASE_URLS="sqlite:///testsuite" ${PYTHON_CMD} -m pytest -v -rs -o addopts=
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 30700
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}aiocontextvars>=0:devel/py-aiocontextvars@${PY_FLAVOR}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-aiortc/Makefile b/devel/py-aiortc/Makefile
index 892c2f63ca5e..75ca757e8759 100644
--- a/devel/py-aiortc/Makefile
+++ b/devel/py-aiortc/Makefile
@@ -26,10 +26,4 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aioice>=0.7.5:devel/py-aioice@${PY_FLAVOR} \
USES= localbase python:3.5+
USE_PYTHON= autoplist concurrent distutils
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 30700
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dataclasses>=0:devel/py-dataclasses@${PY_FLAVOR}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-dataclasses/Makefile b/devel/py-dataclasses/Makefile
index fdd23968bd32..3694c2deeea2 100644
--- a/devel/py-dataclasses/Makefile
+++ b/devel/py-dataclasses/Makefile
@@ -10,6 +10,9 @@ COMMENT= Backport of the dataclasses module for Python 3.6
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+DEPRECATED= Included in Python 3.7 or later
+EXPIRATION_DATE= 2022-03-31
+
USES= python:3.6
USE_PYTHON= distutils autoplist
diff --git a/net/irrd/Makefile b/net/irrd/Makefile
index 971ccb9e490a..c8fbe5bd01bb 100644
--- a/net/irrd/Makefile
+++ b/net/irrd/Makefile
@@ -56,12 +56,6 @@ SUB_LIST= PYTHON_CMD="${PYTHON_CMD}" \
USERS=${USERS} \
GROUPS=${GROUPS}
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 30700
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dataclasses>=0.6:devel/py-dataclasses@${PY_FLAVOR}
-.endif
-
post-install:
${INSTALL_DATA} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/conf/default_config.yaml \
${STAGEDIR}${PREFIX}/etc/${PORTNAME}${PKGNAMESUFFIX}.yaml.sample
@@ -69,4 +63,4 @@ post-install:
do-test:
@(cd ${TEST_WRKSRC} && ${SETENV} pytest ${PORTNAME})
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/py-netaddr/Makefile b/net/py-netaddr/Makefile
index a71918f04646..7459ad4eed27 100644
--- a/net/py-netaddr/Makefile
+++ b/net/py-netaddr/Makefile
@@ -23,12 +23,6 @@ PORTDOCS= AUTHORS CHANGELOG README.rst
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 30700
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>0:devel/py-importlib-resources@${PY_FLAVOR}
-.endif
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
@@ -36,4 +30,4 @@ post-install-DOCS-on:
do-test:
@cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/py-wsproto/Makefile b/net/py-wsproto/Makefile
index df222608d6c1..252b53891768 100644
--- a/net/py-wsproto/Makefile
+++ b/net/py-wsproto/Makefile
@@ -19,13 +19,7 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 30700
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dataclasses>0:devel/py-dataclasses@${PY_FLAVOR}
-.endif
-
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/py-python-crontab/Makefile b/sysutils/py-python-crontab/Makefile
index b740eda4650a..6a92faeafb2b 100644
--- a/sysutils/py-python-crontab/Makefile
+++ b/sysutils/py-python-crontab/Makefile
@@ -23,14 +23,7 @@ USE_GITLAB= yes
GL_ACCOUNT= doctormo
GL_COMMIT= ba23056ddf1a00ecfd14b0a31c2e0cdad132f8d0
-.include <bsd.port.pre.mk>
-
-# The UTF-8 mode is enabled by default when the locale is C since Python 3.7.
-.if ${PYTHON_REL} < 30700
-TEST_ENV+= LC_ALL=C.UTF-8
-.endif
-
do-test:
@cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/py-fingerprints/Makefile b/textproc/py-fingerprints/Makefile
index a86d600fe4bf..a4fbf17ab602 100644
--- a/textproc/py-fingerprints/Makefile
+++ b/textproc/py-fingerprints/Makefile
@@ -19,14 +19,7 @@ USE_PYTHON= distutils autoplist
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-# Set a locale to avoid build/configure errors. The UTF-8 mode is enabled by
-# default when the locale is C since Python 3.7.
-.if ${PYTHON_REL} < 30700
-USE_LOCALE= en_US.UTF-8
-.endif
-
do-test:
@cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/py-normality/Makefile b/textproc/py-normality/Makefile
index ba2501660589..1465d2d33abd 100644
--- a/textproc/py-normality/Makefile
+++ b/textproc/py-normality/Makefile
@@ -26,14 +26,7 @@ OPTIONS_DEFAULT= ICU
ICU_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyicu>=1.9.3:devel/py-pyicu@${PY_FLAVOR}
-.include <bsd.port.pre.mk>
-# Set a locale to avoid build/configure errors. The UTF-8 mode is enabled by
-# default when the locale is C since Python 3.7.
-.if ${PYTHON_REL} < 30700
-USE_LOCALE= en_US.UTF-8
-.endif
-
do-test:
@cd ${WRKSRC} && ${SET_ENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/py-aiohttp/Makefile b/www/py-aiohttp/Makefile
index 7d8f1286355b..1ffbd08d7e5f 100644
--- a/www/py-aiohttp/Makefile
+++ b/www/py-aiohttp/Makefile
@@ -34,12 +34,6 @@ USES= cpe python:3.6+
CPE_VENDOR= ${PORTNAME}_project
USE_PYTHON= autoplist distutils cython
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 30700
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}idna_ssl>=1.0:dns/py-idna_ssl@${PY_FLAVOR}
-.endif
-
pre-configure:
.for file in _frozenlist _helpers _http_parser _http_writer _websocket
@${RM} ${WRKSRC}/aiohttp/${file}.c
@@ -52,4 +46,4 @@ post-install:
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/py-dj32-django-treebeard/Makefile b/www/py-dj32-django-treebeard/Makefile
index 723f50155474..05c071a83f1c 100644
--- a/www/py-dj32-django-treebeard/Makefile
+++ b/www/py-dj32-django-treebeard/Makefile
@@ -25,13 +25,6 @@ DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=2.2:www/py-django32@${PY_FL
${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
-.include <bsd.port.pre.mk>
-# Set a locale to avoid build/configure errors. The UTF-8 mode is enabled by
-# default when the locale is C since Python 3.7.
-.if ${PYTHON_REL} < 30700
-USE_LOCALE= en_US.UTF-8
-.endif
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC}/build/sphinx/html && \
@@ -41,4 +34,4 @@ post-install-DOCS-on:
do-test:
@cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/py-django-markdownx/Makefile b/www/py-django-markdownx/Makefile
index ef2b5aceb7d4..8baa24801fdb 100644
--- a/www/py-django-markdownx/Makefile
+++ b/www/py-django-markdownx/Makefile
@@ -21,13 +21,4 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 30700
-# Force an UTF-8 environment to avoid failures in the configuration phase for
-# Python versions <= 3.6. Since Python 3.7 the UTF-8 mode is enabled by
-# default when the locale is C.
-USE_LOCALE= en_US.UTF-8
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/py-django-treebeard/Makefile b/www/py-django-treebeard/Makefile
index 1a9605c1495f..49adb2be8380 100644
--- a/www/py-django-treebeard/Makefile
+++ b/www/py-django-treebeard/Makefile
@@ -25,13 +25,6 @@ DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django22>=2.2:www/py-django22@${PY_FL
${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
-.include <bsd.port.pre.mk>
-# Set a locale to avoid build/configure errors. The UTF-8 mode is enabled by
-# default when the locale is C since Python 3.7.
-.if ${PYTHON_REL} < 30700
-USE_LOCALE= en_US.UTF-8
-.endif
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC}/build/sphinx/html && \
@@ -41,4 +34,4 @@ post-install-DOCS-on:
do-test:
@cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/qutebrowser/Makefile b/www/qutebrowser/Makefile
index 2f76ef3475ab..8d6bb142f547 100644
--- a/www/qutebrowser/Makefile
+++ b/www/qutebrowser/Makefile
@@ -40,10 +40,6 @@ WEBENGINE_USE= PYQT=webengine
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 30700
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dataclasses>0:devel/py-dataclasses@${PY_FLAVOR}
-.endif
-
.if ${PYTHON_REL} < 30900
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>0:devel/py-importlib-resources@${PY_FLAVOR}
.endif