aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2023-12-29 06:04:51 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2023-12-29 06:10:44 +0000
commit466d866ac89abb1884c3c3efc5d96b18e7526a2b (patch)
tree9ca1e3a8a6cfa620df33ecb1dcd1ef5754db6cf1
parenta45a17df6fed6abf26daa89df8dc94c5657f5ea3 (diff)
downloadports-466d866ac89abb1884c3c3efc5d96b18e7526a2b.tar.gz
ports-466d866ac89abb1884c3c3efc5d96b18e7526a2b.zip
net/haproxy: revert QUIC support: it does not work with non-OpenSSL SSL implementations. We need to explicitly support LibreSSL.
PR: 267388 Reported by: Ivan Rozhuk <rozhuk.im@gmail.com>
-rw-r--r--net/haproxy/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 51aabf3a0140..b67eac5bc4b7 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -1,6 +1,6 @@
PORTNAME= haproxy
DISTVERSION= 2.8.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net www
MASTER_SITES= http://www.haproxy.org/download/2.8/src/
@@ -55,7 +55,7 @@ DEVICEATLAS_LIB_DEPENDS= libda.so:net/deviceatlas-enterprise-c
DEVICEATLAS_MAKE_ARGS= USE_DEVICEATLAS=1 DEVICEATLAS_LIB=${LOCALBASE}/lib DEVICEATLAS_INC=${LOCALBASE}/include
PROMEX_MAKE_ARGS= USE_PROMEX=1
OPENSSL_USES= ssl
-OPENSSL_MAKE_ARGS= USE_OPENSSL=1 USE_QUIC=1 USE_QUIC_OPENSSL_COMPAT=1 SSL_LIB=${OPENSSLLIB} SSL_INC=${OPENSSLINC}
+OPENSSL_MAKE_ARGS= USE_OPENSSL=1 SSL_LIB=${OPENSSLLIB} SSL_INC=${OPENSSLINC}
LUA_USES= lua:53
LUA_MAKE_ARGS= USE_LUA=1 LUA_INC=${LUA_INCDIR} LUA_LIB=${LUA_LIBDIR} LUA_LIB_NAME=lua-${LUA_VER}