aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-04 03:41:36 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-04 03:42:24 +0000
commit47039c31681e9cafaad22cb29a7cd50bf5b25f39 (patch)
tree9fe5ee8df31a8f26044d3375abf51910f8a13b95
parent1ae4f19bf1d21c5878a2a4802438a536b13f8657 (diff)
www/py-werkzeug21: Add py-werkzeug21 2.1.2 (copied from py-werkzeug)
- Add PORTSCOUT
-rw-r--r--www/Makefile1
-rw-r--r--www/py-werkzeug21/Makefile31
-rw-r--r--www/py-werkzeug21/distinfo3
-rw-r--r--www/py-werkzeug21/pkg-descr12
-rw-r--r--www/py-werkzeug21/pkg-plist110
5 files changed, 157 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f3080573539a..92218229d21e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1781,6 +1781,7 @@
SUBDIR += py-websocket-client
SUBDIR += py-webunit
SUBDIR += py-werkzeug
+ SUBDIR += py-werkzeug21
SUBDIR += py-wfuzz
SUBDIR += py-whitenoise
SUBDIR += py-wikipedia
diff --git a/www/py-werkzeug21/Makefile b/www/py-werkzeug21/Makefile
new file mode 100644
index 000000000000..b4dcfc6235d9
--- /dev/null
+++ b/www/py-werkzeug21/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= werkzeug
+PORTVERSION= 2.1.2
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 21
+DISTNAME= Werkzeug-${DISTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python utilities collection for building WSGI applications
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+USES= cpe python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+CPE_VENDOR= palletsprojects
+
+OPTIONS_DEFINE= EXAMPLES WATCHDOG
+WATCHDOG_DESC= Monitor filesystem events
+
+WATCHDOG_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}watchdog>=0:devel/py-watchdog@${PY_FLAVOR}
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/www/py-werkzeug21/distinfo b/www/py-werkzeug21/distinfo
new file mode 100644
index 000000000000..72cb452b1a73
--- /dev/null
+++ b/www/py-werkzeug21/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1651316657
+SHA256 (Werkzeug-2.1.2.tar.gz) = 1ce08e8093ed67d638d63879fd1ba3735817f7a80de3674d293f5984f25fb6e6
+SIZE (Werkzeug-2.1.2.tar.gz) = 835169
diff --git a/www/py-werkzeug21/pkg-descr b/www/py-werkzeug21/pkg-descr
new file mode 100644
index 000000000000..2dffdf081126
--- /dev/null
+++ b/www/py-werkzeug21/pkg-descr
@@ -0,0 +1,12 @@
+A Python utilities collection for building WSGI applications.
+
+Werkzeug does not try to be a framework, and instead started as a simple
+collection of various utilities useful for building WSGI applications.
+It has since become one of the most advanced collections of its kind.
+
+It includes a powerful debugger, fully featured request and response
+objects, HTTP utilities to handle entity tags, cache control headers,
+HTTP dates, cookie handling, file uploads, a powerful URL routing
+system and a bunch of community contributed add-on modules.
+
+WWW: https://palletsprojects.com/p/werkzeug/
diff --git a/www/py-werkzeug21/pkg-plist b/www/py-werkzeug21/pkg-plist
new file mode 100644
index 000000000000..e026201975c7
--- /dev/null
+++ b/www/py-werkzeug21/pkg-plist
@@ -0,0 +1,110 @@
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.rst
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/application.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/helpers.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/public/style.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/templates/layout.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/templates/static/about.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/templates/static/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/templates/static/not_found.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/utils.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/views/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coolmagic/views/static.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/application.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/models.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/static/style.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/templates/display.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/templates/layout.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/templates/list.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/templates/new.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/templates/not_found.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/utils.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/couchy/views.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/application.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/db.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/network.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/pages.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/shared/content.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/shared/down.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/shared/favicon.ico
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/shared/header.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/shared/logo.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/shared/style.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/shared/up.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/templates/layout.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/templates/missingpage.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/templates/search.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/templates/server.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/templates/serverlist.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cupoftee/utils.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/httpbasicauth.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18nurls/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18nurls/application.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18nurls/templates/about.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18nurls/templates/blog.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18nurls/templates/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18nurls/templates/layout.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18nurls/urls.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18nurls/views.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manage-coolmagic.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manage-couchy.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manage-cupoftee.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manage-i18nurls.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manage-plnt.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manage-shorty.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manage-simplewiki.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/manage-webpylike.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partial/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partial/complex_routing.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plnt/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plnt/database.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plnt/shared/style.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plnt/sync.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plnt/templates/about.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plnt/templates/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plnt/templates/layout.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plnt/utils.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plnt/views.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plnt/webapp.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shortly/shortly.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shortly/static/style.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shortly/templates/404.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shortly/templates/layout.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shortly/templates/new_url.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shortly/templates/short_link_details.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/application.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/models.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/static/style.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/templates/display.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/templates/layout.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/templates/list.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/templates/new.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/templates/not_found.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/utils.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shorty/views.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/actions.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/application.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/database.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/shared/style.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/specialpages.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/action_diff.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/action_edit.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/action_log.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/action_revert.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/action_show.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/layout.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/macros.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/missing_action.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/page_index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/page_missing.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/templates/recent_changes.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplewiki/utils.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/webpylike/example.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/webpylike/webpylike.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wsecho.py