aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-12-21 20:16:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-12-21 20:19:28 +0000
commit47273d2d89eb3808689194d72dd321ae811f73f1 (patch)
treedcfeb9f7c2737e921f1d7367738f5ba37f34cc54
parent48f4cb3e159c091b90d1c7162365d351d6afb940 (diff)
downloadports-47273d2d89eb3808689194d72dd321ae811f73f1.tar.gz
ports-47273d2d89eb3808689194d72dd321ae811f73f1.zip
math/gismo: Update 0.8.4-849 -> 21.12.0
Reported by: portscout
-rw-r--r--math/gismo/Makefile7
-rw-r--r--math/gismo/distinfo14
-rw-r--r--math/gismo/files/patch-src_gsCore_gsLinearAlgebra.h11
-rw-r--r--math/gismo/files/patch-src_gsIO_gsFileManager.cpp13
-rw-r--r--math/gismo/pkg-plist5
5 files changed, 29 insertions, 21 deletions
diff --git a/math/gismo/Makefile b/math/gismo/Makefile
index 3c43f787c19d..835a30c2407b 100644
--- a/math/gismo/Makefile
+++ b/math/gismo/Makefile
@@ -1,7 +1,6 @@
PORTNAME= gismo
DISTVERSIONPREFIX= v
-DISTVERSION= 0.8.4-849
-DISTVERSIONSUFFIX= -g8b36bfe5
+DISTVERSION= 21.12.0
CATEGORIES= math # geometry
MAINTAINER= yuri@FreeBSD.org
@@ -17,7 +16,9 @@ USE_LDCONFIG= yes
CMAKE_TESTING_ON= GISMO_BUILD_UNITTESTS # one test is known to fail: https://github.com/gismo/gismo/issues/466
-GH_TUPLE= gismo:gsElasticity:7bfde6d:gsElasticity/extensions/gsElasticity \
+GH_TUPLE= gismo:gsElasticity:a94347d:gsElasticity/extensions/gsElasticity \
+ gismo:gsKLShell:5247352:gsKLShell/extensions/gsKLShell \
+ gismo:gsStructuralAnalysis:f18c4b7:gsStructuralAnalysis/extensions/gsStructuralAnalysis \
gismo:gsUnitTest:7c42e58:gsUnitTest/extensions/gsUnitTest
.include <bsd.port.pre.mk>
diff --git a/math/gismo/distinfo b/math/gismo/distinfo
index 17722b97269b..43ff89bacc92 100644
--- a/math/gismo/distinfo
+++ b/math/gismo/distinfo
@@ -1,7 +1,11 @@
-TIMESTAMP = 1628817047
-SHA256 (gismo-gismo-v0.8.4-849-g8b36bfe5_GH0.tar.gz) = a5db6ef29024f0d4d34228228c1d84d72e21b546a37da9a0f14700c69d2ba9aa
-SIZE (gismo-gismo-v0.8.4-849-g8b36bfe5_GH0.tar.gz) = 4945758
-SHA256 (gismo-gsElasticity-7bfde6d_GH0.tar.gz) = 1f9e76b148670dad8ee5c7960218cf6f1d4ffc730ca20755ef0c66980bb3276f
-SIZE (gismo-gsElasticity-7bfde6d_GH0.tar.gz) = 280973
+TIMESTAMP = 1640112553
+SHA256 (gismo-gismo-v21.12.0_GH0.tar.gz) = 4001b4c49661ca8b71baf915e773341e115d154077bef218433a3c1d72ee4f0c
+SIZE (gismo-gismo-v21.12.0_GH0.tar.gz) = 4957758
+SHA256 (gismo-gsElasticity-a94347d_GH0.tar.gz) = 4f8f88347fda4c31e7d366ab79ed19681d8cd4cdfc50947b7be8084e93aca169
+SIZE (gismo-gsElasticity-a94347d_GH0.tar.gz) = 281441
+SHA256 (gismo-gsKLShell-5247352_GH0.tar.gz) = 7b7f6764f21c28b276ec1b62fb4e66c3ae763c996bf473200ae4b0345024350f
+SIZE (gismo-gsKLShell-5247352_GH0.tar.gz) = 77777
+SHA256 (gismo-gsStructuralAnalysis-f18c4b7_GH0.tar.gz) = 6d0027cd3f9aadb55a7ad01293df31c33f6ee500cc3f9a8eb90d6d87f0d239e6
+SIZE (gismo-gsStructuralAnalysis-f18c4b7_GH0.tar.gz) = 616060
SHA256 (gismo-gsUnitTest-7c42e58_GH0.tar.gz) = 67318cc0b685ad2d17199a78c916aa19ac306f3ce4e1679d01f398f117cf12ca
SIZE (gismo-gsUnitTest-7c42e58_GH0.tar.gz) = 22779
diff --git a/math/gismo/files/patch-src_gsCore_gsLinearAlgebra.h b/math/gismo/files/patch-src_gsCore_gsLinearAlgebra.h
deleted file mode 100644
index e68b7d48dbde..000000000000
--- a/math/gismo/files/patch-src_gsCore_gsLinearAlgebra.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gsCore/gsLinearAlgebra.h.orig 2021-08-13 01:12:20 UTC
-+++ src/gsCore/gsLinearAlgebra.h
-@@ -84,7 +84,7 @@ using Eigen::internal::cast; // from Core/MathFunction
- and https://en.wikipedia.org/wiki/NaN
- */
- template<typename Derived>
--inline bool isnumber(const Eigen::MatrixBase<Derived>& x)
-+inline bool isnumber_x(const Eigen::MatrixBase<Derived>& x)
- { return ((x.array() == x.array())).all(); }
-
- /**
diff --git a/math/gismo/files/patch-src_gsIO_gsFileManager.cpp b/math/gismo/files/patch-src_gsIO_gsFileManager.cpp
new file mode 100644
index 000000000000..391707efc8a3
--- /dev/null
+++ b/math/gismo/files/patch-src_gsIO_gsFileManager.cpp
@@ -0,0 +1,13 @@
+--- src/gsIO/gsFileManager.cpp.orig 2021-12-21 18:59:36 UTC
++++ src/gsIO/gsFileManager.cpp
+@@ -40,6 +40,10 @@
+ #include <limits.h>
+ #endif
+
++#if defined __FreeBSD__
++#include <sys/syslimits.h>
++#endif
++
+ namespace gismo
+ {
+
diff --git a/math/gismo/pkg-plist b/math/gismo/pkg-plist
index 6fda8b04f20d..9521c53859fa 100644
--- a/math/gismo/pkg-plist
+++ b/math/gismo/pkg-plist
@@ -12,6 +12,7 @@ bin/fileIo_example
bin/fitting_example
bin/geometry_example
bin/gsInterpolateMap
+bin/gsMakeMultiPatch
bin/gsPatchFromBoundary
bin/gsView
bin/heatEquation_example
@@ -587,8 +588,8 @@ lib/gismo/gsConfig.cmake
lib/gismo/gsDebugExtra.cmake
lib/libgismo.a
lib/libgismo.so
-lib/libgismo.so.20
-lib/libgismo.so.20.12.0
+lib/libgismo.so.21
+lib/libgismo.so.21.12.0
%%DATADIR%%data/bspbasis/tpBSpline2_01.xml
%%DATADIR%%data/bspbasis/tpBSpline2_02.xml
%%DATADIR%%data/curves3d/bspline3d_curve_01.xml