aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2021-09-06 19:15:53 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-09-06 20:04:22 +0000
commit473a0e375ef3e4ffc058478ce07908e5e06e7bc6 (patch)
tree771e995354f9811c24a12edd425334322cd559ee
parent17e0a02dec621d59b71d3654d61f63a6b40a901c (diff)
downloadports-473a0e375ef3e4ffc058478ce07908e5e06e7bc6.tar.gz
ports-473a0e375ef3e4ffc058478ce07908e5e06e7bc6.zip
lang/rust: don't overwrite hwcap with the return value of elf_aux_info(3)
Reported by: jbeich
-rw-r--r--lang/rust/Makefile2
-rw-r--r--lang/rust/files/patch-src_llvm-project_compiler-rt_lib_builtins_cpu__model.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 25ba0b104626..da3b0ae3ebba 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -2,7 +2,7 @@
PORTNAME= rust
PORTVERSION?= 1.54.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= lang
MASTER_SITES= https://static.rust-lang.org/dist/:src \
https://dev-static.rust-lang.org/dist/:src \
diff --git a/lang/rust/files/patch-src_llvm-project_compiler-rt_lib_builtins_cpu__model.c b/lang/rust/files/patch-src_llvm-project_compiler-rt_lib_builtins_cpu__model.c
index ee00760e61c6..b58648815199 100644
--- a/lang/rust/files/patch-src_llvm-project_compiler-rt_lib_builtins_cpu__model.c
+++ b/lang/rust/files/patch-src_llvm-project_compiler-rt_lib_builtins_cpu__model.c
@@ -9,7 +9,7 @@
+#if defined(__linux__)
+ hwcap = getauxval(AT_HWCAP);
+#elif defined(__FreeBSD__)
-+ hwcap = elf_aux_info(AT_HWCAP, &hwcap, sizeof(unsigned long));
++ elf_aux_info(AT_HWCAP, &hwcap, sizeof(unsigned long));
+#endif
__aarch64_have_lse_atomics = (hwcap & HWCAP_ATOMICS) != 0;
}