aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-06 15:59:26 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-06 16:01:16 +0000
commit47626f58b2bda4fab4c27eab24044b4c3b616b5a (patch)
treec61ba275cd3fd8e9b28cc8c41cab5a01386df284
parent6bb17a9fe3ec47e45c6607b7e76f71afda7dbced (diff)
devel/py-mutf8: Add py-mutf8 1.0.6
mutf-8 contains simple pure-python as well as C encoders and decoders for the MUTF-8 character encoding. In most cases, you can also parse the even-rarer CESU-8. These days, you'll most likely encounter MUTF-8 when working on files or protocols related to the JVM. Strings in a Java .class file are encoded using MUTF-8, strings passed by the JNI, as well as strings exported by the object serializer.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-mutf8/Makefile23
-rw-r--r--devel/py-mutf8/distinfo3
-rw-r--r--devel/py-mutf8/pkg-descr8
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 19ea701c68aa..6953c730b614 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5142,6 +5142,7 @@
SUBDIR += py-multitasking
SUBDIR += py-munch
SUBDIR += py-murmurhash
+ SUBDIR += py-mutf8
SUBDIR += py-mutmut
SUBDIR += py-mygpoclient
SUBDIR += py-mypy
diff --git a/devel/py-mutf8/Makefile b/devel/py-mutf8/Makefile
new file mode 100644
index 000000000000..07b2c204e6fb
--- /dev/null
+++ b/devel/py-mutf8/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= mutf8
+PORTVERSION= 1.0.6
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fast MUTF-8 encoder & decoder
+WWW= https://github.com/TkTech/mutf8
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/devel/py-mutf8/distinfo b/devel/py-mutf8/distinfo
new file mode 100644
index 000000000000..43655a50d614
--- /dev/null
+++ b/devel/py-mutf8/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1720022670
+SHA256 (mutf8-1.0.6.tar.gz) = 1bbbefb67c2e5a57104750bb04b0912200b57b2fa9841be245279e83859cb346
+SIZE (mutf8-1.0.6.tar.gz) = 6424
diff --git a/devel/py-mutf8/pkg-descr b/devel/py-mutf8/pkg-descr
new file mode 100644
index 000000000000..d66dea26d7d6
--- /dev/null
+++ b/devel/py-mutf8/pkg-descr
@@ -0,0 +1,8 @@
+mutf-8 contains simple pure-python as well as C encoders and decoders for the
+MUTF-8 character encoding. In most cases, you can also parse the even-rarer
+CESU-8.
+
+These days, you'll most likely encounter MUTF-8 when working on files or
+protocols related to the JVM. Strings in a Java .class file are encoded using
+MUTF-8, strings passed by the JNI, as well as strings exported by the object
+serializer.