aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-09 13:35:09 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-09 13:37:31 +0000
commit478a4a2f4549f2076c4349cc7930583f1d070291 (patch)
tree2431cfaf30e4f266b500b4d446e79fbb6e035ccf
parent63a303f4b4ed2e580b2a6fbb9ab37c8ffa9a8bd6 (diff)
downloadports-478a4a2f4549f2076c4349cc7930583f1d070291.tar.gz
ports-478a4a2f4549f2076c4349cc7930583f1d070291.zip
devel/ipython: Update to 8.12.0
- Allow concurrent installation (USE_PYTHON=concurrent) - Convert to USE_PYTHON=pep517 Changes: https://github.com/ipython/ipython/blob/main/docs/source/whatsnew/version8.rst https://ipython.readthedocs.io/en/stable/whatsnew/version8.html
-rw-r--r--devel/ipython/Makefile14
-rw-r--r--devel/ipython/distinfo6
2 files changed, 14 insertions, 6 deletions
diff --git a/devel/ipython/Makefile b/devel/ipython/Makefile
index 6395aac89dd0..7dd833b70b57 100644
--- a/devel/ipython/Makefile
+++ b/devel/ipython/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ipython
-DISTVERSION= 8.11.0
+PORTVERSION= 8.12.0
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +11,8 @@ WWW= https://ipython.org/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING.rst
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=51.0.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backcall>=0:devel/py-backcall@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}decorator>=0:devel/py-decorator@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jedi>=0.16:devel/py-jedi@${PY_FLAVOR} \
@@ -24,7 +26,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backcall>=0:devel/py-backcall@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib-inline>0:math/py-matplotlib-inline@${PY_FLAVOR}
USES= cpe python:3.7+
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent pep517
CONFLICTS_INSTALL= py*-ipython5
@@ -34,7 +36,13 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= EXAMPLES
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 31000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR}
+.endif
+
post-install-EXAMPLES-on:
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/ipython/distinfo b/devel/ipython/distinfo
index b1afc87d489e..b5923d75ea11 100644
--- a/devel/ipython/distinfo
+++ b/devel/ipython/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1679904746
-SHA256 (ipython-8.11.0.tar.gz) = 735cede4099dbc903ee540307b9171fbfef4aa75cfcacc5a273b2cda2f02be04
-SIZE (ipython-8.11.0.tar.gz) = 5462176
+TIMESTAMP = 1680726456
+SHA256 (ipython-8.12.0.tar.gz) = a950236df04ad75b5bc7f816f9af3d74dc118fd42f2ff7e80e8e60ca1f182e2d
+SIZE (ipython-8.12.0.tar.gz) = 5465154