aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-10-16 02:26:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-10-16 02:26:21 +0000
commit47dca63ab4b2416a937c06bc800e67c9d3b02c48 (patch)
tree90da46a0a01dcb286ff0c92a1f971734ff116819
parent07e3d7237d336c166bf6ce4a535be1573448fb77 (diff)
downloadports-47dca63ab4b2416a937c06bc800e67c9d3b02c48.tar.gz
ports-47dca63ab4b2416a937c06bc800e67c9d3b02c48.zip
New port: games/volleyball A game similar to GNU Arcade Volleyball
Volleyball is a simple sports game, starring two penguins. Is a two player game, and follows the basic rules of actual Volleyball. Each player hits the ball, trying to reach the opponents field. If the ball touches the floor of the opponents field, the player scores one point. WWW: http://www.losersjuegos.com.ar/juegos/volleyball/volleyball.php PR: ports/87175 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Notes
Notes: svn path=/head/; revision=145494
-rw-r--r--games/Makefile1
-rw-r--r--games/volleyball/Makefile35
-rw-r--r--games/volleyball/distinfo2
-rw-r--r--games/volleyball/pkg-descr9
-rw-r--r--games/volleyball/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 87fa3fd58a7d..0a37e5fba390 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -581,6 +581,7 @@
SUBDIR += vectoroids
SUBDIR += virt
SUBDIR += viruskiller
+ SUBDIR += volleyball
SUBDIR += vor
SUBDIR += wanderer
SUBDIR += wargus
diff --git a/games/volleyball/Makefile b/games/volleyball/Makefile
new file mode 100644
index 000000000000..872427606ce2
--- /dev/null
+++ b/games/volleyball/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: volleyball
+# Date created: 09 Oct 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= volleyball
+PORTVERSION= 0.8
+CATEGORIES= games
+MASTER_SITES= http://www.losersjuegos.com.ar/juegos/volleyball/descargas/
+DISTNAME= ${PORTNAME}20051004
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A game similar to GNU Arcade Volleyball
+
+USE_SDL= sdl
+USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="`${SDL_CONFIG} --cflags` ${CFLAGS}" \
+ LDFLAGS="`${SDL_CONFIG} --libs`"
+ALL_TARGET= volleyball
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/paso_8
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|ima/|${DATADIR}/|' ${WRKSRC}/*.c
+ @${REINPLACE_CMD} -e 's|^\([LDC]*FLAGS\)|#\1|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/volleyball ${PREFIX}/bin/
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ima/* ${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/games/volleyball/distinfo b/games/volleyball/distinfo
new file mode 100644
index 000000000000..ac6b20d1c4a9
--- /dev/null
+++ b/games/volleyball/distinfo
@@ -0,0 +1,2 @@
+MD5 (volleyball20051004.tar.gz) = ecb73928e6102d8a6788a98b7c631495
+SIZE (volleyball20051004.tar.gz) = 366477
diff --git a/games/volleyball/pkg-descr b/games/volleyball/pkg-descr
new file mode 100644
index 000000000000..dd76fc1985c8
--- /dev/null
+++ b/games/volleyball/pkg-descr
@@ -0,0 +1,9 @@
+Volleyball is a simple sports game, starring two penguins. Is a two
+player game, and follows the basic rules of actual Volleyball. Each
+player hits the ball, trying to reach the opponents field. If the
+ball touches the floor of the opponents field, the player scores
+one point.
+
+WWW: http://www.losersjuegos.com.ar/juegos/volleyball/volleyball.php
+
+- Dmitry Marakasov <amdmi3@mail.ru>
diff --git a/games/volleyball/pkg-plist b/games/volleyball/pkg-plist
new file mode 100644
index 000000000000..5ea96c83b797
--- /dev/null
+++ b/games/volleyball/pkg-plist
@@ -0,0 +1,8 @@
+bin/volleyball
+%%DATADIR%%/LICENSE-KIND.FILES
+%%DATADIR%%/fondo.bmp
+%%DATADIR%%/fuente.bmp
+%%DATADIR%%/pelota.bmp
+%%DATADIR%%/personaje_1.bmp
+%%DATADIR%%/personaje_2.bmp
+@dirrm %%DATADIR%%