aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-12-26 22:23:51 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-12-26 22:23:51 +0000
commit481978c0272ec2244f1ae1f0dee3b92dbdafed8e (patch)
treefc5c8e8ddf04302a453d85dc81d88e7b274a79c4
parentcb41009d6cb3f52aebe13ce9c77c14cf97269512 (diff)
downloadports-481978c0272ec2244f1ae1f0dee3b92dbdafed8e.tar.gz
ports-481978c0272ec2244f1ae1f0dee3b92dbdafed8e.zip
sysutils/conky: Update to 1.16.1
- Project now uses ninja
-rw-r--r--sysutils/conky/Makefile4
-rw-r--r--sysutils/conky/distinfo6
-rw-r--r--sysutils/conky/files/patch-src_x11.h16
3 files changed, 21 insertions, 5 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index a3ac017d6d2b..a32033c83f21 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -1,5 +1,5 @@
PORTNAME= conky
-PORTVERSION= 1.15.0
+PORTVERSION= 1.16.1
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
@@ -10,7 +10,7 @@ WWW= https://github.com/brndnmtthws/conky
LIB_DEPENDS= libinotify.so:devel/libinotify
BUILD_DEPENDS= gsed:textproc/gsed
-USES= cpe cmake:noninja compiler:c++11-lib gettext-runtime iconv \
+USES= cpe cmake compiler:c++11-lib gettext-runtime iconv \
localbase lua:52-53 pkgconfig tar:bzip2
CMAKE_ARGS= -DBUILD_PORT_MONITORS:BOOL=false \
diff --git a/sysutils/conky/distinfo b/sysutils/conky/distinfo
index 051644f30c77..a706ee0921c5 100644
--- a/sysutils/conky/distinfo
+++ b/sysutils/conky/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1665942072
-SHA256 (brndnmtthws-conky-v1.15.0_GH0.tar.gz) = bebd54637bf8819ee395b765e3615ad28606d28a7870ac99ed1dffb1d14087b2
-SIZE (brndnmtthws-conky-v1.15.0_GH0.tar.gz) = 1800684
+TIMESTAMP = 1672086732
+SHA256 (brndnmtthws-conky-v1.16.1_GH0.tar.gz) = a293530980bf5ec2250e6d52533cb3426de66c99477ae15430215b3e4b536593
+SIZE (brndnmtthws-conky-v1.16.1_GH0.tar.gz) = 1696411
diff --git a/sysutils/conky/files/patch-src_x11.h b/sysutils/conky/files/patch-src_x11.h
new file mode 100644
index 000000000000..c0a45206d133
--- /dev/null
+++ b/sysutils/conky/files/patch-src_x11.h
@@ -0,0 +1,16 @@
+--- src/x11.h.orig 2022-12-26 18:54:10 UTC
++++ src/x11.h
+@@ -22,6 +22,7 @@
+ *
+ */
+
++#ifdef BUILD_X11
+ #pragma once
+
+ #include <X11/Xatom.h>
+@@ -157,3 +158,5 @@ extern priv::use_xpmdb_setting use_xpmdb;
+ #else
+ extern priv::use_xpmdb_setting use_xpmdb;
+ #endif
++
++#endif /* BUILD_X11 */