aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:04:26 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:04:26 +0000
commit4865fd0cfa6b9092ff102089ee5192760927a8ce (patch)
treef385cc8fe4585a617336d721d3fd929440a96e7d
parent64ffca0b6de477d84898a046ccbe1ed5296f926a (diff)
downloadports-4865fd0cfa6b9092ff102089ee5192760927a8ce.tar.gz
ports-4865fd0cfa6b9092ff102089ee5192760927a8ce.zip
www/py-requests-cache: Convert to USE_PYTHON=pep517
- Clean up RUN_DEPENDS: py-exceptiongroup is not needed anymore after py-cattrs 22.2.0 update - Bump PORTREVISION for dependency and package change
-rw-r--r--www/py-requests-cache/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/www/py-requests-cache/Makefile b/www/py-requests-cache/Makefile
index 8c0817d93674..82f0ec3185c8 100644
--- a/www/py-requests-cache/Makefile
+++ b/www/py-requests-cache/Makefile
@@ -1,5 +1,6 @@
PORTNAME= requests-cache
PORTVERSION= 0.9.6
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,7 @@ WWW= https://github.com/requests-cache/requests-cache
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.4:devel/py-appdirs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}attrs>=21.2:devel/py-attrs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cattrs>=1.8:devel/py-cattrs@${PY_FLAVOR} \
@@ -19,17 +21,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.4:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}urllib3>=1.25.5,1:net/py-urllib3@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 31100
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}exceptiongroup>=1.0.0rc3:devel/py-exceptiongroup@${PY_FLAVOR}
-.endif
-
do-test:
cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>