aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-08-22 17:44:17 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-08-22 17:44:17 +0000
commit4952cf637ae51394337f4ec1c3df17417c171831 (patch)
tree98b98fb2c73a21f08ff9682a33b2584d04de400e
parent84c9db61e287493d33f24c5cb108908f56a801ca (diff)
downloadports-4952cf637ae51394337f4ec1c3df17417c171831.tar.gz
ports-4952cf637ae51394337f4ec1c3df17417c171831.zip
biology/jellyfish: Update to 2.3.0
-rw-r--r--biology/jellyfish/Makefile3
-rw-r--r--biology/jellyfish/distinfo6
-rw-r--r--biology/jellyfish/files/patch-include_jellyfish_hash__counter.hpp11
-rw-r--r--biology/jellyfish/files/patch-sub__commands_count__main.cc11
-rw-r--r--biology/jellyfish/files/patch-sub__commands_merge__main.cc11
-rw-r--r--biology/jellyfish/files/patch-sub__commands_query__main.cc20
6 files changed, 4 insertions, 58 deletions
diff --git a/biology/jellyfish/Makefile b/biology/jellyfish/Makefile
index d84f96e88420..9937ac96c1b2 100644
--- a/biology/jellyfish/Makefile
+++ b/biology/jellyfish/Makefile
@@ -1,7 +1,6 @@
PORTNAME= Jellyfish
DISTVERSIONPREFIX= v
-DISTVERSION= 2.2.10
-PORTREVISION= 9
+DISTVERSION= 2.3.0
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
diff --git a/biology/jellyfish/distinfo b/biology/jellyfish/distinfo
index 9bea24513108..8e77167cbbfa 100644
--- a/biology/jellyfish/distinfo
+++ b/biology/jellyfish/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1557758001
-SHA256 (gmarcais-Jellyfish-v2.2.10_GH0.tar.gz) = 49137356b1cdd014cb70e866f0739fc3fafea6421fa22cc64bcfeba55fc1dc27
-SIZE (gmarcais-Jellyfish-v2.2.10_GH0.tar.gz) = 677009
+TIMESTAMP = 1629646709
+SHA256 (gmarcais-Jellyfish-v2.3.0_GH0.tar.gz) = 23819da9edb579a0cfb8baac9eff473a9477f4f749930cdb754dce1d117495cd
+SIZE (gmarcais-Jellyfish-v2.3.0_GH0.tar.gz) = 679144
diff --git a/biology/jellyfish/files/patch-include_jellyfish_hash__counter.hpp b/biology/jellyfish/files/patch-include_jellyfish_hash__counter.hpp
deleted file mode 100644
index 7410c3edcb71..000000000000
--- a/biology/jellyfish/files/patch-include_jellyfish_hash__counter.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/jellyfish/hash_counter.hpp.orig 2018-04-16 12:46:09 UTC
-+++ include/jellyfish/hash_counter.hpp
-@@ -213,7 +213,7 @@ class hash_counter { (protected)
- new_ary_ = new array(ary_->size(), ary_->key_len(), ary_->val_len() + 1,
- ary_->max_reprobe(), ary_->reprobes());
- }
-- } catch(typename array::ErrorAllocation e) {
-+ } catch(typename array::ErrorAllocation &e) {
- new_ary_ = 0;
- }
- }
diff --git a/biology/jellyfish/files/patch-sub__commands_count__main.cc b/biology/jellyfish/files/patch-sub__commands_count__main.cc
deleted file mode 100644
index b4f2404b6cb2..000000000000
--- a/biology/jellyfish/files/patch-sub__commands_count__main.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- sub_commands/count_main.cc.orig 2018-04-16 12:46:09 UTC
-+++ sub_commands/count_main.cc
-@@ -360,7 +360,7 @@ int count_main(int argc, char *argv[])
- uint64_t max = args.upper_count_given ? args.upper_count_arg : std::numeric_limits<uint64_t>::max();
- try {
- merge_files(files, args.output_arg, header, min, max);
-- } catch(MergeError e) {
-+ } catch(MergeError &e) {
- err::die(err::msg() << e.what());
- }
- if(!args.no_unlink_flag) {
diff --git a/biology/jellyfish/files/patch-sub__commands_merge__main.cc b/biology/jellyfish/files/patch-sub__commands_merge__main.cc
deleted file mode 100644
index 0b331da069ff..000000000000
--- a/biology/jellyfish/files/patch-sub__commands_merge__main.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- sub_commands/merge_main.cc.orig 2019-05-13 07:46:43 UTC
-+++ sub_commands/merge_main.cc
-@@ -33,7 +33,7 @@ int merge_main(int argc, char *argv[])
-
- try {
- merge_files(args.input_arg, args.output_arg, out_header, min, max);
-- } catch(MergeError e) {
-+ } catch(MergeError &e) {
- err::die(err::msg() << e.what());
- }
-
diff --git a/biology/jellyfish/files/patch-sub__commands_query__main.cc b/biology/jellyfish/files/patch-sub__commands_query__main.cc
deleted file mode 100644
index 243b0df29485..000000000000
--- a/biology/jellyfish/files/patch-sub__commands_query__main.cc
+++ /dev/null
@@ -1,20 +0,0 @@
---- sub_commands/query_main.cc.orig 2019-05-13 07:47:53 UTC
-+++ sub_commands/query_main.cc
-@@ -60,7 +60,7 @@ void query_from_cmdline(std::vector<const char*> mers,
- if(canonical)
- m.canonicalize();
- out << m << " " << db.check(m) << "\n";
-- } catch(std::length_error e) {
-+ } catch(std::length_error &e) {
- std::cerr << "Invalid mer '" << *it << "'\n";
- }
- }
-@@ -77,7 +77,7 @@ void query_from_stdin(const Database& db, std::ostream
- if(canonical)
- m.canonicalize();
- out << db.check(m) << std::endl; // a flush is need for interactive use
-- } catch(std::length_error e) {
-+ } catch(std::length_error &e) {
- std::cerr << "Invalid mer '" << buffer << "'" << std::endl;
- }
- }