aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-18 18:35:33 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-18 18:42:45 +0000
commit499a8f4525f35eb8ecbc02accb45f97d418fd15c (patch)
treedd765370193af672ac8c08ec3d57f5b293c157fd
parentb2d30443ea2020da0f6b5d4178332027e7b6a553 (diff)
downloadports-499a8f4525f35eb8ecbc02accb45f97d418fd15c.tar.gz
ports-499a8f4525f35eb8ecbc02accb45f97d418fd15c.zip
science/chemicalfun: New port: C++ library for working with chemical reactions and formulas
-rw-r--r--science/Makefile1
-rw-r--r--science/chemicalfun/Makefile22
-rw-r--r--science/chemicalfun/distinfo3
-rw-r--r--science/chemicalfun/pkg-descr5
-rw-r--r--science/chemicalfun/pkg-plist15
5 files changed, 46 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 7544e8b3641e..ba1d4a70bcf9 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -44,6 +44,7 @@
SUBDIR += cgribex
SUBDIR += checkmol
SUBDIR += chemical-mime-data
+ SUBDIR += chemicalfun
SUBDIR += chemps2
SUBDIR += chemtool
SUBDIR += chemtool-devel
diff --git a/science/chemicalfun/Makefile b/science/chemicalfun/Makefile
new file mode 100644
index 000000000000..82cf71740a37
--- /dev/null
+++ b/science/chemicalfun/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= chemicalfun
+DISTVERSION= g20220104
+CATEGORIES= science # chemistry
+MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${PORTNAME}/get/${BB_COMMIT}${EXTRACT_SUFX}?dummy=/:src
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}:src
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ library for working with chemical reactions and formulas
+
+BUILD_DEPENDS= nlohmann-json>0:devel/nlohmann-json
+
+USES= cmake:testing eigen:3
+
+BB_ACCOUNT= gems4
+BB_COMMIT= dd673f906517
+
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${PORTNAME}-${BB_COMMIT}
+
+CMAKE_OFF= CHEMICALFUN_BUILD_PYTHON
+CMAKE_TESTING_ON= CHEMICALFUN_BUILD_TESTS # tests fail to compile, BitBucket offers no easy way to report this
+
+.include <bsd.port.mk>
diff --git a/science/chemicalfun/distinfo b/science/chemicalfun/distinfo
new file mode 100644
index 000000000000..00b9fb8a00e8
--- /dev/null
+++ b/science/chemicalfun/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1642530020
+SHA256 (chemicalfun-g20220104.tar.gz) = 2944e24ceda906511f7837ae29298d10aee47a0a9440f6955ff4be39899233c8
+SIZE (chemicalfun-g20220104.tar.gz) = 931249
diff --git a/science/chemicalfun/pkg-descr b/science/chemicalfun/pkg-descr
new file mode 100644
index 000000000000..7fcf96a2a48a
--- /dev/null
+++ b/science/chemicalfun/pkg-descr
@@ -0,0 +1,5 @@
+ChemicalFun is a C++ library (Python and C++ API) for generating
+balanced chemical reactions and for parsing and calculating properties
+of chemical formulas.
+
+WWW: https://bitbucket.org/gems4/chemicalfun/src/master/
diff --git a/science/chemicalfun/pkg-plist b/science/chemicalfun/pkg-plist
new file mode 100644
index 000000000000..9423b34945f4
--- /dev/null
+++ b/science/chemicalfun/pkg-plist
@@ -0,0 +1,15 @@
+include/ChemicalFun/FormulaParser.h
+include/ChemicalFun/FormulaParser/ChemicalData.h
+include/ChemicalFun/FormulaParser/ChemicalFormulaParser.h
+include/ChemicalFun/FormulaParser/MoietyParser.h
+include/ChemicalFun/ReactionsGenerator.h
+include/ChemicalFun/ReactionsGenerator/ChemicalReactions.h
+include/ChemicalFun/ReactionsGenerator/Combiner.h
+include/ChemicalFun/ReactionsGenerator/Generator.h
+include/ChemicalFun/ReactionsGenerator/MatrixUtils.h
+include/ChemicalFun/ReactionsGenerator/Reaction.h
+lib/cmake/ChemicalFun/ChemicalFunConfig.cmake
+lib/cmake/ChemicalFun/ChemicalFunConfigVersion.cmake
+lib/cmake/ChemicalFun/ChemicalFunTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/ChemicalFun/ChemicalFunTargets.cmake
+lib/libChemicalFun.so