aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-23 18:18:18 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-23 18:18:18 +0000
commit499cc24aa0fa0736b64d8d66e62f57c8a646539f (patch)
treea1fc11e7e5c81d3ac8af2df2fd57f117ba4de5ec
parent12b52ec3851e108715b9eefa9e40479980474b6a (diff)
graphics/gdal: Update to 3.4.1
- Add PCRE2 option - Change default from PCRE to PCRE2 Changes: https://github.com/OSGeo/gdal/releases https://github.com/OSGeo/gdal/blob/release/3.4/gdal/NEWS.md
-rw-r--r--graphics/gdal/Makefile11
-rw-r--r--graphics/gdal/distinfo6
-rw-r--r--graphics/gdal/pkg-plist2
3 files changed, 11 insertions, 8 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 9a6bdefad331..995f2e0b6d6a 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -1,8 +1,7 @@
# Created by: Randall Hopper
PORTNAME= gdal
-PORTVERSION= 3.3.3
-PORTREVISION= 2
+PORTVERSION= 3.4.1
CATEGORIES= graphics geography
MASTER_SITES= https://download.osgeo.org/gdal/${PORTVERSION}/ \
LOCAL/sunpoet
@@ -23,10 +22,10 @@ LIB_DEPENDS= libgeotiff.so:graphics/libgeotiff \
libqhull.so:math/qhull \
libtiff.so:graphics/tiff
-OPTIONS_DEFINE= ARMADILLO CFITSIO CHARLS CRYPTOPP CURL DEFLATE DODS ECW EXPAT EXR FREEXL GEOS GTA HDF5 HEIF JASPER KML LERC LIBXML2 MYSQL NETCDF ODBC OPENJPEG PCRE PGSQL RASTERLITE2 SFCGAL SPATIALITE SQLITE TILEDB WEBP XERCES ZSTD
+OPTIONS_DEFINE= ARMADILLO CFITSIO CHARLS CRYPTOPP CURL DEFLATE DODS ECW EXPAT EXR FREEXL GEOS GTA HDF5 HEIF JASPER KML LERC LIBXML2 MYSQL NETCDF ODBC OPENJPEG PCRE PCRE2 PGSQL RASTERLITE2 SFCGAL SPATIALITE SQLITE TILEDB WEBP XERCES ZSTD
OPTIONS_RADIO= PDF
OPTIONS_RADIO_PDF= PODOFO POPPLER
-OPTIONS_DEFAULT=CURL EXPAT FREEXL GEOS JASPER LIBXML2 OPENJPEG PCRE PGSQL POPPLER WEBP ZSTD \
+OPTIONS_DEFAULT=CURL EXPAT FREEXL GEOS JASPER LIBXML2 OPENJPEG PCRE2 PGSQL POPPLER WEBP ZSTD \
HDF5 KML NETCDF SPATIALITE SFCGAL SQLITE XERCES
OPTIONS_SUB= yes
CHARLS_DESC= JPEG-Lossless support via charls
@@ -37,6 +36,7 @@ EXR_DESC= EXR support via OpenEXR library
HEIF_DESC= HEIF support via libheif library
LERC_DESC= LERC (Limited Error Raster Compression) support
PCRE_DESC= Regular expression support for SQLite
+PCRE2_DESC= Regular expression support for SQLite
RASTERLITE2_DESC= RasterLite2 support
TILEDB_DESC= TileDB support
@@ -61,6 +61,7 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/share \
--with-proj=yes \
--with-qhull=yes \
--with-threads=yes \
+ --without-jpeg12 \
--without-libtool \
${ICONV_CONFIGURE_ARG}
GNU_CONFIGURE= yes
@@ -150,6 +151,8 @@ OPENJPEG_CONFIGURE_WITH=openjpeg
OPENJPEG_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
PCRE_CONFIGURE_WITH= pcre
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
+PCRE2_CONFIGURE_WITH= pcre2
+PCRE2_LIB_DEPENDS= libpcre2-8.so:devel/pcre2
PGSQL_CONFIGURE_WITH= pg
PGSQL_USES= pgsql
PODOFO_CONFIGURE_WITH= podofo
diff --git a/graphics/gdal/distinfo b/graphics/gdal/distinfo
index 9b83861868d4..78b830b720e5 100644
--- a/graphics/gdal/distinfo
+++ b/graphics/gdal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1635730919
-SHA256 (gdal-3.3.3.tar.xz) = 1e8fc8b19c77238c7f4c27857d04857b65d8b7e8050d3aac256d70fa48a21e76
-SIZE (gdal-3.3.3.tar.xz) = 12946356
+TIMESTAMP = 1642102175
+SHA256 (gdal-3.4.1.tar.xz) = 332f053516ca45101ef0f7fa96309b64242688a8024780a5d93be0230e42173d
+SIZE (gdal-3.4.1.tar.xz) = 13257288
diff --git a/graphics/gdal/pkg-plist b/graphics/gdal/pkg-plist
index 57f29c5df4ea..1313d3a88215 100644
--- a/graphics/gdal/pkg-plist
+++ b/graphics/gdal/pkg-plist
@@ -25,11 +25,11 @@ bin/ogr2ogr
bin/ogrinfo
bin/ogrlineref
bin/ogrtindex
-bin/testepsg
etc/bash_completion.d/gdal-bash-completion.sh
include/cpl_atomic_ops.h
include/cpl_auto_close.h
include/cpl_aws.h
+include/cpl_compressor.h
include/cpl_config.h
include/cpl_config_extras.h
include/cpl_conv.h