aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:02:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:02:33 +0000
commit499f21bf5c98b697eb26322db0198867210330f0 (patch)
tree9885904eee0f5005ad0d9fe961b2bfd5e32b9adc
parent5a910ffd7240e84f53b09a438e73faba3567c424 (diff)
downloadports-499f21bf5c98b697eb26322db0198867210330f0.tar.gz
ports-499f21bf5c98b697eb26322db0198867210330f0.zip
math/py-fraction: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--math/py-fraction/Makefile6
-rw-r--r--math/py-fraction/files/patch-setup.py11
2 files changed, 16 insertions, 1 deletions
diff --git a/math/py-fraction/Makefile b/math/py-fraction/Makefile
index 53623eb711ae..bdad3c75c1e5 100644
--- a/math/py-fraction/Makefile
+++ b/math/py-fraction/Makefile
@@ -1,5 +1,6 @@
PORTNAME= fraction
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= PYPI \
https://github.com/bradley101/fraction/releases/download/${PORTVERSION}/
@@ -13,8 +14,11 @@ WWW= https://github.com/bradley101/fraction
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/math/py-fraction/files/patch-setup.py b/math/py-fraction/files/patch-setup.py
new file mode 100644
index 000000000000..7f8199f859ab
--- /dev/null
+++ b/math/py-fraction/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2022-05-21 10:47:22 UTC
++++ setup.py
+@@ -4,7 +4,7 @@ setuptools.setup(
+ long_description = fh.read()
+
+ setuptools.setup(
+- name="Fraction", # Replace with your own username
++ name="fraction", # Replace with your own username
+ version="2.2.0",
+ author="Shantanu Banerjee",
+ author_email="hi@shantanubanerjee.com",