aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-07-19 09:42:16 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-07-19 09:42:16 +0000
commit49c6d55a5ac2e31e5922029d4f0a17bda94488ba (patch)
tree0a226b5486dc4aac57c5e7b1c4a89faa6b4e1cc1
parent3e1a104b6825136073b39fb291d7f820c29ded3c (diff)
downloadports-49c6d55a5ac2e31e5922029d4f0a17bda94488ba.tar.gz
ports-49c6d55a5ac2e31e5922029d4f0a17bda94488ba.zip
Switch to the new PHP infrastructure.
Notes
Notes: svn path=/head/; revision=114193
-rw-r--r--databases/phppgadmin/Makefile4
-rw-r--r--net-mgmt/jffnms/Makefile3
-rw-r--r--net-mgmt/zabbix/Makefile7
-rw-r--r--net-mgmt/zabbix2/Makefile7
-rw-r--r--net/jffnms/Makefile3
-rw-r--r--sysutils/dtc/Makefile6
-rw-r--r--www/twig/Makefile5
7 files changed, 19 insertions, 16 deletions
diff --git a/databases/phppgadmin/Makefile b/databases/phppgadmin/Makefile
index 91d82a717374..cd37bed7d651 100644
--- a/databases/phppgadmin/Makefile
+++ b/databases/phppgadmin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= phppgadmin
PORTVERSION= 3.4.1
+PORTREVISION= 1
CATEGORIES= databases www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,11 +19,10 @@ COMMENT= Web Based Postgres Administration
USE_REINPLACE= yes
USE_BZIP2= yes
.if !defined(WITHOUT_PHP_DEPENDS)
-USE_PHP= yes
+USE_PHP= ctype imap openssl pgsql pcre posix session tokenizer xml zlib
.endif
WRKSRC= ${WRKDIR}/phpPgAdmin
NO_BUILD= YES
-PHP_PORT?= ${PORTSDIR}/www/mod_php4-twig
PGADMDIR?= www/data/phpPgAdmin
PLIST_SUB+= PGADMDIR=${PGADMDIR}
diff --git a/net-mgmt/jffnms/Makefile b/net-mgmt/jffnms/Makefile
index 7e2befacf954..b53d2927b29d 100644
--- a/net-mgmt/jffnms/Makefile
+++ b/net-mgmt/jffnms/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jffnms
PORTVERSION= 0.7.8
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}
@@ -16,10 +17,10 @@ COMMENT= Very advanced network monitoring and control system
RUN_DEPENDS= neato:${PORTSDIR}/graphics/graphviz \
rrdtool:${PORTSDIR}/net/rrdtool \
- php:${PORTSDIR}/lang/php4-nms \
nmap:${PORTSDIR}/security/nmap \
${LOCALBASE}/sbin/tmpwatch:${PORTSDIR}/sysutils/tmpwatch
+USE_PHP= gd snmp sockets
USE_MYSQL= yes
USE_REINPLACE= yes
diff --git a/net-mgmt/zabbix/Makefile b/net-mgmt/zabbix/Makefile
index 2e5fada87d94..1a77e2ec82d9 100644
--- a/net-mgmt/zabbix/Makefile
+++ b/net-mgmt/zabbix/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zabbix
PORTVERSION= 1.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES?= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -21,17 +22,17 @@ OPTIONS= PGSQL "Use a PostgreSQL backend" off \
FPING "Use fping for pinging hosts" on
.endif
-.include <bsd.port.pre.mk>
-
.ifdef(ZABBIX_AGENT_ONLY)
PKGNAMESUFFIX= -agent
PLIST= ${MASTERDIR}/pkg-plist.agent
PKGMESSAGE= nonexistent
.else # ZABBIX_AGENT_ONLY
LIB_DEPENDS= netsnmp.6:${PORTSDIR}/net-mgmt/net-snmp
-RUN_DEPENDS= php:${PORTSDIR}/lang/php4-nms
+USE_PHP= gd snmp sockets
.endif # ZABBIX_AGENT_ONLY
+.include <bsd.port.pre.mk>
+
.ifndef(WITHOUT_FPING)
RUN_DEPENDS+= ${LOCALBASE}/sbin/fping:${PORTSDIR}/net/fping
.endif
diff --git a/net-mgmt/zabbix2/Makefile b/net-mgmt/zabbix2/Makefile
index 2e5fada87d94..1a77e2ec82d9 100644
--- a/net-mgmt/zabbix2/Makefile
+++ b/net-mgmt/zabbix2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zabbix
PORTVERSION= 1.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES?= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -21,17 +22,17 @@ OPTIONS= PGSQL "Use a PostgreSQL backend" off \
FPING "Use fping for pinging hosts" on
.endif
-.include <bsd.port.pre.mk>
-
.ifdef(ZABBIX_AGENT_ONLY)
PKGNAMESUFFIX= -agent
PLIST= ${MASTERDIR}/pkg-plist.agent
PKGMESSAGE= nonexistent
.else # ZABBIX_AGENT_ONLY
LIB_DEPENDS= netsnmp.6:${PORTSDIR}/net-mgmt/net-snmp
-RUN_DEPENDS= php:${PORTSDIR}/lang/php4-nms
+USE_PHP= gd snmp sockets
.endif # ZABBIX_AGENT_ONLY
+.include <bsd.port.pre.mk>
+
.ifndef(WITHOUT_FPING)
RUN_DEPENDS+= ${LOCALBASE}/sbin/fping:${PORTSDIR}/net/fping
.endif
diff --git a/net/jffnms/Makefile b/net/jffnms/Makefile
index 7e2befacf954..b53d2927b29d 100644
--- a/net/jffnms/Makefile
+++ b/net/jffnms/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jffnms
PORTVERSION= 0.7.8
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}
@@ -16,10 +17,10 @@ COMMENT= Very advanced network monitoring and control system
RUN_DEPENDS= neato:${PORTSDIR}/graphics/graphviz \
rrdtool:${PORTSDIR}/net/rrdtool \
- php:${PORTSDIR}/lang/php4-nms \
nmap:${PORTSDIR}/security/nmap \
${LOCALBASE}/sbin/tmpwatch:${PORTSDIR}/sysutils/tmpwatch
+USE_PHP= gd snmp sockets
USE_MYSQL= yes
USE_REINPLACE= yes
diff --git a/sysutils/dtc/Makefile b/sysutils/dtc/Makefile
index 77e6c30bf0c0..8a910b4adcdc 100644
--- a/sysutils/dtc/Makefile
+++ b/sysutils/dtc/Makefile
@@ -7,20 +7,20 @@
PORTNAME= dtc
PORTVERSION= 0.12.0.6
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.gplhost.com/pub/dtc/bsd/
MAINTAINER= thomas@goirand.fr
COMMENT= A hosting web GUI for admin and accounting apache/named/proftpd/qmail
-RUN_DEPENDS= php:${PHP_PORT} \
- ${LOCALBASE}/share/pear/Crypt/CBC.php:${PORTSDIR}/security/pear-Crypt_CBC \
+RUN_DEPENDS= ${LOCALBASE}/share/pear/Crypt/CBC.php:${PORTSDIR}/security/pear-Crypt_CBC \
${LOCALBASE}/libexec/proftpd:${PORTSDIR}/ftp/proftpd-mysql \
${LOCALBASE}/libexec/apache2/mod_log_sql.so:${PORTSDIR}/www/mod_log_sql2 \
${LOCALBASE}/bin/webalizer:${PORTSDIR}/www/webalizer \
${QMAIL_DIR}/bin/qmail-start:${PORTSDIR}/mail/qmail
-PHP_PORT=${PORTSDIR}/lang/php4-dtc
+USE_PHP= session mysql sockets gd
QMAIL_DIR?= /var/qmail
DTCROOT?= www/dtc
diff --git a/www/twig/Makefile b/www/twig/Makefile
index 92e7fb4eae64..9917ab27484d 100644
--- a/www/twig/Makefile
+++ b/www/twig/Makefile
@@ -7,7 +7,7 @@
PORTNAME= twig
PORTVERSION= 2.7.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www mail
MASTER_SITES= http://www.informationgateway.org/download/
@@ -16,14 +16,13 @@ COMMENT= Web Based Email Client and Scheduler
.if !defined(WITHOUT_PHP_DEPENDS)
.if !defined(WITH_PHP3)
-USE_PHP= yes
+USE_PHP= ctype imap openssl pgsql pcre posix session tokenizer xml zlib
.else
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/${PHP3_PORT}
.endif
.endif
NO_BUILD= YES
-PHP_PORT?= ${PORTSDIR}/www/mod_php4-twig
PHP3_PORT?= www/mod_php3
TWIG?= www/data-dist/twig
PLIST_SUB+= TWIG=${TWIG}