aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2023-02-01 13:30:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2023-02-01 13:31:37 +0000
commit49e0bd1b3f802f330f67f8ad9bedab239cbb9384 (patch)
tree84d05aa14015b97032e2b9897bd2584524f402e9
parent3d8852483c2485abd9c7e3ff408f23465e972b8e (diff)
downloadports-49e0bd1b3f802f330f67f8ad9bedab239cbb9384.tar.gz
ports-49e0bd1b3f802f330f67f8ad9bedab239cbb9384.zip
audio/libgpod: remove wrong dependency on gtk20
This port actually only depends on gdkpixbuf2 While here remove the mono slave ports which is not depended on anymore
-rw-r--r--MOVED1
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libgpod-sharp/Makefile20
-rw-r--r--audio/libgpod-sharp/pkg-plist6
-rw-r--r--audio/libgpod/Makefile15
5 files changed, 3 insertions, 40 deletions
diff --git a/MOVED b/MOVED
index 8f9a662fb316..9cc7f78934b8 100644
--- a/MOVED
+++ b/MOVED
@@ -17763,3 +17763,4 @@ www/webtrees||2023-01-30|Has expired: Uses obsolete PHP version; use www/webtree
x11-toolkits/libsexy||2023-01-30|Depends on EOLed gtk+20, not depended on in the ports tree
x11-toolkits/gtkmathview||2023-01-30|Depends on EOLed gtk+20, not depended on in the ports tree
x11-toolkits/vdk||2023-01-30|Depends on EOLed gtk+20, not depended on in the ports tree
+audio/libgpod-sharp||2023-02-01|Depends on EOLed gtk+20, not depended on in the ports tree
diff --git a/audio/Makefile b/audio/Makefile
index 1c950bfa095b..33114126e27c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -376,7 +376,6 @@
SUBDIR += libgig
SUBDIR += libgme
SUBDIR += libgpod
- SUBDIR += libgpod-sharp
SUBDIR += libgroove
SUBDIR += libid3tag
SUBDIR += libinstpatch
diff --git a/audio/libgpod-sharp/Makefile b/audio/libgpod-sharp/Makefile
deleted file mode 100644
index 24655d544bc5..000000000000
--- a/audio/libgpod-sharp/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-PORTREVISION= 2
-PKGNAMESUFFIX= -sharp
-
-MAINTAINER= mono@FreeBSD.org
-COMMENT= .Net bindings for the libgpod library
-
-RUN_DEPENDS= ${LOCALBASE}/lib/libgpod.so:audio/libgpod
-
-OPTIONS_EXCLUDE=DOCS IMOBILE PYTHON
-OPTIONS_SLAVE= MONO
-
-BUILD_WRKSRC= ${WRKSRC}/bindings/mono
-INSTALL_WRKSRC= ${WRKSRC}/bindings/mono
-
-SLAVE_PORT= yes
-MASTERDIR= ${.CURDIR}/../libgpod
-
-PLIST= ${.CURDIR}/pkg-plist
-
-.include "${MASTERDIR}/Makefile"
diff --git a/audio/libgpod-sharp/pkg-plist b/audio/libgpod-sharp/pkg-plist
deleted file mode 100644
index 9afc3dbf364a..000000000000
--- a/audio/libgpod-sharp/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-lib/libgpod/libgpod-sharp-test.exe
-lib/libgpod/libgpod-sharp-test.exe.mdb
-lib/libgpod/libgpod-sharp.dll
-lib/libgpod/libgpod-sharp.dll.config
-lib/libgpod/libgpod-sharp.dll.mdb
-libdata/pkgconfig/libgpod-sharp.pc
diff --git a/audio/libgpod/Makefile b/audio/libgpod/Makefile
index 6146e0742d8f..a474c6e4e8d1 100644
--- a/audio/libgpod/Makefile
+++ b/audio/libgpod/Makefile
@@ -21,13 +21,12 @@ CONFIGURE_ARGS= --disable-udev --without-hal \
--without-python \
--with-html-dir="${DOCSDIR:H}"
USE_CSTD= gnu89
-USE_GNOME= gdkpixbuf2 gtk20 intltool libxml2
+USE_GNOME= gdkpixbuf2 intltool libxml2
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS IMOBILE MONO
+OPTIONS_DEFINE= DOCS IMOBILE
OPTIONS_DEFAULT=IMOBILE
-OPTIONS_EXCLUDE?= MONO
OPTIONS_SUB= yes
IMOBILE_DESC= Apple iPhone/iPod Touch support
@@ -35,9 +34,6 @@ IMOBILE_DESC= Apple iPhone/iPod Touch support
IMOBILE_LIB_DEPENDS= libimobiledevice-1.0.so:comms/libimobiledevice
IMOBILE_CONFIGURE_WITH= libimobiledevice
-MONO_USE= GNOME=gtksharp20
-MONO_CONFIGURE_WITH= mono
-
PORTDOCS= ChangeLog NEWS README*
.include <bsd.port.options.mk>
@@ -50,16 +46,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|libplist >= 1\.0|libplist-2.0 >= 2.0|g' \
${WRKSRC}/configure
-post-patch-MONO-on:
- @${REINPLACE_CMD} 's/gmcs/mcs/g' ${WRKSRC}/configure ${WRKSRC}/m4/mono.m4
-
-.if ${SLAVE_PORT} == no
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/tools/ipod-time-sync \
${STAGEDIR}${PREFIX}/bin
-.endif
-
-post-install-MONO-off:
@${RM} ${STAGEDIR}${PREFIX}/libdata/pkgconfig/libgpod-sharp.pc
post-install-DOCS-on: