aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-08-15 13:13:57 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-08-15 19:06:03 +0000
commit4c230fed88cc283e954899005d11ed7995f3c05e (patch)
tree99d21c0a00c71dc783026fe01ee4f5deeb7e3857
parentd2b6d58478197fdd64cd53f0da5d0810b36e7a84 (diff)
downloadports-4c230fed88cc283e954899005d11ed7995f3c05e.tar.gz
ports-4c230fed88cc283e954899005d11ed7995f3c05e.zip
KDE: make ecm a build-only dependency in KDE applications
-rw-r--r--deskutils/zanshin/Makefile3
-rw-r--r--devel/kde-dev-scripts/Makefile3
-rw-r--r--devel/kdev-php/Makefile3
-rw-r--r--devel/kdev-python/Makefile3
-rw-r--r--devel/kdevelop/Makefile3
-rw-r--r--devel/kpublictransport/Makefile3
-rw-r--r--devel/poxml/Makefile3
-rw-r--r--graphics/kqtquickcharts/Makefile3
-rw-r--r--graphics/libkdcraw/Makefile4
-rw-r--r--graphics/libkexiv2/Makefile4
-rw-r--r--math/kalk/Makefile3
-rw-r--r--misc/kdeedu-data/Makefile3
-rw-r--r--net/alligator/Makefile3
-rw-r--r--net/kmbox/Makefile3
-rw-r--r--security/keysmith/Makefile3
-rw-r--r--security/kpkpass/Makefile3
16 files changed, 32 insertions, 18 deletions
diff --git a/deskutils/zanshin/Makefile b/deskutils/zanshin/Makefile
index fa8ab8f73b1a..0a943e7ab859 100644
--- a/deskutils/zanshin/Makefile
+++ b/deskutils/zanshin/Makefile
@@ -1,5 +1,6 @@
PORTNAME= zanshin
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +11,7 @@ LIB_DEPENDS= libical.so:devel/libical
USES= cmake compiler:c++14-lang gettext kde:5 qt:5 tar:xz xorg
USE_KDE= akonadi auth bookmarks codecs completion config configwidgets \
- coreaddons crash ecm guiaddons i18n iconthemes itemmodels \
+ coreaddons crash ecm:build guiaddons i18n iconthemes itemmodels \
itemviews jobwidgets kdelibs4support kio notifications package \
parts plasma-framework runner service solid sonnet textwidgets \
unitconversion wallet widgetsaddons windowsystem xmlgui \
diff --git a/devel/kde-dev-scripts/Makefile b/devel/kde-dev-scripts/Makefile
index d18fcb9b6c44..59a873edf281 100644
--- a/devel/kde-dev-scripts/Makefile
+++ b/devel/kde-dev-scripts/Makefile
@@ -1,12 +1,13 @@
PORTNAME= kde-dev-scripts
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE development scripts
USES= cmake kde:5 perl5 python:run qt:5 shebangfix tar:xz
-USE_KDE= doctools ecm
+USE_KDE= doctools ecm:build
USE_QT= buildtools:build qmake:build
SHEBANG_FILES= cxxmetric \
diff --git a/devel/kdev-php/Makefile b/devel/kdev-php/Makefile
index 3ca1b47cd2c2..ecc3422390b1 100644
--- a/devel/kdev-php/Makefile
+++ b/devel/kdev-php/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kdev-php
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +13,7 @@ BUILD_DEPENDS= kdev-pg-qt:devel/kdevelop-pg-qt
LIB_DEPENDS= libKDevPlatformInterfaces.so:devel/kdevelop
USES= cmake compiler:c++11-lib kde:5 qt:5 tar:xz xorg
-USE_KDE= auth codecs completion config configwidgets coreaddons ecm \
+USE_KDE= auth codecs completion config configwidgets coreaddons ecm:build \
i18n itemmodels jobwidgets kcmutils kio parts service solid \
sonnet syntaxhighlighting texteditor textwidgets threadweaver \
widgetsaddons windowsystem xmlgui
diff --git a/devel/kdev-python/Makefile b/devel/kdev-python/Makefile
index 7a1f53e0c562..862f138a6ef0 100644
--- a/devel/kdev-python/Makefile
+++ b/devel/kdev-python/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kdev-python
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +14,7 @@ LIB_DEPENDS= libKDevPlatformInterfaces.so:devel/kdevelop
USES= cmake compiler:c++11-lib kde:5 python qt:5 tar:xz xorg
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
- ecm i18n itemmodels jobwidgets kio newstuff parts service \
+ ecm:build i18n itemmodels jobwidgets kio newstuff parts service \
solid sonnet syntaxhighlighting texteditor textwidgets \
threadweaver widgetsaddons windowsystem xmlgui
USE_QT= concurrent core dbus gui network widgets xml \
diff --git a/devel/kdevelop/Makefile b/devel/kdevelop/Makefile
index 4512811fa2b2..f03faeb72561 100644
--- a/devel/kdevelop/Makefile
+++ b/devel/kdevelop/Makefile
@@ -3,6 +3,7 @@
# devel/kdev-python
PORTNAME= kdevelop
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -40,7 +41,7 @@ SHEBANG_FILES= kdevplatform/util/kdevplatform_shell_environment.sh \
# IDE, which **probably** is used for Qt / KDE development (also
# other things, but let's guess a target market), pull in some
# additional development things that are otherwise build-dep-only.
-USE_KDE+= ecm
+USE_KDE+= ecm:build
USE_QT+= testlib
CMAKE_ARGS= -DCMAKE_POLICY_DEFAULT_CMP0074=NEW \
diff --git a/devel/kpublictransport/Makefile b/devel/kpublictransport/Makefile
index 2f52e01194d9..d46563ecb710 100644
--- a/devel/kpublictransport/Makefile
+++ b/devel/kpublictransport/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kpublictransport
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -8,7 +9,7 @@ COMMENT= Access realtime public transport data
LIB_DEPENDS= libprotobuf.so:devel/protobuf
USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
-USE_KDE= ecm
+USE_KDE= ecm:build
USE_QT= core declarative gui network \
buildtools:build qmake:build
diff --git a/devel/poxml/Makefile b/devel/poxml/Makefile
index 3ae62120ac32..043fdf2882c7 100644
--- a/devel/poxml/Makefile
+++ b/devel/poxml/Makefile
@@ -1,5 +1,6 @@
PORTNAME= poxml
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -7,7 +8,7 @@ COMMENT= Tools to translate Docbook XML using gettext
USES= cmake compiler:c++11-lang gettext-tools:build,run \
kde:5 qt:5 tar:xz
-USE_KDE= doctools ecm
+USE_KDE= doctools ecm:build
USE_QT= core xml \
buildtools:build qmake:build
diff --git a/graphics/kqtquickcharts/Makefile b/graphics/kqtquickcharts/Makefile
index eae5a57e5b99..b5ba703b7934 100644
--- a/graphics/kqtquickcharts/Makefile
+++ b/graphics/kqtquickcharts/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kqtquickcharts
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +11,7 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
-USE_KDE= ecm
+USE_KDE= ecm:build
USE_QT= core declarative network gui \
buildtools:build qmake:build
diff --git a/graphics/libkdcraw/Makefile b/graphics/libkdcraw/Makefile
index fd1ef96bdff3..cc1f8b14beba 100644
--- a/graphics/libkdcraw/Makefile
+++ b/graphics/libkdcraw/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libkdcraw
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -15,7 +15,7 @@ LIB_DEPENDS= libjasper.so:graphics/jasper \
libraw.so:graphics/libraw
USES= cmake compiler:c++11-lang jpeg kde:5 pkgconfig qt:5 tar:xz
-USE_KDE= ecm
+USE_KDE= ecm:build
USE_QT= core gui \
buildtools:build qmake:build
USE_LDCONFIG= yes
diff --git a/graphics/libkexiv2/Makefile b/graphics/libkexiv2/Makefile
index 29347ec6244b..f328ebe1210a 100644
--- a/graphics/libkexiv2/Makefile
+++ b/graphics/libkexiv2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libkexiv2
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +10,7 @@ WWW= https://www.digikam.org/
LIB_DEPENDS= libexiv2.so:graphics/exiv2
USES= cmake compiler:c++11-lang kde:5 pkgconfig qt:5 tar:xz
-USE_KDE= ecm
+USE_KDE= ecm:build
USE_QT= core gui \
buildtools:build qmake:build
USE_LDCONFIG= yes
diff --git a/math/kalk/Makefile b/math/kalk/Makefile
index 08977ecf6651..607afbaf9ade 100644
--- a/math/kalk/Makefile
+++ b/math/kalk/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kalk
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= math kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +13,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr
USES= bison cmake desktop-file-utils kde:5 qt:5 tar:xz
-USE_KDE= config coreaddons ecm i18n kirigami2 unitconversion
+USE_KDE= config coreaddons ecm:build i18n kirigami2 unitconversion
USE_QT= core declarative gui network quickcontrols2 testlib widgets \
buildtools:build qmake:build
diff --git a/misc/kdeedu-data/Makefile b/misc/kdeedu-data/Makefile
index 8c108156d292..823075eac80b 100644
--- a/misc/kdeedu-data/Makefile
+++ b/misc/kdeedu-data/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kdeedu-data
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= misc kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -7,7 +8,7 @@ COMMENT= KDE edu data files
WWW= https://edu.kde.org/applications/all/parley
USES= cmake kde:5 qt:5 tar:xz
-USE_KDE= ecm
+USE_KDE= ecm:build
USE_QT= buildtools:build qmake:build
OPTIONS_DEFINE= DOCS
diff --git a/net/alligator/Makefile b/net/alligator/Makefile
index 0d1d0d22ec6f..72abf94fc128 100644
--- a/net/alligator/Makefile
+++ b/net/alligator/Makefile
@@ -1,5 +1,6 @@
PORTNAME= alligator
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +13,7 @@ BUILD_DEPENDS= kirigami-addons>=0:x11-toolkits/kirigami-addons
RUN_DEPENDS= kirigami-addons>=0:x11-toolkits/kirigami-addons
USES= cmake desktop-file-utils kde:5 qt:5 tar:xz
-USE_KDE= config coreaddons ecm i18n syndication
+USE_KDE= config coreaddons ecm:build i18n syndication
USE_QT= core declarative gui network quickcontrols2 sql testlib \
widgets xml \
buildtools:build qmake:build
diff --git a/net/kmbox/Makefile b/net/kmbox/Makefile
index 085202b96d80..bac654ed70d0 100644
--- a/net/kmbox/Makefile
+++ b/net/kmbox/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kmbox
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -9,7 +10,7 @@ WWW= https://www.kde.org/
LICENSE= LGPL21
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
-USE_KDE= ecm
+USE_KDE= ecm:build
# pim components
USE_KDE+= mime
USE_QT= core gui \
diff --git a/security/keysmith/Makefile b/security/keysmith/Makefile
index 3f3ff6cd90c3..6b16b6995330 100644
--- a/security/keysmith/Makefile
+++ b/security/keysmith/Makefile
@@ -1,5 +1,6 @@
PORTNAME= keysmith
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= security kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsodium.so:security/libsodium
USES= cmake desktop-file-utils gettext kde:5 pkgconfig qt:5 tar:xz xorg
-USE_KDE= dbusaddons ecm i18n kirigami2 windowsystem
+USE_KDE= dbusaddons ecm:build i18n kirigami2 windowsystem
USE_QT= concurrent core dbus declarative gui network quickcontrols2 svg widgets \
buildtools:build qmake:build
USE_XORG= x11
diff --git a/security/kpkpass/Makefile b/security/kpkpass/Makefile
index 76d30f324923..e92171cdb2f6 100644
--- a/security/kpkpass/Makefile
+++ b/security/kpkpass/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kpkpass
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= security kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -8,7 +9,7 @@ WWW= https://www.kde.org/
USES= cmake compiler:c++11-lang gettext kde:5 qt:5 \
shared-mime-info tar:xz
-USE_KDE= archive ecm
+USE_KDE= archive ecm:build
USE_QT= core gui testlib \
buildtools:build qmake:build