aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Osipov <michaelo@FreeBSD.org>2024-07-22 11:24:07 +0000
committerMichael Osipov <michaelo@FreeBSD.org>2024-08-03 15:59:49 +0000
commit4c51f2b5e43071f5a5d7ced87ae2711c3be388a4 (patch)
tree5c5ab6d552b28fa6175a94371d6efd5b126043e0
parent363128c1641bb9b77d2bed74188f624da930f66b (diff)
downloadports-4c51f2b5e43071f5a5d7ced87ae2711c3be388a4.tar.gz
ports-4c51f2b5e43071f5a5d7ced87ae2711c3be388a4.zip
Mk/: Possible values for "ssl" are inconsistent
Co-authored-by: Mathieu Arnold <mat@FreeBSD.org> PR: 278406 Approved by: jrm (mentor), otis (mentor), mat (portmgr) Differential Revision: https://reviews.freebsd.org/D46059
-rw-r--r--Mk/Scripts/qa.sh4
-rw-r--r--Mk/Uses/ssl.mk6
-rw-r--r--Mk/bsd.default-versions.mk4
3 files changed, 11 insertions, 3 deletions
diff --git a/Mk/Scripts/qa.sh b/Mk/Scripts/qa.sh
index 935edf72065e..cc214ec028ee 100644
--- a/Mk/Scripts/qa.sh
+++ b/Mk/Scripts/qa.sh
@@ -623,7 +623,11 @@ proxydeps_suggest_uses() {
elif [ ${pkg} = "devel/readline" ]; then
warn "you need USES+=readline"
# ssl
+ # When updating this, please also update the versions list in
+ # bsd.default-versions.mk and ssl.mk!
elif [ ${pkg} = "security/openssl" -o ${pkg} = "security/openssl111" \
+ -o ${pkg} = "security/openssl31" -o ${pkg} = "security/openssl32" \
+ -o ${pkg} = "security/openssl33" \
-o ${pkg} = "security/libressl" -o ${pkg} = "security/libressl-devel" \
]; then
warn "you need USES=ssl"
diff --git a/Mk/Uses/ssl.mk b/Mk/Uses/ssl.mk
index a8c95e4d9a4d..f8a459eb87e7 100644
--- a/Mk/Uses/ssl.mk
+++ b/Mk/Uses/ssl.mk
@@ -8,8 +8,10 @@
#
# DEFAULT_VERSIONS+= ssl=<openssl variant>
#
-# Variants being base, openssl, openssl30, openssl31, openssl32,
-# openssl-quictls, libressl, and libressl-devel.
+# When updating this, please also update the same list in bsd.default-versions.mk
+# and the checks for USES=ssl in qa.sh!
+# Variants being base, openssl, openssl111, openssl31, openssl32,
+# openssl33, libressl, and libressl-devel.
#
# The Makefile sets these variables:
# OPENSSLBASE - "/usr" or ${LOCALBASE}
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 60fc2628481a..f6aeb2db9dff 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -146,7 +146,9 @@ RUBY_DEFAULT?= 3.2
RUST_DEFAULT?= rust
# Possible values: 4.16, 4.19
SAMBA_DEFAULT?= 4.16
-# Possible values: base, openssl, openssl111, openssl31, openssl32, libressl, libressl-devel
+# When updating this, please also update the same list in ssl.mk and the checks
+# for USES=ssl in qa.sh!
+# Possible values: base, openssl, openssl111, openssl31, openssl32, openssl33, libressl, libressl-devel
. if !defined(SSL_DEFAULT)
# If no preference was set, check for an installed base version
# but give an installed port preference over it.