aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2022-03-08 00:46:33 +0000
committerJason E. Hale <jhale@FreeBSD.org>2022-03-08 00:48:11 +0000
commit4caa00e2142c3c203cce71b7570ce551794bcffd (patch)
tree465c473346363225cd4395c5ee0beb1a4dd55d24
parenteb5c9adba6c99b971b7eb61af7bcb3f5c2388754 (diff)
downloadports-4caa00e2142c3c203cce71b7570ce551794bcffd.tar.gz
ports-4caa00e2142c3c203cce71b7570ce551794bcffd.zip
archivers/libunrar6: Update to 6.1.6
Bump PORTREVISION on sysutils/fusefs-rar2fs which builds against the source.
-rw-r--r--archivers/libunrar6/Makefile2
-rw-r--r--archivers/libunrar6/distinfo6
-rw-r--r--archivers/libunrar6/files/patch-os.hpp4
-rw-r--r--archivers/libunrar6/files/patch-rijndael.cpp28
-rw-r--r--archivers/libunrar6/files/patch-rijndael.hpp6
-rw-r--r--sysutils/fusefs-rar2fs/Makefile2
6 files changed, 24 insertions, 24 deletions
diff --git a/archivers/libunrar6/Makefile b/archivers/libunrar6/Makefile
index 631c3cc273a8..fd40cfa06542 100644
--- a/archivers/libunrar6/Makefile
+++ b/archivers/libunrar6/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libunrar6
-PORTVERSION= 6.0.7
+PORTVERSION= 6.1.6
CATEGORIES= archivers
MASTER_SITES= http://www.rarlab.com/rar/
DISTNAME= unrarsrc-${PORTVERSION}
diff --git a/archivers/libunrar6/distinfo b/archivers/libunrar6/distinfo
index 710e0cc15a1b..4d84265bcb8c 100644
--- a/archivers/libunrar6/distinfo
+++ b/archivers/libunrar6/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1645632381
-SHA256 (unrarsrc-6.0.7.tar.gz) = a7029942006cbcced3f3b7322ec197683f8e7be408972ca08099b196c038f518
-SIZE (unrarsrc-6.0.7.tar.gz) = 232903
+TIMESTAMP = 1646677210
+SHA256 (unrarsrc-6.1.6.tar.gz) = 67f4ab891c062218c2badfaac9c8cab5c8bfd5e96dabfca56c8faa3d209a801d
+SIZE (unrarsrc-6.1.6.tar.gz) = 236651
diff --git a/archivers/libunrar6/files/patch-os.hpp b/archivers/libunrar6/files/patch-os.hpp
index dff506575c08..c0a0c1604907 100644
--- a/archivers/libunrar6/files/patch-os.hpp
+++ b/archivers/libunrar6/files/patch-os.hpp
@@ -1,6 +1,6 @@
---- os.hpp.orig 2017-04-28 17:28:46 UTC
+--- os.hpp.orig 2022-01-24 07:33:18 UTC
+++ os.hpp
-@@ -150,6 +150,10 @@
+@@ -168,6 +168,10 @@
#include <locale.h>
diff --git a/archivers/libunrar6/files/patch-rijndael.cpp b/archivers/libunrar6/files/patch-rijndael.cpp
index 93d60494b85c..19749b3b7403 100644
--- a/archivers/libunrar6/files/patch-rijndael.cpp
+++ b/archivers/libunrar6/files/patch-rijndael.cpp
@@ -1,7 +1,7 @@
---- rijndael.cpp.orig 2018-06-24 15:10:31 UTC
+--- rijndael.cpp.orig 2022-01-24 07:33:18 UTC
+++ rijndael.cpp
-@@ -7,6 +7,8 @@
- ***************************************************************************/
+@@ -3,6 +3,8 @@
+ **************************************************************************/
#include "rar.hpp"
+#ifndef OPENSSL_AES
@@ -9,7 +9,7 @@
#ifdef USE_SSE
#include <wmmintrin.h>
#endif
-@@ -56,6 +58,7 @@ inline void Copy128(byte *dest,const byt
+@@ -75,6 +77,7 @@ inline void Copy128(byte *dest,const byte *src)
#endif
}
@@ -17,12 +17,12 @@
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
// API
-@@ -63,14 +66,41 @@ inline void Copy128(byte *dest,const byt
+@@ -82,14 +85,41 @@ inline void Copy128(byte *dest,const byte *src)
Rijndael::Rijndael()
{
+#ifndef OPENSSL_AES
- if (S[0]==0)
+ if (S5[0]==0)
GenerateTables();
+#endif // OPENSSL_AES
CBCMode = true; // Always true for RAR.
@@ -59,7 +59,7 @@
#ifdef USE_SSE
// Check SSE here instead of constructor, so if object is a part of some
// structure memset'ed before use, this variable is not lost.
-@@ -111,6 +141,7 @@ void Rijndael::Init(bool Encrypt,const b
+@@ -139,6 +169,7 @@ void Rijndael::Init(bool Encrypt,const byte *key,uint
if(!Encrypt)
keyEncToDec();
@@ -67,7 +67,7 @@
}
void Rijndael::blockEncrypt(const byte *input,size_t inputLen,byte *outBuffer)
-@@ -118,6 +149,15 @@ void Rijndael::blockEncrypt(const byte *
+@@ -146,6 +177,15 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
if (inputLen <= 0)
return;
@@ -83,7 +83,7 @@
size_t numBlocks = inputLen/16;
#ifdef USE_SSE
if (AES_NI)
-@@ -176,6 +216,7 @@ void Rijndael::blockEncrypt(const byte *
+@@ -204,6 +244,7 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
input += 16;
}
Copy128(m_initVector,prevBlock);
@@ -91,7 +91,7 @@
}
-@@ -217,6 +258,15 @@ void Rijndael::blockDecrypt(const byte *
+@@ -245,6 +286,15 @@ void Rijndael::blockDecrypt(const byte *input, size_t
if (inputLen <= 0)
return;
@@ -107,7 +107,7 @@
size_t numBlocks=inputLen/16;
#ifdef USE_SSE
if (AES_NI)
-@@ -279,6 +329,8 @@ void Rijndael::blockDecrypt(const byte *
+@@ -307,6 +357,8 @@ void Rijndael::blockDecrypt(const byte *input, size_t
}
memcpy(m_initVector,iv,16);
@@ -116,7 +116,7 @@
}
-@@ -314,7 +366,7 @@ void Rijndael::blockDecryptSSE(const byt
+@@ -342,7 +394,7 @@ void Rijndael::blockDecryptSSE(const byte *input, size
}
#endif
@@ -125,8 +125,8 @@
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
// ALGORITHM
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
-@@ -454,7 +506,7 @@ void Rijndael::GenerateTables()
- U1[b][0]=U2[b][1]=U3[b][2]=U4[b][3]=T5[i][0]=T6[i][1]=T7[i][2]=T8[i][3]=FFmul0e(b);
+@@ -471,7 +523,7 @@ void Rijndael::GenerateTables()
+ U1[b][0]=U2[b][1]=U3[b][2]=U4[b][3]=T5[I][0]=T6[I][1]=T7[I][2]=T8[I][3]=gmul(b,0xe);
}
}
-
diff --git a/archivers/libunrar6/files/patch-rijndael.hpp b/archivers/libunrar6/files/patch-rijndael.hpp
index e85656700db5..3c375833ef8e 100644
--- a/archivers/libunrar6/files/patch-rijndael.hpp
+++ b/archivers/libunrar6/files/patch-rijndael.hpp
@@ -1,6 +1,6 @@
---- rijndael.hpp.orig 2018-06-24 15:10:31 UTC
+--- rijndael.hpp.orig 2022-01-24 07:33:18 UTC
+++ rijndael.hpp
-@@ -16,6 +16,13 @@
+@@ -12,6 +12,13 @@
class Rijndael
{
private:
@@ -14,7 +14,7 @@
#ifdef USE_SSE
void blockEncryptSSE(const byte *input,size_t numBlocks,byte *outBuffer);
void blockDecryptSSE(const byte *input, size_t numBlocks, byte *outBuffer);
-@@ -25,6 +32,7 @@ class Rijndael
+@@ -21,6 +28,7 @@ class Rijndael
void keySched(byte key[_MAX_KEY_COLUMNS][4]);
void keyEncToDec();
void GenerateTables();
diff --git a/sysutils/fusefs-rar2fs/Makefile b/sysutils/fusefs-rar2fs/Makefile
index 054ebdff4044..f45962929338 100644
--- a/sysutils/fusefs-rar2fs/Makefile
+++ b/sysutils/fusefs-rar2fs/Makefile
@@ -1,9 +1,9 @@
# Created by: Joris Vandalon
PORTNAME= rar2fs
-PORTREVISION= 1
DISTVERSION= 1.29.5
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= sysutils
PKGNAMEPREFIX= fusefs-