aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2023-02-13 09:25:51 +0000
committerAlex Dupre <ale@FreeBSD.org>2023-02-13 09:26:33 +0000
commit4cc8205e2faada337e0e7cd2bc7e8c621fdef9f3 (patch)
treed324d84bd1180f5743a2c90f1bf51603b1f03616
parent571600963b17d02667680933349a8f60be1fdb45 (diff)
downloadports-4cc8205e2faada337e0e7cd2bc7e8c621fdef9f3.tar.gz
ports-4cc8205e2faada337e0e7cd2bc7e8c621fdef9f3.zip
lang/solidity: try to fix build on -CURRENT
-rw-r--r--lang/solidity/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index 0b72c964c980..17fe363ea043 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -32,6 +32,10 @@ Z3_CMAKE_OFF= USE_Z3
CVC4_CMAKE_OFF= USE_CVC4
CVC4_BROKEN= solidity uses cvc4 which has been succeeded by cvc5
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+CXXFLAGS= -Wno-unqualified-std-cast-call
+.endif
+
CMAKE_ARGS+= -DUSE_LD_GOLD=OFF -DTESTS=OFF \
-DRANGE_V3_INCLUDE_DIR="${LOCALBASE}/include" \
-DJSONCPP_INCLUDE_DIR:STRING="${LOCALBASE}/include/jsoncpp" \